Ubuntu

CCSM crashes Unity

Reported by Les Lamb on 2011-09-28
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Tim Penhey
unity (Ubuntu)
Undecided
Unassigned

Bug Description

This is the second time this has happened to me, and this time it is on an entirely different machine.

After a fresh install of 11.10 beta 2, followed by an update (Sept. 28, 2011), Unity crashed while I had CompizConfig Settings Manager open. I was not changing any settings when this happened, just clicking around on some of the categories in Compiz.

Restarting does not fix the problem. When Ubuntu loads, Unity launcher is missing completely, and so are the applet icons on the right side of the panel. All that appears are the wallpaper and panel, with the Nautilus menu (File, Edit, etc.) on the left side.

Unity 2D works fine, but Unity 3D will not load, regardless of how many times I restart.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Wed Sep 28 13:48:24 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.881, 3.0.0-11-generic, x86_64: installed
 fglrx, 8.881, 3.0.0-12-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc RV730 PRO [Radeon HD 4650] [1002:9498] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:e109]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
JockeyStatus:
 kmod:fglrx - ATI Fire GL (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Gateway DX4820
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=d6838529-8c63-4362-902e-352d8ab8529a ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/02/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P01-A1
dmi.board.name: EG43M
dmi.board.vendor: Gateway
dmi.chassis.type: 3
dmi.chassis.vendor: Gateway
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP01-A1:bd04/02/2009:svnGateway:pnDX4820:pvr:rvnGateway:rnEG43M:rvr:cvnGateway:ct3:cvr:
dmi.product.name: DX4820
dmi.sys.vendor: Gateway
version.compiz: compiz 1:0.9.6-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Les Lamb (kernelles) wrote :
summary: - Unity 3D broken
+ Unity Broken
description: updated

thank you for reprting the bug to make ubunut better and feel free in the future.

try this one and report us
 sudo apt-get install unity
if any error than attach it.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, when did you upgrade? could you try if downgrading lightdm to the previous version:
https://launchpad.net/ubuntu/+source/lightdm/0.9.7-0ubuntu2
is fixing the issue for you?

Tim Penhey (thumper) wrote :

Yesterday I committed a fix that stopped unity crashing when modifying settings in CCSM. This should be packaged shortly.

summary: - Unity Broken
+ CCSM crashes Unity
Changed in unity:
assignee: nobody → Tim Penhey (thumper)
importance: Undecided → Critical
milestone: none → 4.20.0
status: New → Fix Committed
Les Lamb (kernelles) wrote :

@Tim Penhey Fantastic, Tim! Thanks for making Ubuntu great.

Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Olivier Febwin (febcrash) wrote :

Same problem with a 32 bits version

zemadz (zemadz) wrote :

Bug present with 11.10 32bit final version aswell. Graphics card ATI Mobility Radeon x1400. Also before crashing Unity was lagging and slow, touchpad wouldn't work (works in Ubuntu 2D mode though), on desktop the create launcher in the right click context menu is missing.

Graphic card does support all the needed features. Everything worked in 11.04

DISPLAY=:0.0 /usr/lib/nux/unity_support_test -p
OpenGL vendor string: X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RV515
OpenGL version string: 2.1 Mesa 7.11

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Chad Colgur (colgur) wrote :

Hit this problem with unity 4.22.0-0ubuntu3. Support test data below.

How to recover? Restart was not sufficient as reported in the OP. Tried moving .gconf/apps/compiz*: No dice.

Thanks,
Chad

colgur@chad-D630:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro NVS 135M/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 280.13

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Shaddi Hasan (shaddih) wrote :

Same issue happened to me, unity 4.22.0 and ccsm 0.9.5.92 on an upgrade to 11.10 from 11.04. I noticed that the Unity plugin had been deselected in CCSM; re-selecting it brought back the launcher and panel.

Chad Colgur (colgur) wrote :

Thanks for the tip Shaddi. I tried that procedure along with several others according to an article on TuxGarage (http://www.tuxgarage.com/2011/04/missing-top-and-side-panels-in-unity.html). Sadly, no luck.

I've attached my syslog after cold-start. It looks like gdm is exiting for some reason. Haven't had much luck determining the cause of that one.

A subsequent start from tty1 (sudo service gdm start) reveals a crash in libgconf-2:
[ 652.616891] show_signal_msg: 24 callbacks suppressed
[ 652.616897] at-spi-registry[2002]: segfault at c ip 0030eb99 sp bfd589c0 error 4 in libgconf-2.so.4.1.5[2f9000+2c000]

Not sure how to interpret that one. Any suggestions welcomed.

Thanks,
Chad

bjarkih (bjarkih1977) wrote :

I've been having similar problems, attached is the system message from running "unity --reset-icons"

bjarkih (bjarkih1977) wrote :

I would like to add that I solved my problem by doing "sudo apt-get purge unity" and then "sudo apt-get unity" I'm not sure if it's neccessary to purge but I wanted to be sure, the problem was geting a bit frustrating.

Upgraded to 11.10 with Unity 4.22.0-0ubuntu3 and got the same thing.

Started ccsm and went to Preferences so I could save/export everything as it was, before I looked at changing anything. Before I could even do that though, unity and/or ccsm went crazy and screwed itself. Heaps of disk activity and unity disappeared never to return. Managed to manually get window manager back but no launcher or menu bar. Re-logged-in and got into ccsm and noticed the unity plug-in was now disabled. Tried to enable but found its now clashed with other settings - so I think other settings got changed. But that did get me the launcher and menu bar back. Looking at the ccsm profiles drop-down there is 'Default' but a couple of other entries with un-printable unicode characters. Pretty radical reaction considering I hadn't changed any setting!

The issue says fix released in 4.20.0-0ubuntu1 but multiple people still report the same problem, so I think status need updating.

A bit more info. I am using 11.10 with CCSM 0.9.5.92 with Unity 4.22.0-0ubuntu3, upgraded from 11.04.

- In CCSM, enabling or disabling *any* plug-in will cause Unity to crash and burn. By running Unity myself I can see it is dying with a segmentation fault

- In CSSM, going anywhere near anything on the 'Preferences' screen will causes unity to crash and burn (again segmentation fault). Note you don't need to make any changes, just looking at the backend menu, or clicking on '+' to add a profile, or clicking on export - all these will lead to Unity crashing.

- Changing setting within a plug-in is sometimes ok, Unity may or may not die from that. Lots of strangeness though, e.g. both Gnome Compatibility and Unity bind the 'Alt-F2' action to run commands, and CCSM complains about the clash. However, 'Alt-F2' only actually works to pop-up the Unity run dialog if you have it set to 'Alt-F2' in both plug-ins.

Currently CCSM and Unity seem mutually pretty incompatible. Looks like Unity is unstable under configuration changes.

Adam Benfer (adam-b) wrote :

I have this issue as well.

I've removed CCSM,

I've purged both compiz and unity and re-installed the newest versions and Unity still won't launch for me.

I guess I'm stuck in Unity 2D for the time being. Any help fixing this issue would be appreciated.

Favux (favux-is) wrote :

Same problem here on two machines in Oneiric. Except, in addition to no launcher and the Nautilus menu bar on the top left, I'm not convinced the panel is really there as the rest of it is missing. It actually almost looks like it does when shutting down.

I had opened CCSM on the first machine (Nvidia video) to see if there were any settings I wanted to change when Unity went AWOL. I tried the maneuvers in: http://www.tuxgarage.com/2011/04/missing-top-and-side-panels-in-unity.html to no avail.

I made the mistake on the second machine (AMD video) of opening CCSM so I could compare the settings and attempt to determine what was different. Shortly after I closed CCSM Unity disappeared on this machine too.

Currently using Unity 2D on both. Debating on whether an Oneiric reinstall is worth it at this point.

Adam Benfer (adam-b) wrote :

Actually Favux's link (http://www.tuxgarage.com/2011/04/missing-top-and-side-panels-in-unity.html) fixed my issue. Once I was back in CCSM and re-enabled "Ubuntu Unity Plugin" and then disabled all the conflicts Dash and the Notification bar re-appeared. I don't know why being in CCSM originally caused this but at least I'm not stuck in Unity 2D anymore.

Favux (favux-is) wrote :

That's good Adam. Maybe I'll try again.

But my experience seems to indicate the mere act of opening and closing CCSM changes a (config?) setting somewhere that breaks the Unity plug-in. And resetting both does not fix it.

freethinker (pratikmsinha) wrote :

Renabling Ubuntu Unity Plugin and resolving the conflicts worked for me too. Alternative to resolving conflicts for me was to disable 'Static Application Switcher' plugin might also do the trick, coz thats what the Unity plugin is conflicting with.

Favux (favux-is) wrote :

Thank you Adam and freethinker. That worked for me too on both machines. There were two key binding conflicts with the 'Static Application Switcher' and one with the 'Desktop Wall' plugin. Inconvenient but doable now that I know the magical incantation.

Basically we're following the instructions in Ask Ubuntu here: http://askubuntu.com/questions/63921/unity-3d-doesnt-work-anymore-just-shows-a-menu-on-the-top It turns out all you need to do is log out of your corrupted Unity (ctrl-alt-delete) and switch to Unity 2D and log into it. Then start CCSM and enable the Unity plugin. It will pop up a dialog about Ignore or Resolve conflicts. Choose Resolve conflicts and then select the middle button for each conflict. Then log out of Unity 2D choose Unity and log in to it. It should be back to normal.

Greg Lynch (gregalynch) wrote :

Has the fix actually been sent out via update manager yet? I ran the updates this morning (10/19), but I don't want to install ccsm until I know the fix has gone through. (I had the bug described here with my last install and ended up having to reinstall the OS - don't want to do that again).

Phil Hord (phil-phord) wrote :

I'm seeing the same problems others are reporting here on 11.10 (released) with latest Unity: unity_4.24.0-0ubuntu2b1_amd64.deb

It wasn't clear to me that mods in "Ubuntu 2d" would persist in "Ubuntu", so here's what I did to restore my settings:

1. Create a new user and login as him (Unity works).
2. Report his compiz settings using
     gconftool-2 -R /apps/compiz-1 > working-unity
3. Login as "me" and report my settings:
     gconftool-2 -R /apps/compiz-1 > borked-unity
4. Compare to find the difference:
$ diff borked-unity working-unity
624c624
< launcher_reveal_edge = Left
---
> alt_tab_bias_viewport = false
627c627
< alt_tab_bias_viewport = true
---
> launcher_reveal_edge = Left
955,956c955,956
< run_key = <Alt>F2
< main_menu_key = <Alt>F1
---
> run_key =
> main_menu_key =
1493c1493
< active_plugins = [core,bailer,composite,opengl,vpswitch,snap,compiztoolbox,resize,place,session]
---
> active_plugins = [core,bailer,detection,composite,opengl,decor,vpswitch,grid,snap,move,regex,gnomecompat,compiztoolbox,mousepoll,resize,wall,animation,place,imgpng,workarounds,expo,fade,unitymtgrabhandles,session,scale,ezoom,unityshell]

Maybe this can help someone if they're still trying to debug this issue.

FWIW, I didn't know about "unity --reset". That would have solved my problem. Instead, I found that the "active_plugins" setting was the key. I restored it using this command:

  gconftool-2 --type list --list-type string --set /apps/compiz-1/general/screen0/options/active_plugins "[core,bailer,detection,composite,opengl,decor,vpswitch,grid,snap,move,regex,gnomecompat,compiztoolbox,mousepoll,resize,wall,animation,place,imgpng,workarounds,expo,fade,unitymtgrabhandles,session,scale,ezoom,unityshell]"

And for good measure:

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro NVS 160M/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 280.13

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

$ sudo lshw -c video
  *-display
       description: VGA compatible controller
       product: G98M [Quadro NVS 160M]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f5000000-f5ffffff memory:e0000000-efffffff memory:f2000000-f3ffffff ioport:df00(size=128) memory:f4000000-f401ffff

Hadmut Danisch (hadmut) wrote :

Same problem here with oneiric 64 bit...

Alex Badea (vamposdecampos) wrote :

The preferences crash is probably due to a bug in python-compizconfig; patch coming up shortly.

(before)$ python -c 'import compizconfig; print compizconfig.Context().Profiles'
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
{'0\xbf\xf0\x01': <compizconfig.Profile object at 0x7fb2bf1b7090>, '\x80\xa1\xf0\x01': <compizconfig.Profile object at 0x7fb2bf1b7050>}

(after)$ python -c 'import compizconfig; print compizconfig.Context().Profiles'
Checking if settings need to be migrated ...no
Checking if internal files need to be migrated ...no
Backend : gconf
Integration : true
Profile : unity
Adding plugins
Skipping upgrade com.canonical.unity.unity.01.upgrade
Skipping upgrade com.canonical.unity.unity.02.upgrade
Initializing core options...done
{'unity': <compizconfig.Profile object at 0x7f76d12d0090>}

To post a comment you must log in.