unity-panel-service crashed with SIGSEGV in panel_service_show_entry()

Bug #861144 reported by Ali Aliev on 2011-09-28
42
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Michal Hruby
unity (Ubuntu)
Critical
Michal Hruby

Bug Description

Unity panel crashed

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Это каталог: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,unitymtgrabhandles,place,regex,resize,snap,vpswitch,mousepoll,gnomecompat,grid,move,wall,session,animation,workarounds,expo,fade,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Wed Sep 28 09:28:40 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 280.13, 3.0.0-12-generic, x86_64: installed
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 nVidia Corporation GT218 [GeForce 310M] [10de:0a70] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:396d]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110927)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 kmod:nvidia_current - nvidia_current (Proprietary, Disabled, Not in use)
MachineType: LENOVO 20060
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=88f07f45-41fa-4f53-b704-5a236acda94e ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x409199 <panel_service_show_entry+249>: mov (%r14),%rax
 PC (0x00409199) ok
 source "(%r14)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 panel_service_show_entry ()
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 12/08/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 29CN35WW(V2.12)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Base Board Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr29CN35WW(V2.12):bd12/08/2010:svnLENOVO:pn20060:pvrIdeapadZ560:rvnLENOVO:rnBaseBoardProductName:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 20060
dmi.product.version: Ideapad Z560
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu23
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Ali Aliev (aliev) wrote :

StacktraceTop:
 panel_service_show_entry (self=0x1582000, entry_id=<optimized out>, timestamp=<optimized out>, x=443, y=24, button=1) at /build/buildd/unity-4.18.0/services/panel-service.c:1335
 handle_method_call (connection=<optimized out>, sender=<optimized out>, object_path=<optimized out>, interface_name=<optimized out>, method_name=0x7fdad4281a80 "ShowEntry", parameters=0x232c090, invocation=0x7fdad428e060, user_data=0x1582000) at /build/buildd/unity-4.18.0/services/panel-main.c:184
 call_in_idle_cb (user_data=<optimized out>) at /build/buildd/glib2.0-2.30.0/./gio/gdbusconnection.c:4446
 g_main_dispatch (context=0x149ccf0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
 g_main_context_dispatch (context=0x149ccf0) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
importance: Medium → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: New → Confirmed
Michal Hruby (mhr3) on 2011-11-09
visibility: private → public
Michal Hruby (mhr3) on 2011-11-10
Changed in unity (Ubuntu):
assignee: nobody → Michal Hruby (mhr3)
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
assignee: Michal Hruby (mhr3) → nobody
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Tim Penhey (thumper) on 2011-11-28
Changed in unity:
importance: Undecided → Critical
milestone: none → 5.0.0
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
assignee: nobody → Michal Hruby (mhr3)
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.