run the wrong command if enter is hit before the view is refreshed

Bug #856205 reported by Sebastien Bacher on 2011-09-22
218
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
Unity Distro Priority
Undecided
Unassigned
libunity
Fix Released
High
Neil J. Patel
libunity (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
unity (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
unity-lens-applications (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Using Oneiric beta2, if you do alt-f2, type a command and hit "enter" before the view is refreshed the wrong command is run (i.e it seems to run the previously used and not the one you just typed)

Related branches

Didier Roche (didrocks) on 2011-09-22
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Neil J. Patel (njpatel)
summary: - run the wrong command if enter is hitted before the view is refreshed
+ run the wrong command if enter is hit before the view is refreshed
Didier Roche (didrocks) on 2011-09-22
Changed in unity:
milestone: none → 4.18.0
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Changed in libunity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 4.0.8
status: New → Fix Committed
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in libunity (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 4.0.6-0ubuntu2

---------------
libunity (4.0.6-0ubuntu2) oneiric; urgency=low

  * Backport r85 to make "SearchFinished signals work again", it's needed
    to fix the unity dash activating the wrong entry on enter (lp: #856205)
 -- Sebastien Bacher <email address hidden> Thu, 29 Sep 2011 11:38:25 +0200

Changed in libunity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-29
Changed in libunity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

that's still an issue in 4.20 or the candidate update that didrocks put in the ppa yesterday

Changed in unity (Ubuntu Oneiric):
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.20.0 → 4.24.0
Didier Roche (didrocks) on 2011-10-17
Changed in unity:
milestone: 4.24.0 → 4.26.0

For reference, the similar bug in Unity 2d is tracked on bug #774256

Tim Penhey (thumper) on 2011-11-14
tags: added: udp
Didier Roche (didrocks) on 2011-11-16
Changed in unity-distro-priority:
status: New → Fix Committed
Michal Hruby (mhr3) on 2011-11-16
Changed in unity:
assignee: Neil J. Patel (njpatel) → Michal Hruby (mhr3)
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-12-08
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-lens-applications (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
Changed in unity-lens-applications (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu3

---------------
unity (4.24.0-0ubuntu3) precise; urgency=low

  * Backported fix for lp: #856205
    "run the wrong command if enter is hit before the view is refreshed"
 -- Sebastien Bacher <email address hidden> Mon, 12 Dec 2011 19:38:25 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 0.4.12-0ubuntu3

---------------
unity-lens-applications (0.4.12-0ubuntu3) precise; urgency=low

  * Backport the fix for lp: #856205
    "run the wrong command if enter is hit before the view is refreshed"

  [ Didier Roche ]
  * debian/control:
    - don't dep anymore on zeitgeist-extension-fts. This functionnality
      is now provided by zeitgeist-core which is installed by libzeitgeist.
 -- Sebastien Bacher <email address hidden> Tue, 13 Dec 2011 11:19:09 +0100

Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Changed in unity-lens-applications (Ubuntu Oneiric):
status: Triaged → Fix Committed

Hello Sebastien, or anyone else affected,

Accepted unity-lens-applications into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Hello Sebastien, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Marc Deslauriers (mdeslaur) wrote :

I've tested unity and unity-lens-applications in oneiric -proposed, and can confirm that it fixes the issue for me without any apparent regressions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 0.4.12-0ubuntu2.1

---------------
unity-lens-applications (0.4.12-0ubuntu2.1) oneiric-proposed; urgency=low

  * Backport the fix for lp: #856205
    "run the wrong command if enter is hit before the view is refreshed"
 -- Sebastien Bacher <email address hidden> Tue, 13 Dec 2011 11:39:52 +0100

Changed in unity-lens-applications (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2.1

---------------
unity (4.24.0-0ubuntu2.1) oneiric-proposed; urgency=low

  * Backported fix for lp: #856205
    "run the wrong command if enter is hit before the view is refreshed"
 -- Sebastien Bacher <email address hidden> Mon, 12 Dec 2011 18:48:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
James Cuzella (trinitronx) wrote :

Thanks for fixing this!!! ^_^

Alex Launi (alexlauni) on 2012-01-10
Changed in unity:
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Alex Launi (alexlauni) on 2012-01-10
Changed in unity:
milestone: 4.26.0 → 4.30.0
Didier Roche (didrocks) on 2012-01-10
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity:
milestone: 4.30.0 → none
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu Quantal):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: libunity (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers