compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()

Bug #855252 reported by Bayan Rafeh on 2011-09-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Neil J. Patel
unity (Ubuntu)
Critical
Unassigned

Bug Description

I'm not sure what happened here, Unity crashed directly when I booted and opened the dash. Unity seems to be crashing a lot and this is one of the instances where it does.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Wed Sep 21 08:56:07 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x7ff3c7b6847e <_ZN5unity4dash8LensView13OnResultAddedERKNS0_6ResultE+62>: mov (%rdx,%rax,1),%rbx
 PC (0x7ff3c7b6847e) ok
 source "(%rdx,%rax,1)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rbx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 unity::dash::LensView::OnResultAdded(unity::dash::Result const&) () from /usr/lib/compiz/libunityshell.so
 unity::dash::Results::OnRowAdded(unity::dash::Result&) () from /usr/lib/libunity-core-4.0.so.4
 unity::dash::Model<unity::dash::Result>::OnRowAdded(_DeeModel*, _DeeModelIter*) () from /usr/lib/libunity-core-4.0.so.4
 unity::glib::Signal1<void, _DeeModel*, _DeeModelIter*>::Callback(_DeeModel*, _DeeModelIter*, unity::glib::Signal1<void, _DeeModel*, _DeeModelIter*>*) () from /usr/lib/libunity-core-4.0.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Bayan Rafeh (bayan-rafeh92) wrote :

StacktraceTop:
 unity::dash::LensView::OnResultAdded (this=0x3541a80, result=...) at /build/buildd/unity-4.16.0/plugins/unityshell/src/LensView.cpp:168
 emit (_A_a1=..., impl=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:1010
 emit (_A_a1=..., this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:2781
 unity::dash::Results::OnRowAdded (this=<optimized out>, result=...) at /build/buildd/unity-4.16.0/UnityCore/Results.cpp:36
 emit (_A_a1=..., impl=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:1010

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-09-27
visibility: private → public
Neil J. Patel (njpatel) on 2011-09-27
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
milestone: none → 4.20.0
status: New → In Progress
Changed in unity (Ubuntu):
importance: Medium → Critical
Neil J. Patel (njpatel) on 2011-09-28
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers