(oneiric) dash result expansions don't display icons

Bug #854615 reported by Jane Silber on 2011-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
unity (Ubuntu)
High
Gord Allott

Bug Description

In an up to date (20 Sept) Oneiric beta, none of the "see more results" tags in the dash actually display the icons. I see the same behaviour in
- the app lens with the "see more results" tag on the apps available for download (e.g,. "see 43 more results", but when clicked, no icons displayed)
- the file lens with the "see more results" tag on the "recently downloaded" section (e.g,. "see 29 more results, but when clicked, no icons displayed)

In all cases, the scroll bar behaves as expected (i.e., it shows up), so the results seem to be known, just not displayed.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,vpswitch,mousepoll,grid,snap,imgpng,place,session,move,regex,gnomecompat,unitymtgrabhandles,wall,animation,workarounds,expo,fade,ezoom,scale,unityshell]
CompositorRunning: compiz
Date: Tue Sep 20 11:37:22 2011
DistUpgraded: Log time: 2011-09-07 16:36:15.956610
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:215a]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: LENOVO 5129CTO
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=52f3f8dd-ab0d-4f3b-8cef-9bc54492e659 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-07 (12 days ago)
dmi.bios.date: 09/15/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6QET53WW (1.23 )
dmi.board.name: 5129CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6QET53WW(1.23):bd09/15/2010:svnLENOVO:pn5129CTO:pvrThinkPadX201s:rvnLENOVO:rn5129CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 5129CTO
dmi.product.version: ThinkPad X201s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Jane Silber (silbs) wrote :
Didier Roche (didrocks) on 2011-09-20
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 4.18.0
tags: added: didrocks-oneiric-list
David Barth (dbarth) wrote :

It must be HW specific, since this is working well on my rather old ATI/radeon.

@Jay: can you inspect the Mesa configuration and HW reference.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: nobody → Jay Taoko (jaytaoko)
Jason Smith (jassmith) wrote :

Does the text for the icons show up? What happens when you mouse over?

Jay Taoko (jaytaoko) on 2011-09-23
Changed in unity:
status: Triaged → In Progress
Jason Smith (jassmith) wrote :

Also can you please provide a screenshot if possible

Jay Taoko (jaytaoko) wrote :

It doesn't look like a Mesa issue. All the GPU systems are rendering correctly recently. Also more things wouldn't show it it was a Mesa related issue.
Is it possible to have a screenshot of the issue?

Jane Silber (silbs) wrote :

Text for the icons doesn't show up. Nothing happens if you mouseover. However, if I click in the big open space, it react as if the icon were there (i.e,. launch the Software Center for that app).

Screenshots attached. One shows the "See 44 more" tag, the other shows what happens when clicking on that tag (which also shows the scrollbar, so the dash knows about the apps, just doesn't render the icons).

Jane Silber (silbs) wrote :
Jay Taoko (jaytaoko) wrote :

If the scrollbar shows up but the icons are not visible, there is the possibility that the model hasn't loaded all the icons. There is an asynchronous process going in that case.

David Barth (dbarth) wrote :

Further analysis shows that the bug cannot be reproduced on a similar HW (Jay has the same GPU available in his lab).

This hypothesis is further confirmed by the existence of this other bug https://bugs.launchpad.net/dee/+bug/840758 related to asynchronous results causing crashes in Unity.

Combining the 2 elements, it looks like Gord's fix could apply to your particular problem: https://code.launchpad.net/~gordallott/unity/fix-music-lens-causing-crashers/+merge/76761

Please look for the next point release upload on Monday.

Jay Taoko (jaytaoko) wrote :

I have a similar system. Mine is an intel core i3 while the bug was reported on a core i5 CPU. Both CPUs have the same GPU. I
cannot reproduce the issue so we can rule out a graphics or driver issue.

The issue could be related to the dee model as mentioned in #9.

Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
David Barth (dbarth) wrote :

unity-4.18 was released on Monday.

Could you upgrade and verify whether the issue is still reproducible? Thanks

Changed in unity (Ubuntu):
status: Triaged → In Progress
milestone: none → ubuntu-11.10
Jane Silber (silbs) wrote :

Updated today (27 Sept) and the issue still happens. No change in behaviour from original bug report.

Jay Taoko (jaytaoko) wrote :

When there is nothing in the search entry, what is the behavior? Are icons still hidden when you click to see more results?

Neil J. Patel (njpatel) wrote :

Hi Jane, do the icons/text appear if you scroll (either via grabbing the scrollbar or mouse-wheel)?

Also, I'm in Millbank all next week if we can't figure it out for this week's release, and seems to be something that is going to be easier to debug in front of the offending computer :)

Neil J. Patel (njpatel) wrote :

Okay, I can reproduce this easily by switching to a vertical monitor setup (with the dash/launcher on the bottom monitor) and then following Jane's instructions. Seems like there is a maths error somewhere between Abs Geo and normal Geo.

Gord Allott (gordallott) on 2011-09-28
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Gord Allott (gordallott)
Changed in unity (Ubuntu):
assignee: Jay Taoko (jaytaoko) → Gord Allott (gordallott)
Gord Allott (gordallott) on 2011-09-28
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Jay Taoko (jaytaoko) wrote :

Is the bug still happening with the latest release?

Jane Silber (silbs) wrote :

It now works for me. Thanks!

To post a comment you must log in.