Multi Monitor: Option to hide unity's top panel on the second monitor

Bug #853865 reported by Alex on 2011-09-19
390
This bug affects 108 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Sushmita

Bug Description

Some presentations are given full screen on the second monitor while someone is still working on another screen. Many people use lyricue for example. But the panel is very distractive being always on top, thus making unity unacceptable for presentations.

Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2011-09-19
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: multimonitor
tags: added: bitesize

I experience the unwanted top panel when using LibreOffice Impress with an external projector for the audience view.

It would be helpful to be able to remove the top panel from a secondary monitor, in a similar manner to the way one can now specify that the launcher doesn't appear on a given monitor. This would give a cleaner screen before and after presentations.

When the presentation runs, the presenter view (console) shows on the laptop and the audience sees just the current slide on screen. However, I find that although the slide expands to full screen, the shadow of the now invisible top panel is superimposed on the slide. This is clearly a problem.

If I click within the external display, that shadow disappears from the audience view, and appears on the presenter view. When I click on the presenter view on the laptop screen, the shadow returns to the audience view...

Possibly a separate bug, but would almost certainly be fixed (for the audience view) by implementing this wishlist feature.

ben (roboben) wrote :

Hi guys,

I just want to say that I find it a ultimate neccessary feature to hide the panel on a external monitor. Would love to see this implemented!

thanks,

ben

Matthew Tompsett (matthewbpt) wrote :

I agree this is a issue with Unity that needs to be addressed. I like to use the second monitor to display fullscreen apps (prime example is xbmc on second monitor) and having the top panel unhidable ruins the experience, which is one of the reasons I'm using gnome shell instead of Unity right now. Please fix this!

Daniel van Vugt (vanvugt) wrote :

Neil, you have bug 956863.

Matthew, you have bug 734908.

Unity drawing on top of fullscreen windows is not a feature. It is a bug (or several bugs). So please make sure you are looking at the correct bug.

Samuel Mehrbrodt (sam92) on 2013-02-08
summary: - Should have an option to hide unity's top panel on the second monitor
+ Multi Monitor: Option to hide unity's top panel on the second monitor
Christopher Townsend (townsend) wrote :

This has been fixed and has been available in Raring. Marking as such.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Samuel Mehrbrodt (sam92) wrote :

It has indeed been fixed that the panel is no longer on top of a presentation.
But I think this bug is about adding an option to permanently hide the panel on a monitor.

That would be useful in our use case, where the audience always sees the second monitor whether there is a presentation running or not. We used to have a black background and no panels, so it's "invisible". But that's not possible with Unity at the moment.

Christopher Townsend (townsend) wrote :

@Samuel,

Oh, I see. I came here from a bug that was duplicated to this one (bug #748539) which has been fixed. I'll remark this one as Confirmed and unduplicate that bug since it's not the same.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Joan CiberSheep (cibersheep) wrote :

I use Ubuntu with Unity to project on a canon (a projector) but it's quite annoying (and not so professional) to display the top bar.
It would be interesting to be able to hide it.

relgames (relgames) wrote :

The only solution I have found so far is to not use Unity but switch to gnome-fallback instead.

iBART (mogio) wrote :

I would like to have this option...

Will Cooke (willcooke) on 2015-08-28
Changed in unity:
status: Confirmed → Opinion
Changed in unity (Ubuntu):
status: Confirmed → Opinion

This is not just opinion, this is seriously frustrating.

I'm still having this issue on 15.10. When running presentations at church, the panel appears any time the presentation window loses focus, which is often, as I have to run other applications on the main screen and use menus, etc.

Changed in unity:
status: Opinion → Confirmed
Andrea Azzarone (azzar1) wrote :

Roland this is a bug. If a fullscreen window is the top-most window in its monitor panel should not be shown. Are you using and weird indicator?

Changed in unity (Ubuntu):
status: Opinion → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Sushmita (sush-patil-mita)
jens_we (jens-westphal) wrote :

Hi,

ubuntu 15.10

Yes, i have this bug too, i realy would like to use ubuntus default desktop, but since 5 years this is only half or unfixed

https://bugs.launchpad.net/unity/+bug/899680

https://bugs.launchpad.net/unity/+bug/734908

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/748539

i think unfixed due to the point ubunt does not want the user to hide the top panel on second screen

sorry, but for me this is a blocker, a show stopper as i have to control the output of my presentation screen.

i belive a simple config option like "show top panel only on first monitor" as it exist for the site panel could solve this for anybody and would save livetime of hundred's or thousend's of people facing that problem and mess around it.

The fix with right-click - stay always on top is not enough, and i'm not happy after working a half year with unity that i have to use a diffrent desktop like lxde, cinamon, mate or what ever - caused by such a small thing that should have fixed five years ago.

jens

Kai Mast (kai-mast) wrote :

Why is this still not resolved in wily (16.04)? How can one help to do this?

Is this a limitation of X11? Maybe Mir can handle fullscreen apps better?

philip (philipkigo) wrote :

This problem is so severe. I installed ubuntu with unity after talking everyone into how good ubuntu is, 5 years support and all. Then installed openlp to project church lyrics and the bar was there and there was nothing i could do about it. Luckily i had another usb with opensuse using kde. Opensuse really saved the day. These are the kinds of things that make users flee from ubuntu.

Samuel Mehrbrodt (sam92) wrote :

> Then installed openlp to project church lyrics and the bar was there and there was nothing i could do about it.

OpenLP has an option "Override X server" or similiar which fixes (works around) that problem; at least when the presentation is running.

Of course the bar is still annoying when you have no presentation running.

I been using lot of linux desktops over the last five years and its been really awesome. Across all of them, unity is one which i think that has done tremendous work. Foe me, its like way over the Microsoft windows GUI and its features. For a instance, isn't it that cool that notification which pops up when I connects to wireless network. Awesome guys. I love it.

However, I really like Canonical people considering the request which have continuing on this Bug. I feel its not a bug, but an essential feature for people who need it. When we are in multiple desktops, people expect secondary to have just a display instead of the other bars and etc.

Florian Bach (leseratte10) wrote :

I'm also interested in this feature. This request is open since 6 years and it's still not implemented.

I have multiple monitors on my computer and I usually have some fullscreen applications (like, a video) on one of them. It would be cool if we could configure the top unity bar for each screen independently so I can hide it on one of my screens but still display it on the other two.

Similarly (but this bug report probably isn't the right place for this), it'd be cool to be able to place the Unity launcher on multiple but not all screens. At the moment we can only pick between one screen only or all screens.

ChrisDebenham (chris-debenham) wrote :

Since unity is going away this won't be a problem in the future.
With gnome-shell you can use the multi-monitor extension to control launcher placements etc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers