Dash unmaximize/maximize button is mismatched with actual window size

Bug #852984 reported by Wildjiji on 2011-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Wildjiji
unity (Ubuntu)
Low
Wildjiji

Bug Description

1. make sure the dash is not maximzed
2. logout and login again or restart unity from terminal
3. open dash see the the maximize/unmaximize button.

What happens
its in the state as if dash is maximized

What should happen
when dash is not maximized the button in the panel should show the correct state

=====Patch=====

I fix following patch.

diff -ruN unity-4.16.0.org/plugins/unityshell/src/WindowButtons.cpp unity-4.16.0/plugins/unityshell/src/WindowButtons.cpp
--- unity-4.16.0.org/plugins/unityshell/src/WindowButtons.cpp 2011-09-17 21:46:46.457858075 +0900
+++ unity-4.16.0/plugins/unityshell/src/WindowButtons.cpp 2011-09-18 00:10:23.331318340 +0900
@@ -59,6 +59,7 @@
       _place_hidden_interest(0)
   {
     LoadImages();
+ UpdateDashUnmaximize();
     PanelStyle::GetDefault()->changed.connect(sigc::mem_fun(this, &WindowButton::LoadImages));
     DashSettings::GetDefault()->changed.connect(sigc::mem_fun(this, &WindowButton::UpdateDashUnmaximize));

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu1 [modified: usr/lib/compiz/libunityshell.so]
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,compiztoolbox,decor,place,imgpng,snap,vpswitch,regex,grid,move,session,gnomecompat,mousepoll,resize,animation,wall,animationaddon,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
CurrentDmesg: [ 933.179734] hrtimer: interrupt took 4970768 ns
Date: Sun Sep 18 13:02:57 2011
DistUpgraded: Log time: 2011-06-26 00:04:58.605910
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: vboxguest, 4.1.2, 3.0.0-11-generic, i686: installed
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=7864bbca-c79e-4fb6-9189-4e10e752546c ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-09 (8 days ago)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Wildjiji (wildjiji) wrote :
Omer Akram (om26er) on 2011-09-18
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
status: New → Confirmed
description: updated
Omer Akram (om26er) on 2011-09-18
Changed in unity:
assignee: nobody → Wildjiji (wildjiji)
Changed in unity (Ubuntu):
assignee: nobody → Wildjiji (wildjiji)
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Incomplete → In Progress
Changed in unity (Ubuntu):
status: Incomplete → In Progress
Omer Akram (om26er) wrote :

I tested your branch and it seems it fixes the issue for me here.

Changed in unity:
milestone: none → 4.18.0

Holy Jesus Christ. Remove these f**king buttons already !!! They do NOT belong there. Dash is NOT a window. It's overlay. Are you and your religious astronaut leader retarded ?

Download full text (4.4 KiB)

6205, you should watch your language, is there any document or a rule
around the globe that states only windows can have controls to close
and maximize.? If not please troll else where.

On Sun, Sep 18, 2011 at 6:10 PM, 6205 <email address hidden> wrote:
> Holy Jesus Christ.  Remove these f**king buttons already !!! They do NOT
> belong there. Dash is NOT a window. It's  overlay. Are you and your
> religious astronaut leader retarded ?
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/852984
>
> Title:
>  Dash unmaximize/maximize button is mismatched with actual window size
>
> Status in Unity:
>  In Progress
> Status in “unity” package in Ubuntu:
>  In Progress
>
> Bug description:
>  1. make sure the dash is not maximzed
>  2. logout and login again or restart unity from terminal
>  3. open dash see the the maximize/unmaximize button.
>
>  What happens
>  its in the state as if dash is maximized
>
>  What should happen
>  when dash is not maximized the button in the panel should show the correct state
>
>  =====Patch=====
>
>  I fix following patch.
>
>  diff -ruN unity-4.16.0.org/plugins/unityshell/src/WindowButtons.cpp unity-4.16.0/plugins/unityshell/src/WindowButtons.cpp
>  --- unity-4.16.0.org/plugins/unityshell/src/WindowButtons.cpp   2011-09-17 21:46:46.457858075 +0900
>  +++ unity-4.16.0/plugins/unityshell/src/WindowButtons.cpp       2011-09-18 00:10:23.331318340 +0900
>  @@ -59,6 +59,7 @@
>         _place_hidden_interest(0)
>     {
>       LoadImages();
>  +    UpdateDashUnmaximize();
>       PanelStyle::GetDefault()->changed.connect(sigc::mem_fun(this, &WindowButton::LoadImages));
>       DashSettings::GetDefault()->changed.connect(sigc::mem_fun(this, &WindowButton::UpdateDashUnmaximize));
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: unity 4.16.0-0ubuntu1 [modified: usr/lib/compiz/libunityshell.so]
>  ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
>  Uname: Linux 3.0.0-11-generic i686
>  .tmp.unity.support.test.0:
>
>  ApportVersion: 1.23-0ubuntu1
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,compiztoolbox,decor,place,imgpng,snap,vpswitch,regex,grid,move,session,gnomecompat,mousepoll,resize,animation,wall,animationaddon,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
>  CompositorRunning: compiz
>  CurrentDmesg: [  933.179734] hrtimer: interrupt took 4970768 ns
>  Date: Sun Sep 18 13:02:57 2011
>  DistUpgraded: Log time: 2011-06-26 00:04:58.605910
>  DistroCodename: oneiric
>  DistroVariant: ubuntu
>  DkmsStatus: vboxguest, 4.1.2, 3.0.0-11-generic, i686: installed
>  GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
>  Lsusb:
>   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
>   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
>   Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
>  MachineType: innotek GmbH VirtualBox
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=7864bbca-c79e-4fb...

Read more...

Neil J. Patel (njpatel) on 2011-09-26
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers