Dash Minimize / Maximize / Close buttons are not very pretty

Bug #851313 reported by Rainer Rohde on 2011-09-15
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Not really a bug, but more of an opinion: considering the overall look and feel of Unity and the dash, these three buttons look out of place. Is there any way those could be improved? Maybe some bevel added (similar to the dash icon itself)?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,snap,gnomecompat,move,resize,imgpng,grid,vpswitch,unitymtgrabhandles,regex,place,mousepoll,session,animation,wall,fade,expo,scale,workarounds,ezoom,unityshell]
Date: Thu Sep 15 15:38:10 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64+mac (20110815)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-13 (2 days ago)

Rainer Rohde (rainer-rohde) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Rainer Rohde (rainer-rohde) wrote :

Are there any mockups to show the proposed changes? I am rather curious to see what's planned ...

Joschi Poschi (joschiposchi) wrote :

Why can't the Dash use regular buttons of the used theme? Would make it a lot more consistent. I know themes like 'Adwaita' would be a little bit to big, but for certain themes there could be adjusted buttons. These buttons were the first thing I thought "Yuck, who put these there".

Rainer Rohde (rainer-rohde) wrote :

I think the dash looked far better without those icons before. If minimizing /maximizing the dash is needed, it could be done with a click on the lower right corner or something similar. But those icons really destroy the clean look of the dash imho.

Bilal Shahid (s9iper1) wrote :

the dash is pretty decent and itstoo with out these button of close minimize and maximize.if we should use the shourtcut key instead of these button of minimize /maximize and close so it will be pretty decent..

Märt Põder (boamaod) wrote :

I'd argue for removing of these buttons, because Dash in technically not a window, but a dock or toolbar or something in this vein. It's also problematic, because when user opens Dash, the buttons to close/maximize Dash appear exactly at the same place where were the window buttons (if a window was open). It gives us two levels of window buttons (and Dash is partly transparent, if you remember) and is confusing. For consistency reasons, there shouldn't be window buttons on Dash.

Rainer Rohde (rainer-rohde) wrote :

I personally agree with tabbernuk!

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, those buttons got improved in precise, closing the bug

Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers