Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key shortcut is pressed

Bug #849561 reported by Adolfo Jayme on 2011-09-13
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

When you press Alt+F1 to select an icon from the Launcher by using the keyboard, the currently selected icon is highlighted with a white frame. This do not happen for the first Launcher icon (the BFB).

Related branches

Omer Akram (om26er) wrote :

what does design say on this should navigation start from the first app launcher or should the BFB be highlighted. currently this not good for someone using alt+f1 for the first time under unity as nothing is highlighted

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → 4.18.0
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Omer Akram (om26er) on 2011-09-15
tags: added: oneiric regression-release
John Lea (johnlea) wrote :

This bug is a regression

Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
description: updated
Changed in ayatana-design:
importance: Undecided → High
status: New → Fix Committed
status: Fix Committed → Fix Released
tags: added: onew udo
summary: - Launcher icon for Dash do not highlight on Alt+F1 key shortcut
+ Launcher - Launcher icon for Dash do not highlight on Alt+F1 key
+ shortcut
summary: - Launcher - Launcher icon for Dash do not highlight on Alt+F1 key
- shortcut
+ Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
+ shortcut is pressed
Tim Penhey (thumper) wrote :

What is Alt-F1 supposed to do? Do we have a list of key bindings anywhere?

Adolfo Jayme (fitojb) wrote :

Alt+F1 gives focus to the Launcher to manage it with the keyboard. A (unofficial and for Natty) list of keybindings is available in AskUbuntu.

John Lea (johnlea) wrote :

@fitoschido; another list of keybindings is in the image attached to bug https://bugs.launchpad.net/ayatana-design/+bug/855532 ;-)

Omer Akram (om26er) on 2011-09-24
tags: added: a11y
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Gord Allott (gordallott) on 2011-09-29
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Paul Sladen (sladen) wrote :

The dup attached to this notes a more significant side-effect: pressing Alt-F1 puts things into a mode that is very hard to get out of.

Changed in unity (Ubuntu):
importance: Medium → High
Jason Smith (jassmith) on 2011-10-02
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Jason Smith (jassmith)
importance: Medium → High
Omer Akram (om26er) on 2011-10-02
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Didier Roche (didrocks) on 2011-10-17
Changed in unity:
milestone: 4.24.0 → 4.26.0
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2011-10-28
Changed in unity:
milestone: 4.26.0 → 5.0.0
Tim Penhey (thumper) on 2011-11-21
Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2011-11-21
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) wrote :

@Tim
Since bfb launcher icon is a special icon, how it should be during key nav? Can you pass me a mockup, please?

P.S.: i need one or more new png files but I can ask Rosie for those.

Omer Akram (om26er) wrote :

You might want to have a peek at how its done in unity-2d I don't expect any special treatment for BFB in this case.

Andrea Azzarone (azzar1) wrote :

@Omer, but it's too white? :)

Andrea Azzarone (azzar1) wrote :

sorry... it's too white! :)

Xi Zhu (xi.zhu) wrote :
Xi Zhu (xi.zhu) wrote :
Andrea Azzarone (azzar1) wrote :

What do you think about this (see the attachment)?

Andrea Azzarone (azzar1) wrote :
Andrea Azzarone (azzar1) wrote :
John Lea (johnlea) wrote :

@andyrock; could you attach a screencast of the focus switching between the bfb and the top icon to this bug, thx!

Andrea Azzarone (azzar1) wrote :

@John

John Lea (johnlea) wrote :

Reviewed and signed off by design, thx!

It would be also be good to discuss this bug in Budapest, as there are a couple of asset changes that we might want to play with, but this is easier to do when we are sitting face to face.

Changed in ayatana-design:
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2011-12-06
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.0.0-0ubuntu1

---------------
unity (5.0.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release.
    - compiz crashed with SIGSEGV in __dynamic_cast() (LP: #853038)
    - unity-panel-service crashed with SIGSEGV in panel_service_show_entry()
      (LP: #861144)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() (LP: #869816)
    - Launcher - Launcher icon for Dash does not highlight when the Alt+F1 key
      shortcut is pressed (LP: #849561)
    - compiz crashed with SIGSEGV in unity::PanelTray::FilterTrayCallback()
      (LP: #868868)
    - [regression] Compiz: Visible tearing is worse in 11.10 than 11.04, even
      when "Sync To VBlank" is enabled, but only when Unity is active.
      (LP: #880707)
    - [regression] All apps have a lower frame rate under Unity. (LP: #861061)
    - compiz crashed with SIGSEGV in
      nux::Property<nux::color::Color>::operator=() from
      unity::switcher::SwitcherController::OnBackgroundUpdate() (LP: #887465)
    - DashSearchBarSpinner.cpp:56: Conditional jump or move depends on
      uninitialised value(s) (LP: #901610)
    - quicklist shows in incorrect position when launched from workspace
      switcher (LP: #914251)
    - Build "show me the desktop" mini-app that adds a show desktop button to
      Launcher (LP: #681348)
    - Select quicklist items with just one right click (LP: #688830)
    - cannot change volume by scrolling on the icon when the SoundMenu is
      opened (LP: #722082)
    - [a11y] Unity launcher buttons are not Actionable (LP: #772573)
    - Ubuntu Start launcher item doesn't start dash with keyboard navigation
      (LP: #825037)
    - multimonitor , window management - Multi-Monitor Maximized Difficulty
      (LP: #843958)
    - [regression] Drag and drop inside dash is very slow with Active Blur
      activated (LP: #851172)
    - Activating an alt-tab icon that holds initially unminimized windows
      should unminimize all windows (LP: #854595)
    - Dash - The Dash category headers are positioned incorrectly
      (LP: #839467)
    - Missing global menu with a semi-maximized window dragged to the right.
      (LP: #861279)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - top bar, integrated menu - when a application is first launched, the
      integrated menu should be displayed for 2 seconds before fading out of
      view (LP: #874254)
    - Window control buttons are not shown when an indicator is opened and the
      pointer is over the top-left corner (LP: #890970)
    - Quicklist item using some special chars doesn't show at all
      (LP: #899677)
    - PanelView.cpp:370: Conditional jump or move depends on uninitialised
      value(s) (LP: #901602)
    - unityshell.cpp:1982,1984: Conditional jump or move depends on
      uninitialised value(s) (LP: #901603)
    - Dash Search spinner sometimes doesn't spin at all (LP: #903090)
    - Point of tooltip is misaligned to focused ap...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers