A minimized window 'remains' behind on the desktop if /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows is set to true

Bug #847967 reported by Doug McMahon on 2011-09-12
270
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
X.Org X server
Confirmed
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
High
Sam Spilsbury
xorg-server (Ubuntu)
High
Chris Halse Rogers

Bug Description

Any window minimized to unity launcher remains on the desktop unseen
You cannot interact with the area it occupies other than files on the desktop outside it's area can be D&D into if applicable otherwise they return to position
Minimizing a maximized window can create additional havoc

Xserver patch required: http://lists.x.org/archives/xorg-devel/2011-September/024996.html

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.5.94+bzr2803-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,text,imgpng,compiztoolbox,fade,resize,mousepoll,cube,rotate,gnomecompat,vpswitch,move,scale,regex,expo,place,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Mon Sep 12 11:16:44 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current-updates, 280.13, 3.0.0-10-generic, i686: installed
 nvidia-current-updates, 280.13, 3.0.0-11-generic, i686: installed
GraphicsCard:
 nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0209]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
JockeyStatus:
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current_updates - nvidia_current_updates (Proprietary, Enabled, Not in use)
 kmod:nvidia_current - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
MachineType: Dell Inc. XPS M1330
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=ad432a25-9ac2-4357-9630-7b4a0dc3deb2 ro quiet splash vt.handoff=7
SourcePackage: compiz
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Doug McMahon (mc3man) wrote :
description: updated
Changed in compiz (Ubuntu):
status: New → Confirmed
Zetoke (zetoke) wrote :

Affects me too. Very annoying bug.

Doug McMahon (mc3man) wrote :

I've gone ahead & set that option to false and after a log out/in minimized windows are handled properly
As of a daily on 08/10 that option is set to true by default

summary: - A minimized window 'remains' behind on the desktop
+ A minimized window 'remains' behind on the desktop if
+ /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
+ is set to true
Doug McMahon (mc3man) wrote :

To test in the absence of gconf-editor (not default installed
gconftool-2 -s -t boolean /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows false

Zetoke (zetoke) wrote :

This works for me, thanks.

Sam Spilsbury (smspillaz) wrote :
Changed in xorg-server:
status: New → Confirmed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.16.0
description: updated
Didier Roche (didrocks) on 2011-09-13
affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → High
status: New → In Progress
Didier Roche (didrocks) on 2011-09-13
Changed in xorg-server (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Shanekpiper (shanekpiper) wrote :
Download full text (4.6 KiB)

Brought this over from the bug I reported.

I have noticed over the last few days when I am using Firefox in maximum view and have other application windows open under it, when I minimise it, it leave a ghost trail of about 3 to 4 graphical links in the top left of the screen, this happens on my laptop and my pc at work. One is using the intel GPU and the other NVIDIA, This occurs on both machines so its not related to the hardware but ubuntu 11.10 beta itself.

After FF is minimised other applications are in accessible, clicking on them does nothing, clicking randomly on the laucher sometimes works, and other times some applications are locked and can not be opened again and have to be force quit. super S also locked u, but may display one or 2 windows. It is as though the FF screen is laying over the top like a pain of glass.

I hope my explanation of the bug is understandable, and that other people too are having similar issues.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: xorg 1:7.6+7ubuntu7
ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Sep 13 20:18:23 2011
DistUpgraded: Log time: 2011-09-12 21:34:42.825382
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 280.13, 3.0.0-10-generic, x86_64: installed
 nvidia-current, 280.13, 3.0.0-11-generic, x86_64: installed
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a day
GpuHangReproducibility: Occurs more often under certain circumstances
GpuHangStarted: Within the last few days
GraphicsCard:
 nVidia Corporation G96 [GeForce 9600M GT] [10de:0649] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0145]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Disabled, Not in use)
MachineType: Acer Aspire 8930
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=2528fc89-c646-498d-8dbc-b7c8fa41ec85 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UnitySupp...

Read more...

Omer Akram (om26er) on 2011-09-18
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in xorg-server (Ubuntu):
importance: Undecided → High
Rocko (rockorequin) wrote :

Does that setting even have any effect any more, other than to cause buggy focus behaviour and graphical glitches? Its comment says "Hack to enable minimised windows in switcher" but with it set to false, my minimized windows still appear in the switcher when I press ALT-F4.

Changed in xorg-server (Ubuntu):
milestone: none → ubuntu-11.10-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.10.4-1ubuntu2

---------------
xorg-server (2:1.10.4-1ubuntu2) oneiric; urgency=low

  * debian/patches/221_fix_SendEvent_flag_mask.diff:
    - Add patch from Sam Spilsbury to fix the event mask handling which would
      generate an incorrect BadValue error when a client tries to use SendEvent
      with ShapeNotify. (LP: #847967)
 -- Christopher James Halse Rogers <email address hidden> Mon, 19 Sep 2011 15:18:57 +1000

Changed in xorg-server (Ubuntu):
status: Confirmed → Fix Released
Franck (alci) wrote :

@shanekpiper: Yes. This is behaviour I'm seeing also, and I decided this bug report was corresponding. I hope this is the case :-)

Waiting for xorg-server - 2:1.10.4-1ubuntu2 to show up in my update-manager...

Chris Halse Rogers (raof) wrote :

There's still a Unity/Compiz task before this is fully fixed. You'll still find this happening when you minimise maximised windows, even with the newer X server.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in compiz-core:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.5.96
Doug McMahon (mc3man) wrote :

It may be good to release the unity fix now that the new xorg-server has been releaased and likely installed
The possibilities for bad behavior with just xorg-server upgraded have increased
With the option enabled in the unity plugin still get issues, with it disabled new bad behavior is happening, whether because of no new unity or not, obviously can't tell.
screen shows one ex.
Open thunderbird not maxed, minimize to launcher.
Try to raise Thunderbird from the message indicator, opens transparent.

Even worse if there is another window open on the Ws, then Thunderbird open transparent underneath the other window, havoc results on that workspace

Doug McMahon (mc3man) wrote :

when another window is open - in this case home, trying to close home results in an unresponsive ghost window

Download full text (4.5 KiB)

This is all fixed in trunk unity and compiz-core now.

compiz core revision: 2827, 2830, 2831
unity revision: 1582

On Wed, Sep 21, 2011 at 12:27 AM, Launchpad Bug Tracker
<email address hidden> wrote:
> ** Branch linked: lp:compiz
>
> --
> You received this bug notification because you are a member of Compiz
> Maintainers, which is the registrant for Compiz Core.
> https://bugs.launchpad.net/bugs/847967
>
> Title:
>  A minimized window 'remains' behind on the desktop if
>  /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
>  is set to true
>
> Status in Compiz Core:
>  Fix Committed
> Status in Unity:
>  Fix Committed
> Status in X.Org X server:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Fix Committed
> Status in “xorg-server” package in Ubuntu:
>  Fix Released
>
> Bug description:
>  Any window minimized to unity launcher remains on the desktop unseen
>  You cannot interact with the area it occupies other than  files on the desktop outside it's area can be D&D into if applicable otherwise they return to position
>  Minimizing a maximized window can create additional havoc
>
>  Xserver patch required: http://lists.x.org/archives/xorg-
>  devel/2011-September/024996.html
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: compiz 1:0.9.5.94+bzr2803-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-11.17-generic 3.0.4
>  Uname: Linux 3.0.0-11-generic i686
>  NonfreeKernelModules: nvidia
>  .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
>  .proc.driver.nvidia.registry: Binary: ""
>  .proc.driver.nvidia.version:
>   NVRM version: NVIDIA UNIX x86 Kernel Module  280.13  Wed Jul 27 16:55:43 PDT 2011
>   GCC version:  gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu2)
>  .tmp.unity.support.test.0:
>
>  ApportVersion: 1.22.1-0ubuntu2
>  Architecture: i386
>  CompizPlugins: [core,composite,opengl,decor,text,imgpng,compiztoolbox,fade,resize,mousepoll,cube,rotate,gnomecompat,vpswitch,move,scale,regex,expo,place,unityshell,scaleaddon]
>  CompositorRunning: compiz
>  Date: Mon Sep 12 11:16:44 2011
>  DistUpgraded: Fresh install
>  DistroCodename: oneiric
>  DistroVariant: ubuntu
>  DkmsStatus:
>   nvidia-current-updates, 280.13, 3.0.0-10-generic, i686: installed
>   nvidia-current-updates, 280.13, 3.0.0-11-generic, i686: installed
>  GraphicsCard:
>   nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
>     Subsystem: Dell Device [1028:0209]
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
>  JockeyStatus:
>   kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
>   kmod:nvidia_current_updates - nvidia_current_updates (Proprietary, Enabled, Not in use)
>   kmod:nvidia_current - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
>  MachineType: Dell Inc. XPS M1330
>  PackageArchitecture: all
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=ad432a25-9ac2-4357-9630-7b4a0dc3deb2 ro quiet splash vt.handoff=7
>  SourcePackage: compiz
>  UnitySupportTest: Error: command ['/usr/li...

Read more...

gerstrong (gerstrong) wrote :

nice! Can't wait to see it happen :-)

gerstrong (gerstrong) wrote :

Well, I don't get this bug anymore now. Latest Update Oneiric

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
entonjackson (aj-mysc) wrote :

i still have this problem, when having several windows of one program open and one of them is minimized.
double click on the application in the launcher shows them all up, but the minimized one is invisible.
in ccsm i've set up fixed launcher and smallest icon size, if this helps.
any suggestions?

Changed in compiz-core:
milestone: 0.9.5.96 → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

Fix released in:
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low

Changed in compiz (Ubuntu):
status: New → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
luxiter (luxiter-hotmail) wrote :

i've same issue on gnome-fallback on ubuntu 12.04
Nvidia driver Proprietary driver installed (downloaded from nvidia.com)
System is up to date but i don't use Unity.

To post a comment you must log in.