unity-panel-service crashed with SIGSEGV in g_closure_invoke()

Bug #843280 reported by Stephan on 2011-09-06
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Alejandro Piñeiro
unity (Ubuntu)
High
Alejandro Piñeiro
Oneiric
Undecided
Unassigned

Bug Description

Should be fixed in 4.24. As it was identified as a race condition, ensure you don't get any crash after 5 session restarts.

crash; was using firefox and entering the menu in unity panel. Panel crashes quite often with this WeTab (= tablet PC = ExoPC).

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.12.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Tue Sep 6 23:05:28 2011
Disassembly: => 0x300000002: Cannot access memory at address 0x300000002
DistUpgraded: Log time: 2011-08-11 09:52:35.085248
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: Device [1b0a:00c7]
   Subsystem: Device [1b0a:00c7]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
MachineType: PEGATRON WeTab 3G
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=08d55a1c-acbb-4d21-bf77-b6aff387fadc ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x300000002: Cannot access memory at address 0x300000002
 PC (0x300000002) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-panel-service crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: Upgraded to oneiric on 2011-08-11 (26 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/19/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: Lucid-GE-133
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: WeTab 3G
dmi.board.vendor: PEGATRON
dmi.board.version: 30011285
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 1
dmi.chassis.vendor: PEGATRON
dmi.chassis.version: TT116B01
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrLucid-GE-133:bd11/19/2010:svnPEGATRON:pnWeTab3G:pvrTT116B01:rvnPEGATRON:rnWeTab3G:rvr30011285:cvnPEGATRON:ct1:cvrTT116B01:
dmi.product.name: WeTab 3G
dmi.product.version: TT116B01
dmi.sys.vendor: PEGATRON
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu20
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Stephan (stephan-hoehne) wrote :

StacktraceTop:
 ?? ()
 g_closure_invoke (closure=0x24697a0, return_value=0x0, n_param_values=2, param_values=0x24876a0, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.29.18/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=96, instance=0x22f47d0, emission_return=0x0, instance_and_params=0x24876a0) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3272
 g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=0x7fff9f104888) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3003
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.29.18/./gobject/gsignal.c:3060

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public

Seems to be a problem in connection with Onboard screen keyboard.

2011/9/8 Sebastien Bacher <email address hidden>

> ** Visibility changed to: Public
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/843280
>
> Title:
> unity-panel-service crashed with SIGSEGV in g_closure_invoke()
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/843280/+subscriptions
>

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
importance: Medium → Critical
David Barth (dbarth) wrote :

Can you confirm that the use of a physical keyboard "resolves" the problem? Is there a particular procedure to follow to reproduce the issue with Onboard?

Changed in unity:
assignee: nobody → Alejandro Piñeiro (apinheiro)
Changed in unity (Ubuntu):
assignee: nobody → Alejandro Piñeiro (apinheiro)
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
importance: Critical → High
Changed in unity:
importance: Undecided → High
tags: added: a11y
Changed in unity:
milestone: none → 4.22.0
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Alejandro Piñeiro (apinheiro) wrote :

Hi. I have been testing this bug yesterday and today.

After all this tests, I can conclude that the problem is related with a race condition.

First: the original environment where this bug was detected is not valid. I was only able to reproduce it with a11y enabled, something not suggested on the description of the bug.

Second: I don't see any relation between this bug and onboard.

About why I think that it is related to a race condition:
  * Sometimes just at login the panel-service got stuck on a call to atk_get_root
  * Sometimes it starts fine, but just when you launch orca, if crashes (on that g_closure_invoke)
  * Sometimes it starts fine, and doesn't crash when you launch orca, but crashes when you interact with the panel (ie: logout)
  * Sometimes it works fine, without any problem.

Not sure about the percentage for any of those options, but after all my tests, lets say 20/30/30/20

Recently Neil asked me to make some changes on when the a11y stuff is loaded due bug 817691, also related with race
conditions. At that moment we made just a little change, by moving when the a11y is initialized, in order to keep the changes as small as possible.

Finally, FWIW, need to say that the process of re-launch the panel-service works fine. It can crash or stop, but the new panel-service works fine (also with Orca), so we don't enter on the usual mode of panel-service crashing each time it tries to do something.

Changed in unity:
status: Incomplete → In Progress
Changed in unity (Ubuntu):
status: Incomplete → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
description: updated
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello Stephan, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

The proposed version works fine.
I did not get any crash after 5+ session restarts.

Martin Pitt (pitti) on 2011-10-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.