Dash loses focus after switching windows or desktops

Bug #842466 reported by Jonathan Lange on 2011-09-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Robert Carr
unity (Ubuntu)
Medium
Robert Carr

Bug Description

On my system:
 1. Hit Alt-F2 to open the Dash
 2. Type something to show that it has focus
 3. Hit Ctrl-Alt-Down to switch desktops (or Alt-Tab to switch windows)
 4. The desktop (or window) changes
 5. Try to type something, or try hitting Esc to close the Dash

What you see:
 Although in step 2, the Dash has focus, by step 5, it does not. This means that the Dash cannot be closed by hitting the Esc key. The only way of closing the Dash at that point is to find a part of the screen that it does not cover and then click on it.

What I expect to see:
 To be honest, I was surprised that Alt-Tab or desktop switching keybindings worked while the Dash was open. I guess that's not so much a big deal. Either way, I expect the Dash to keep focus while it's on top of everything.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.12.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,mousepoll,resize,gnomecompat,place,wall,vpswitch,move,regex,snap,session,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Tue Sep 6 10:38:42 2011
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-07-26 (41 days ago)

Jonathan Lange (jml) wrote :
Jonathan Lange (jml) wrote :

Possibly related to bug 830730, bug 739300 and bug 838552.

Omer Akram (om26er) on 2011-09-06
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Kyubutsu (jf) wrote :

"What I expect to see:
 To be honest, I was surprised that Alt-Tab or desktop switching keybindings worked while the Dash was open. I guess that's not so much a big deal. Either way, I expect the Dash to keep focus while it's on top of everything."

first off, dash does keep focus while it's open and correctly disengages when an app takes the focus [by user input].
second, i don't quite see the practical sense in having the dash open WHILE switching workspaces. those are two different functions alright.
furthermore, such thing would probably only work with compositing enabled [unity3D] if at all. and we already past feature freeze anyway.
it is my opinion this should be under WISHLIST and not as a bug.

On Sun, Sep 11, 2011 at 5:05 PM, gnomitsu <email address hidden> wrote:
> "What I expect to see:
>  To be honest, I was surprised that Alt-Tab or desktop switching keybindings worked while the Dash was open. I guess that's not so much a big deal. Either way, I expect the Dash to keep focus while it's on top of everything."
>
> first off, dash does keep focus while it's open and correctly disengages when an app takes the focus [by user input].

It does not correctly disengage. It loses focus, but it stays visible
and on top of everything. This makes the underlying application that
I've switched to be unusable.

> second, i don't quite see the practical sense in having the dash open WHILE switching workspaces. those are two different functions alright.

Uhh... what? If the Dash closed when it was open and I switched
workspaces, that would be great. If it kept focus after I switched
workspaces, that would be great too.

I know they are two different functions. But, at the moment, you can
switch desktops or hit Alt-Tab while the Dash is open, and the Dash
ought to behave sensibly when that happens.

> furthermore, such thing would probably only work with compositing enabled [unity3D] if at all. and we already past feature freeze anyway.
> it is my opinion this should be under WISHLIST and not as a bug.
>

I don't think you've understood the bug report. I am not proposing a
new feature. I'm proposing not having a honking great big
difficult-to-close *thing* covering my desktop and completely
obscuring any keyboard input I might have, just because I accidentally
hit Alt-Tab while the Dash is open.

jml

Omer Akram (om26er) wrote :

this is not an issue with unity from trunk.

Changed in unity:
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Jonathan Lange (jml) wrote :

What version of the Ubuntu package will the fix be in? Would like to test this.

Omer Akram (om26er) wrote :

that would be unity 4.18.0 hopefully on Monday(maybe thursday) though not fully sure. The only case that still not fixed is ctrl+alt+down-arrow as doing that changes the workspace+moves the focus as if you want to navigate with keyboard.

Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 4.18.0
assignee: nobody → Robert Carr (robertcarr)
Changed in unity (Ubuntu):
assignee: nobody → Robert Carr (robertcarr)
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Jonathan Lange (jml) wrote :

I can verify that the fix works. Should a new bug be opened for the C-A-Dn case?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers