run command (alt+F2): results do not contain the exact match

Bug #842108 reported by Paul on 2011-09-05
202
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Michal Hruby
unity-lens-applications
Medium
Michal Hruby
unity (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Test case:
1. Open the run command dialog (Alt + F2)
2. Type in the search field: evolution
   -> When evolution is installed, the results should show the exact match first (evolution), and others later (like evolution-settings)

3. Clear the search field
4. Type in the search field: wine
   -> When wine is installed, the results should show the exact match first (wine) followed by other applications matching the query

===

when using the ´run command´ dialog (ALT + F2) search results are shown real time below. My expectation is that the exact match is also shown in the search results. In some cases the exact match will not be shown.
for example:
"evolutio" will yield the result "evolution" and "evolution-settings"
"evolution" will only yield the result "evolution-settings"
==> although evolution matches exactly the executable file the program is not listed in the results.

"wine" will show several matches starting with wine, but not wine it self. "win" would do.

But in other cases the exact match is displayed:
"gedit" will show the expected result.

My assumption is that the exact match is not shown if more than one match is available. If only one program matches the input, the program is displayed.

lsb_release -rd
Description: Ubuntu oneiric (development branch)
Release: 11.10

Related branches

Robert Roth (evfool) on 2011-09-06
affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Confirmed
James Hunt (jamesodhunt) wrote :

The problem here might be an "off-by-one" bug...

- alt+f2 and type "gvim", I get the results:

gvimdiff
gvimtutor

...whereas on the console command-line, typing "gvim"+TAB we have:

gvim <--- XXX: missing in unity
gvimdiff
gvimtutor

- alt+f2 and type "mumble" I get the results:

mumble-overlay

...whereas on the console command-line, typing "mumble"+TAB we have:

mumble <--- XXX: missing in unity
mumble-overlay

Omer Akram (om26er) on 2011-09-28
Changed in unity:
status: New → Confirmed
Omer Akram (om26er) on 2011-09-28
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Damiön la Bagh (kat-amsterdam) wrote :

Attaching Screenshots of the bug

Damiön la Bagh (kat-amsterdam) wrote :

Here is the screenshot from the terminal showing that the application exists

Damiön la Bagh (kat-amsterdam) wrote :

Workaround is to type one less character and click the program with the mouse

so to open x3270
you would do

alt+F2
x327
Mouse left-click x3270 from the lens (RSI anyone?)

max ulidtko (ulidtko) wrote :

Same with "firefox" command. Highly irritating bug.

Thibault D (thibdrev) wrote :

same with evinc / evince

Omer Akram (om26er) on 2011-11-10
Changed in unity-lens-files (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
David Murrell (david-murrell) wrote :

Fixed with this patch, I think.

--- runner.vala.old 2011-11-12 15:47:54.171325168 +1300
+++ runner.vala 2011-11-12 15:47:26.419187540 +1300
@@ -272,7 +272,7 @@
       {
         foreach (var exec_candidate in this.executables)
         {
- if (exec_candidate.has_prefix (search_string) && exec_candidate != search_string)
+ if (exec_candidate.has_prefix (search_string) )
           {
             executables_match.add (exec_candidate);
           }

I'm not quite sure what the original reasoning was there, but I'm sure it made sense at the time :)

rgrig (radugrigore) wrote :

There is another comparison "!= search_string" above David's patch that makes it fail if someone types "/usr/bin/evince"

Didier Roche (didrocks) on 2011-11-22
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Changed in unity-lens-files:
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

bug #912768 is about the same issue, typing "mumble" leads to mumble not being listed

Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
Changed in unity-lens-applications:
importance: Undecided → Medium
no longer affects: unity-lens-files
no longer affects: unity-lens-files (Ubuntu)
Changed in unity-lens-applications (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Péter Trombitás (trombipeti) wrote :

I think some solution/workaround would be to execute the search_string if it is a command, and if not, then execute the first match. I don't know vala so I don't know how/whether it could be done, but looking at the source code with all my python knowledge - that is not a lot:) - it seems possible.

Péter Trombitás (trombipeti) wrote :

Does this make any sense? I can't test it:P
in runner.vala:
around line 56:
    private Settings gp_settings;
+
+ private bool search_string_executable = false;
around line 246:
      /* complete again system executables */
      else
      {
        foreach (var exec_candidate in this.executables)
        {
          if (exec_candidate.has_prefix (search_string)) // this line is changed as in David's patch
+ {
+ if (exec_candidate != search_string)
+ {
+ executables_match.add (exec_candidate);
+ }
+ else
+ {
+ search_string_executable = true;
+ }
          }
        }
      }
and around line 272:
      // 1. enable launching the exact search string if no other result or if it's executable
      if ((executables_match.size == 0) && (dirs_match.size == 0) || search_string_executable == true))

I don't think that it's a duplicate, since this bug is coded in the
runner.vala file and we know how to get rid of it, but doing so would cause
other problems (if I get everything well:))

2012/3/16 Cinquero <email address hidden>

> Duplicate: https://bugs.launchpad.net/ubuntu/+source/unity-
> 2d/+bug/919320
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (931183).
> https://bugs.launchpad.net/bugs/842108
>
> Title:
> run command (alt+F2): results do not contain the exact match
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/842108/+subscriptions
>

Péter Trombitás (trombipeti) wrote :

Sorry, that _is_ a duplicate, but the bugzilla gnome is not related IMHO.

2012. március 17. 1:46 Trombitás Péter írta, <email address hidden>:

> I don't think that it's a duplicate, since this bug is coded in the
> runner.vala file and we know how to get rid of it, but doing so would cause
> other problems (if I get everything well:))
>
>
> 2012/3/16 Cinquero <email address hidden>
>
>> Duplicate: https://bugs.launchpad.net/ubuntu/+source/unity-
>> 2d/+bug/919320
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (931183).
>> https://bugs.launchpad.net/bugs/842108
>>
>> Title:
>> run command (alt+F2): results do not contain the exact match
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/unity/+bug/842108/+subscriptions
>>
>
>

Didier Roche (didrocks) on 2012-04-13
Changed in unity-lens-applications:
assignee: nobody → Michal Hruby (mhr3)
Didier Roche (didrocks) on 2012-04-24
Changed in unity-lens-applications (Ubuntu Precise):
assignee: Didier Roche (didrocks) → nobody
Michal Hruby (mhr3) on 2012-04-26
Changed in unity-lens-applications:
status: Confirmed → In Progress
milestone: none → 5.12.0
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2012-04-26
Changed in unity:
milestone: none → 5.12.0
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Michal Hruby (mhr3)
status: Confirmed → Fix Committed
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released

Hello Paul, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in unity-lens-applications (Ubuntu Precise):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Paul, or anyone else affected,

Accepted unity-lens-applications into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Everything works fine in the proposed package.

2012/4/27 Martin Pitt <email address hidden>

> Hello Paul, or anyone else affected,
>
> Accepted unity-lens-applications into precise-proposed. The package will
> build now and be available in a few hours. Please test and give feedback
> here. See https://wiki.ubuntu.com/Testing/EnableProposed for
> documentation how to enable and use -proposed. Thank you in advance!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (931183).
> https://bugs.launchpad.net/bugs/842108
>
> Title:
> run command (alt+F2): results do not contain the exact match
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/842108/+subscriptions
>

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.12.0-0ubuntu1

---------------
unity-lens-applications (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Popularity sorting not working correctly (LP: #985495)
    - run command (alt+F2): results do not contain the exact match
      (LP: #842108)
    - [11.0412.04 upgrade] Dash is always empty due to zeitgeist crash:
      Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 11:18:48 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.