task tray icons are misaligned and badly sized

Bug #839354 reported by Rocko on 2011-09-02
92
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

See attached screenshot. This is what my task tray icons look like immediately after login. The skype icon and the battery icon (I've no idea what that one is for - it doesn't response to mouse clicks) are misaligned, and the pidin icon is enormous.

If I close these applications and restart them once unity has loaded, they are correctly sized and aligned.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.12.0-0ubuntu1
Uname: Linux 3.1.0-rc4-git-20110831.1150 x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,vpswitch,text,place,move,mousepoll,regex,compiztoolbox,snap,session,gnomecompat,resize,wall,imgpng,grid,animation,unitymtgrabhandles,expo,ezoom,staticswitcher,workarounds,fade,scale,scaleaddon,unityshell]
Date: Fri Sep 2 15:40:49 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (0 days ago)

Related branches

Rocko (rockorequin) wrote :
Rocko (rockorequin) wrote :

Update: I have to close both Skype *and* pidgin before restarting them returns the icons to normal size. If I just close pidgin, restarting it results in an enormous pidgin icon. When I close both skype and pidgin, the battery icon that does nothing jumps back to normal alignment, and subsequently opening pidgin or skype gives me normal icons.

Changed in unity (Ubuntu):
status: New → Confirmed
Dmitry-Kogura (dmitry-kogura) wrote :

I have this bug too. Icons of applications don't resize to tray size. If size of application icon very big than more small icons duplicated twice. See attachment

Rocko (rockorequin) wrote :

Wow! That's even worse than my icons!

I've found that if I run pidgin first, unity always shows a huge icon. But if I run skype then pidgin, they have correct icon sizes.

Omer Akram (om26er) on 2011-09-04
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.14.0
Roman Kapl (msntfs) wrote :

Another application that is affected by this bug is MeTV.

Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Miloš Jakovljević (milos-sd) wrote :

It is not fixed. Not it is even worst. Now they are always large. :(

can you paste the result of

$ apt-cache policy unity

Dmitry-Kogura (dmitry-kogura) wrote :

I confirm. bug still exists. large icons

apt-cache policy unity
unity:
  Установлен: 4.14.2-0ubuntu1
  Кандидат: 4.14.2-0ubuntu1
  Таблица версий:
 *** 4.14.2-0ubuntu1 0
        500 http://mirror.datacenter.by/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

Rocko (rockorequin) wrote :

I'm still getting the large pidgin icon and misaligned other icons with unity 4.14.2-0ubuntu1 as well. I restarted unity with "unity --replace&disown" to test it.

apt-get cache policy unity gives:
unity:
  Installed: 4.14.2-0ubuntu1
  Candidate: 4.14.2-0ubuntu1
  Version table:
 *** 4.14.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status

At the moment, my giant pidgin icon isn't being drawn at all, but there is a blank space left for it that responds to mouse clicks below the unity bar (ie clicking on or below the bar around there shows the pidgin window). The battery icon to its left has its centre aligned to the bottom of the bar. Everything acting the same as before except that the pidgin icon isn't actually being redrawn.

Dmitry-Kogura (dmitry-kogura) wrote :

Some people wrote here that the bug hasn't been fixed. Why the status is still Fix Released? Will anybody pay attention to the problem? Maybe necessary to open a new issue?

Omer Akram (om26er) wrote :

Sorry, this bug is still there, I can confirm as well.

Changed in unity:
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in unity (Ubuntu):
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
milestone: 4.14.0 → 4.18.0
milestone: 4.18.0 → none
Rocko (rockorequin) wrote :

It *might* now be a timing issue - I always get the huge pidgin icon on first logging in (it's in my startup apps), but if I quit pidgin and restart it, I sometimes get a normal-sized icon now.

Rocko (rockorequin) wrote :

And also worth noting, re the timing issue: I rarely get the skype icon in the systray if I launch it automatically at startup. But launching it once I'm logged in gives me an icon pretty much every time.

There were startup timing issues initially in natty as well - the skype icon used to be a single pixel if you auto-started it.

Rocko (rockorequin) wrote :

Another note: restarting unity with "unity --replace" makes the big pidgin icon re-appear if it was normal size before the restart.

Omer Akram (om26er) on 2011-09-24
tags: added: regression-release

I have this bug as well, visible with some apt-get program, HandBake and the Desura beta.

I know this patch is for a different bug, but the code looks like it might be able to help fix this:
https://code.launchpad.net/~njpatel/unity/fix-panel-tray

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers