Cannot search for some apps in Dash

Bug #837075 reported by Jason Warner on 2011-08-29
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned

Bug Description

This is a general bug, but I will try to be specific.

Dash is not finding all my installed apps. I can't find a pattern as to what it finds and what it doesn't, but here is my specific case now.

I have Shutter installed, but when I type 'Shutt', no results returned. When I type 'Shutter', no results returned. I can launch Shutter from the command line.

This has been happening on-and-off with various apps for a while, but it seems to have gotten worse recently.

Another case is that when I install an app from S-C, I cannot immediately search for it in Dash and launch it. My workaround was to reboot and then Dash would typically find the app.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Tue Aug 30 08:57:28 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
ProcEnviron:
 LC_CTYPE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Jason Warner (jasoncwarner) wrote :
David Barth (dbarth) wrote :

I tried to reproduce the bug, but can get the matching to work here in my dash. If nothing matches, or you have problems getting an app to be seen after an installation, I would look for the processes supposed to work on your system.

You should see:
- zeitgeist-datahub
- /usr/bin/python /usr/bin/zeitgeist-daemon
- /usr/lib/unity-lens-applications/unity-applications-daemon
among other unity related processes.

You should also make sure to have zeitgeist-extension-fts installed and up-to-date (0.0.7-0ubuntu2 is the latest version)

Neil J. Patel (njpatel) on 2011-08-30
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 4.12.0
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-08-31
Changed in unity:
assignee: Neil J. Patel (njpatel) → Mikkel Kamstrup Erlandsen (kamstrup)
Didier Roche (didrocks) on 2011-09-01
Changed in unity:
milestone: 4.12.0 → 4.14.0
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: 4.14.0 → 4.16.0

@Jason: You still see this? I really can't reproduce this.

Jason Warner (jasoncwarner) wrote :

@Mikkel - I haven't had this problem for a bit. I don't know exactly when it started working. Might as well close it if no one can reproduce.

Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Changed in unity:
milestone: 4.18.0 → 4.20.0
Neil J. Patel (njpatel) on 2011-09-29
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers