Ubuntu

Pressing alt on maximized window does show menu but not window controls

Reported by The Fiddler on 2011-08-28
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Brandon Schaefer
unity-2d
Medium
Florian Boucault
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Medium
Unity Community Hackers

Bug Description

Steps to reproduce:
1. open a window and maximize it (e.g. nautilus)
2. move the mouse away from the panel to make the window controls / menu hide
3. press alt

On step 3, the window title will be replaced by the menu (as it should). However, the window controls remain invisible, which is unexpected. Move the mouse over the control area and they will suddenly re-appear to the side of the menu, which feels inconsistent.

Pressing the alt button should behave the same as moving the mouse over the title: both the controls and the menu should appear at the same time.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,imgpng,mousepoll,resize,vpswitch,regex,grid,snap,obs,commands,animation,place,session,expo,unitymtgrabhandles,wall,workarounds,ezoom,fade,scale,unityshell,scaleaddon]
Date: Sun Aug 28 23:51:10 2011
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-08-26 (2 days ago)

The Fiddler (stapostol) wrote :
Paul Sladen (sladen) wrote :

Confirmed; this leads to inconsistent placing of the menus.

Changed in unity (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Omer Akram (om26er) on 2011-09-01
Changed in unity (Ubuntu):
status: Confirmed → New
John Lea (johnlea) on 2011-09-02
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
tags: added: onew udo
Paul Sladen (sladen) wrote :

This probably wants solving more generically per bug #838133.

John: I what's ideal here is that the use of Alt, or Pointer hover *anywhere* on the Top Bar (WM buttons, Menus, Space or Indicators) always causes the full Top Bar (WM buttons, Menus, Space or Indicators) to show.

I've been observing people who manage to hover over the indicators, but still don't see the WM Buttons or menus.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → In Progress
importance: Undecided → Medium
milestone: none → 4.6
assignee: nobody → Florian Boucault (fboucault)
Omer Akram (om26er) on 2011-09-05
tags: added: bitesize
Omer Akram (om26er) on 2011-09-05
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
Paul Sladen (sladen) on 2011-09-05
summary: - Pressing alt on maximized window does shows menu but not window controls
+ Pressing alt on maximized window does show menu but not window controls
Changed in unity-2d:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-09-07
Changed in unity:
assignee: nobody → Unity Community Hackers (unity-community-hackers)
Changed in unity (Ubuntu):
assignee: nobody → Unity Community Hackers (unity-community-hackers)
Didier Roche (didrocks) on 2011-09-08
Changed in unity-2d:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: none → 4.14.0
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: 4.14.0 → 4.16.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.6.1-0ubuntu1

---------------
unity-2d (4.6.1-0ubuntu1) oneiric; urgency=low

  * Fix a segfault due to new unity service backend change.

unity-2d (4.6.0-0ubuntu1) UNRELEASED; urgency=low

  * New upstream release
    - [dash] Apps lens shows no result by default (LP: #834571)
    - Metacity needs command line options to activate capture before unmap and
      compositing without effects (LP: #791205)
    - Bold fonts everywhere in the UI (dash, launcher, workspace switcher) but
      in the panel (LP: #808849)
    - the migration script needs to be run in unity-2d as well (LP: #819733)
    - [dash] "View photos" in the dash launches default image viewer instead
      of shotwell (LP: #822605)
    - Launcher tooltips sometimes leave holes in panel and windows
      (LP: #837277)
    - [dash] Search with non ascii characters fails (LP: #840010)
    - add a configuration key (dconf) to enable the opengl backend
      (LP: #809202)
    - [launcher] when pressing super key shortcuts numbering start at 2
      instead of 1 (LP: #830036)
    - [UIFe] Unity 2D should be using the same BFB icon as Unity (LP: #838829)
    - [launcher] trash icon needs to be the same as in Unity 3D (LP: #840025)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - [dash] DropShadow on "See X more results" can cause visual errors on
      scroll (LP: #843820)
    - Dash - In the App lens filters, users should only be able filter by
      'star' rating in one star increments (LP: #839759)
    - Emptying the trash from the unity sidebar should respect nautilus' "Ask
      before emptying" setting (LP: #730003)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
  * debian/control:
    - rebuild against current nux and unity (API change)
 -- Didier Roche <email address hidden> Fri, 09 Sep 2011 13:50:22 +0200

Changed in unity-2d (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0

The problem is fixed in my branch for unity.

Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Jason Smith (jassmith) on 2011-09-22
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 4.18.0-0ubuntu1

---------------
unity (4.18.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Screen corruption when resuming from suspend/hibernate (LP: #676166)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #764024)
    - Dash and launcher appear underneath windows (LP: #805087)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #811401)
    - [Oneric] unity-panel-service crashed with SIGSEGV in getenv()
      (LP: #817691)
    - compiz crashed with SIGSEGV in unity::FilterBar::RemoveFilter()
      (LP: #845732)
    - crash on closing a window (LP: #856015)
    - Cannot open a window that starts iconified (LP: #732997)
    - Launcher - When useing Alt F1 launcher keyboard navigation, Launcher
      should not scroll until top or bottom of Launcher is reached
      (LP: #765749)
    - Stacking problem when switching between apps with multiple windows
      (LP: #802527)
    - Pull panel to de-maximize window occasionally not working in a secondary
      screen (LP: #802651)
    - Window under Dash gets focused if it opened later (LP: #830730)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/show_minimized_windows
      is set to true (LP: #847967)
    - a11y support on Unity is broken (LP: #851103)
    - compiz crashed with SIGSEGV in dee_model_get_tag() (LP: #840758)
    - crash when looping paint list in preparePaint (on closing windows)
      (LP: #853807)
    - Alt-Tab should not preview windows at excessively large sizes
      (LP: #854740)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - Dragging a launcher icon makes it squashed (LP: #855761)
    - unable to unminimize gedit windows where more than one window where one
      has a dialog open (LP: #856030)
    - (oneiric) alt-tab UX doesn't work well on multi-monitor (LP: #855364)
    - Launcher shows on the primary monitor instead of the left most monitor
      (LP: #857668)
    - Keynav - pressing down key causes launcher items to jump up and down
      (LP: #858469)
    - Windows creep cross the screen with ALT+TAB (LP: #722830)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - All unity windows are invisible (panel, launcher, dash) (LP: #745996)
    - Dash "See 97 more results" has ~1 second of latency (LP: #731158)
    - Windows cannot be dragged down from panel if banshee closed to sound
      menu (LP: #781215)
    - no menu bar on top, compositing bug? (LP: #806358)
    - Launcher - a spread can accidentally be triggered during the 'dragging
      and dropping behind the Launcher' interaction (LP: #832988)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - Pressing alt on maximized window does show menu but not window controls
      (LP: #836274)
    - Application name drawn under Dash controls when window opens under Dash
      (LP: #838176)
    - Start ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-03
tags: added: reviewedbydesigno
removed: udo
Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers