New Unity Alt-Tab switcher window is slow to appear

Bug #836023 reported by The Fiddler on 2011-08-28
250
This bug affects 58 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
5.0
Fix Committed
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

I am using the new alt-tab switcher in Oneiric. When I press alt-tab the window switcher takes just a little too long to appear. Releasing alt-tab during this period will generally work (I've seen it miss presses but this no longer happens after the latest upgrades) but the switcher won't appear until half a second later.

I don't know if the window is slow to render or this is just a timeout, but it feels slow and somewhat annoying when you have many windows (and you need to see the window before you can select the correct one). I'd appreciate it if this could be made faster or even configurable.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.5.92+bzr2791-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,imgpng,mousepoll,resize,vpswitch,regex,grid,snap,obs,commands,animation,place,session,expo,unitymtgrabhandles,wall,workarounds,ezoom,staticswitcher,fade,scale,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Sun Aug 28 15:53:05 2011
DistUpgraded: Log time: 2011-08-18 14:20:17.816663
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.881, 3.0.0-9-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc AMD Radeon HD 6310 GraphicsATI [1002:9802] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1611]
MachineType: Hewlett-Packard HP Pavilion dm1 Notebook PC
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic root=UUID=f207a949-88c8-4270-ab26-b19efdc43b0f ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to oneiric on 2011-08-26 (2 days ago)
dmi.bios.date: 04/26/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.12
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1611
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 96.39
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.12:bd04/26/2011:svnHewlett-Packard:pnHPPaviliondm1NotebookPC:pvr058A100000252B10000120100:rvnHewlett-Packard:rn1611:rvr96.39:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP Pavilion dm1 Notebook PC
dmi.product.version: 058A100000252B10000120100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu1
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

The Fiddler (stapostol) wrote :
Alex Launi (alexlauni) wrote :

The switcher has had time to be optimized a bit, is this still an issue for you?

Changed in unity:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
Simone Bordet (simone-bordet) wrote :

I concur with this bug.

Other switchers have the capability to configure a "popup" timeout, which is usually around 200 ms.

However, 200 ms for fast typers is way too long.

Unfortunately there is no way to configure that timeout (if it is a timeout) for the new Application Switcher in 11.10.

Thanks !

TomasHnyk (sup) wrote :

I do not know about the original poster, but it is still an issue for me (on uptodate 11.10). It also affects 7 people, so setting to confirmed.

Changed in unity:
status: Incomplete → New
status: New → Incomplete
status: Incomplete → Confirmed
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Download full text (4.2 KiB)

Still an issue on my system.

2011/11/22 TomasHnyk <email address hidden>

> I do not know about the original poster, but it is still an issue for me
> (on uptodate 11.10). It also affects 7 people, so setting to confirmed.
>
> ** Changed in: unity
> Status: Incomplete => New
>
> ** Changed in: unity
> Status: New => Incomplete
>
> ** Changed in: unity
> Status: Incomplete => Confirmed
>
> ** Changed in: compiz (Ubuntu)
> Status: Incomplete => Confirmed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/836023
>
> Title:
> New compiz alt-tab switcher window is slow to appear
>
> Status in Unity:
> Confirmed
> Status in “compiz” package in Ubuntu:
> Confirmed
>
> Bug description:
> I am using the new alt-tab switcher in Oneiric. When I press alt-tab
> the window switcher takes just a little too long to appear. Releasing
> alt-tab during this period will generally work (I've seen it miss
> presses but this no longer happens after the latest upgrades) but the
> switcher won't appear until half a second later.
>
> I don't know if the window is slow to render or this is just a
> timeout, but it feels slow and somewhat annoying when you have many
> windows (and you need to see the window before you can select the
> correct one). I'd appreciate it if this could be made faster or even
> configurable.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: compiz 1:0.9.5.92+bzr2791-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
> Uname: Linux 3.0.0-9-generic x86_64
> NonfreeKernelModules: fglrx
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,gnomecompat,imgpng,mousepoll,resize,vpswitch,regex,grid,snap,obs,commands,animation,place,session,expo,unitymtgrabhandles,wall,workarounds,ezoom,staticswitcher,fade,scale,unityshell,scaleaddon]
> CompositorRunning: compiz
> Date: Sun Aug 28 15:53:05 2011
> DistUpgraded: Log time: 2011-08-18 14:20:17.816663
> DistroCodename: oneiric
> DistroVariant: ubuntu
> DkmsStatus: fglrx, 8.881, 3.0.0-9-generic, x86_64: installed
> GraphicsCard:
> ATI Technologies Inc AMD Radeon HD 6310 GraphicsATI [1002:9802] (prog-if
> 00 [VGA controller])
> Subsystem: Hewlett-Packard Company Device [103c:1611]
> MachineType: Hewlett-Packard HP Pavilion dm1 Notebook PC
> PackageArchitecture: all
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-9-generic
> root=UUID=f207a949-88c8-4270-ab26-b19efdc43b0f ro quiet splash vt.handoff=7
> SourcePackage: compiz
> UpgradeStatus: Upgraded to oneiric on 2011-08-26 (2 days ago)
> dmi.bios.date: 04/26/2011
> dmi.bios.vendor: Hewlett-Packard
> dmi.bios.version: F.12
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: 1611
> dmi.board.vendor: Hewlett-Packard
> dmi.board.version: 96.39
> dmi.chassis.asset.tag: Chassis Asset Tag
> dmi.chassis.type: 10
> dmi.chassis.vendor: Hewlett-Packard
> dmi.chassis.version: Chassis Version
> dmi.modalias:
> dmi:bvnHewlett-Packard:bvrF.12:bd04/26/2011:svnHewlett-Packard:pnHPPaviliondm1NotebookPC:pvr058A100000252B10000120100:rvnHew...

Read more...

I experience this problem on Ubuntu 11.10. On 2 different machines (GeForce 8600 GT (G84) 512MB and Quadro FX 3450/4000 SDI (NV41GL) 256MB).

I would estimate (with only 2 apps open) that it takes anywhere from 300ms to 500ms and is most definitely noticeable.

Felix Haller (felixhaller) wrote :

also in 12.04

with nvidia GeForce 9600GT (nouveau-drivers)

Cyones77 (cyones77) wrote :

I experience the same problem. My machine have intel GMA 4500MHD

Dave Vree (hdave) wrote :

Seeing the same slowness in 12.04 Beta-2 32bit on GeForce Go 7400. Totally absent from Unity-2D so for me, I'd say it is definitely compositing related.

summary: - New compiz alt-tab switcher window is slow to appear
+ New Unity Alt-Tab switcher window is slow to appear
affects: compiz (Ubuntu) → unity (Ubuntu)
Ken Clive (ken.clive) wrote :

Hmm, I kind of notice the delay, but it's definitely not much more than 1/10 of a second. I do notice, however, that if you just quickly hit Alt+Tab and don't keep holding down Alt, the Alt-Tab switcher never actually displays, and it doesn't switch to the next window in the sequence. Not sure if this particular behavior is related to this or a completely different bug altogether. I will investigate my logs later tomorrow to see what it is.

System specs: 12.04 x86-64, AMD Phenom II X2 560 (3.3 GHz), 8GB DDR3, Nvidia GT520

madbiologist (me-again) wrote :

For those people running Ubuntu 12.04 "Precise Pangolin", unity 5.12-0ubuntu1.1 was released on 5th June 2012. It contains a fix for poor OpenGL performance. Does this provide any improvement to the issue described in this bug report?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
TomasHnyk (sup) wrote :

It does not feel slow (though it could be faster) anymore to me.

Do I understand it correctly that there is no set timeout?

madbiologist (me-again) wrote :

I'm not sure about the timeout - you could try asking in the forums or on the #ubuntu IRC channel on freenode.

Dean Henrichsmeyer (dean) wrote :

It does not. It is still slow to come up initially on the screen and there is a noticeable lag when hitting tab to switch between the icons.

Robert Dyer (psybers) wrote :

I can only test on one of the systems (as I removed Unity from the other for being way too slow). But on the GeForce 8600 GT (G84) 512MB system it is still slow. I estimate around 500-800ms. Compared to my laptop (ATI FireGL 5250) it is most definitely noticeably slower.

Daniel van Vugt (vanvugt) wrote :

madbiologist; No, my OpenGL fix in 5.12-0ubuntu1.1 won't help this bug.

I think this bug is either poor keyboard handling, or just the blur effect being slow. I'm pretty sure Unity (and its Alt-Tab switcher) still suffers from both.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Ryan Tandy (rtandy) wrote :

Thanks for the tip vanvugt, I disabled blur completely (using MyUnity) and alt-tab is now a lot more responsive. Mobility Radeon HD 2600 and fglrx-updates 8.960 FWIW.

Aurélien Leblond (blablack) wrote :

I upgraded to Quantal, and the issue is worst now.

It takes 4 to 5 seconds to switch between icons.

I have a Mobility Radeon HD 5800 with the Open-Source driver.

Aurélien Leblond (blablack) wrote :

More details
- At boot time, the switcher is not slow
- The switcher becomes slow as time passes
- It look very similar to the issue with the Dash being slow when using Blur

Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 6.2
Didier Roche (didrocks) on 2012-08-10
Changed in unity:
milestone: 6.2 → 6.4
Dean Henrichsmeyer (dean) wrote :

Just for further information. My problem went away completely when I switched to the proprietary ATI driver.

Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
milestone: 6.6 → 7.0
Daniel Lobato (elobatocs) wrote :

Still suffering from this with this video drivers:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL version string: 3.0 Mesa 9.1-devel

My workaround:

I think this issue is most likely related with blur. On ccsm , Ubuntu Unity plugin, I have set "Dash blur" to "None" in tab General, and the problem went away. I noticed Unity's launcher (which was slow like alt-tab) is now fast. Probably not the best solution but definitely a good workaround and I honestly don't notice the blur at all.

Daniel van Vugt (vanvugt) wrote :

Here's a workaround to enable one of the Compiz switchers instead (much faster):

1. Run: sudo apt-get install compiz-plugins compizconfig-settings-manager
2. Run: ccsm
3. CCSM > Ubuntu Unity Plugin > Switcher >
    For each key setting, click on the pencil icon and delete the key binding.
4. CCSM > Window Management >
    Now tick Application Switcher or one of the other switchers. Configure it as you like.

thinkpad (fellowsgarden) wrote :

@ #22

... or compiz' scale.

NoBugs! (luke32j) wrote :

Still very slow sometimes, in 13.04 testing ppa branch.

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Adam Niedling (krychek) wrote :

Did you actually fix this or just set it to fix released?

It's already fixed in trunk since some months, I need to check if it's possible to backport this to 12.04

Changed in unity:
status: Fix Released → Triaged
status: Triaged → Fix Released
Download full text (3.3 KiB)

I see this on 13.04 - the switcher shows up slow(sometimes fast), but switching between the various apps (by hitting tab with alt pressed) is slow (especially if there are multiple windows for a particular app). Intel onboard video and Unity 7.0 - lspci, and unity version below:

akarollil@akarollil-desktop:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z68 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
03:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
05:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
06:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
08:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)
akarollil@akarollil-desktop:~$ dpkg -l unity
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-======================================-========================-========================-==========================================================...

Read more...

Ah, sorry, I am running Unity 7.0.0 - and I am guessing the fixed 7.0.1 will show up soon via a software update?

And I confirm David Lobato's workaround in #22 works - setting Dash Blur to anything other than Active Blur make alt-tab switching fast.

tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers