transparency on unity panel broken

Bug #827012 reported by Doug McMahon on 2011-08-15
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Neil J. Patel
unity (Ubuntu)
Low
Unassigned

Bug Description

Since the new dash in unity 4.8 transparency in the unity panel is basically unusable. The lower the opacity set the more obviously this can be seen though it affects all decreases from the default
Also seen is that the app indicator area is 'separated' from the rest of the panel, again seen easier by setting a very low opacity
What is curious with the new dash is that it extends into the panel (the panel becomes part of the dash.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,expo,move,compiztoolbox,place,imgpng,gnomecompat,ezoom,resize,fade,scale,session,unityshell,cube,rotate]
Date: Mon Aug 15 18:42:44 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110815)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) on 2011-08-15
description: updated
Omer Akram (om26er) wrote :

This problem does not happen if blur is disabled, confirming it here.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Went ahead and disabled blur and as mentioned above the unity opacity option now works correctly.
Can also note that with blur disabled than dash no longer extends into the panel - maybe that should be an additional bug on the current dash?

Omer Akram (om26er) on 2011-08-17
Changed in unity:
importance: Undecided → Low
Sam_ (and-sam) wrote :

Actually when enabling blur in CCSM the panel changes (highlights) it's colour. Panel opacity here is 0,0220. Disabling blur also btw. fixes Bug #825632

Doug McMahon (mc3man) wrote :

As of unity 4.10.0 can no longer actually get 0.00 opacity any more so whether blur is enabled or not no longer matters

At the lowest setting , (0.00) it produces a light grey over black & similar over desktop depending on background
screen attached shows over desktop & black at same time

David Barth (dbarth) wrote :

It feels like a duplicate of the design-oriented discussion on #824916

Neil J. Patel (njpatel) on 2011-08-30
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 4.14.0
Neil J. Patel (njpatel) on 2011-09-07
Changed in unity:
status: Confirmed → In Progress
Neil J. Patel (njpatel) on 2011-09-08
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers