compiz crashed with SIGABRT in raise() [Merely unchecking the Unity plugin is enough to crash Compiz...]

Bug #823386 reported by Kenny Strawn on 2011-08-09
132
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Tim Penhey
unity (Ubuntu)
Undecided
Unassigned

Bug Description

This crash report occurred upon trying to perform the workaround to Bug 685552 that Sam Spilsbury pointed out to me... So much for the workaround as it no longer exists.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.0.8-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Tue Aug 9 09:13:49 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: nux
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 free () from /lib/x86_64-linux-gnu/libc.so.6
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Kenny Strawn (realkstrawn93) wrote :
visibility: private → public
Omer Akram (om26er) on 2011-08-09
visibility: public → private
visibility: private → public
Omer Akram (om26er) wrote :

this bug needs retracing and CoreDump is also attached. Once its retraced by launchpad tracer we can make it public then.

description: updated
description: updated
description: updated
Changed in unity (Ubuntu):
status: New → Confirmed

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Download full text (3.3 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.6.1-6ubuntu2 required, but 1:4.6.1-7ubuntu2 is available
libpango1.0-0 version 1.29.3-0ubuntu2 required, but 1.29.3-0ubuntu3 is available
libx11-6 version 2:1.4.3-2ubuntu1 required, but 2:1.4.4-1ubuntu1 is available
libpng12-0 version 1.2.44-2ubuntu1 required, but 1.2.46-3ubuntu1 is available
libgl1-mesa-glx version 7.11-0ubuntu1 required, but 7.11-0ubuntu3 is available
libudev0 version 172-0ubuntu5 required, but 173-0ubuntu3 is available
libglapi-mesa version 7.11-0ubuntu1 required, but 7.11-0ubuntu3 is available
libfreetype6 version 2.4.4-2 required, but 2.4.4-2ubuntu1 is available
libegl1-mesa version 7.11-0ubuntu1 required, but 7.11-0ubuntu3 is available
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
libglib2.0-0 version 2.29.14-0ubuntu1 required, but 2.29.16-0ubuntu2 is available
outdated debug symbol package for libthai0: package version 0.1.15-2 dbgsym version 0.1.14-2ubuntu1
libc-bin version 2.13-9ubuntu3 required, but 2.13-17ubuntu2 is available
libglu1-mesa version 7.11-0ubuntu1 required, but 7.11-0ubuntu3 is available
libffi6 version 3.0.10~rc8-6 required, but 3.0.11~rc1-1 is available
fontconfig version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libcairo2 version 1.10.2-6ubuntu2 required, but 1.10.2-6ubuntu3 is available
libllvm2.9 version 2.9+dfsg-3ubuntu1 required, but 2.9+dfsg-3ubuntu2 is available
libnux-1.0-0 version 1.0.8-0ubuntu2 required, but 1.2.2-0ubuntu2 is available
libgbm1 version 7.11-0ubuntu1 required, but 7.11-0ubuntu3 is available
gcc-4.6-base version 4.6.1-6ubuntu2 required, but 4.6.1-7ubuntu2 is available
outdated debug symbol package for libsigc++-2.0-0c2a: package version 2.2.9-1 dbgsym version 2.2.4.2-1ubuntu1
ttf-dejavu-core version 2.33-1 required, but 2.33-1ubuntu1 is available
libjpeg62 version 6b1-1ubuntu1 required, but 6b1-1ubuntu2 is available
libstdc++6 version 4.6.1-6ubuntu2 required, but 4.6.1-7ubuntu2 is available
libwayland0 version 0.1.0~0.2-0ubuntu2 required, but 0.1.0~0.2-0ubuntu3 is available
libc6 version 2.13-9ubuntu3 required, but 2.13-17ubuntu2 is available
outdated debug symbol package for libdatrie1: package version 0.2.4-3 dbgsym version 0.2.4-1
multiarch-support version 2.13-9ubuntu3 required, but 2.13-17ubuntu2 is available
libx11-data version 2:1.4.3-2ubuntu1 required, but 2:1.4.4-1ubuntu1 is available
fontconfig-config version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libx11-xcb1 version 2:1.4.3-2ubuntu1 required, but 2:1.4.4-1ubuntu1 is available
libnux-1.0-common version 1.0.8-0ubuntu2 required, but 1.2.2-0ubuntu2 is available
libfontconfig1 version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
outdated debug symbol package for libdbus-1-3: package version 1.4.12-4ubuntu2 dbgsym version 1.4.6-1ubuntu6.1
outdated debug symbol package for libglibmm-2.4-1c2a: package version 2.28.1-1 dbgsym...

Read more...

tags: removed: need-amd64-retrace
Kenny Strawn (realkstrawn93) wrote :

The problem, however, is that Bug 797078 is (1) in Metacity, and (2) definitely not because of trying to disable or enable Compiz plugins...

Mirco Müller (macslow) on 2011-09-28
Changed in unity:
status: New → Triaged
importance: Undecided → Critical
milestone: none → 4.20.0
importance: Critical → High
Didier Roche (didrocks) on 2011-09-29
Changed in unity (Ubuntu):
status: Invalid → Triaged
Changed in unity:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2011-09-29
Changed in unity:
assignee: nobody → Tim Penhey (thumper)
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers