[regression] expose have become quite slow with the last update of unity

Bug #821538 reported by Omer Akram on 2011-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Unity 4.6.0 update introduced a regression now the window expose is much slow and jerky on my intel netbook whereas its quite normal on the NVIDIA system

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,place,session,snap,move,resize,workarounds,gnomecompat,expo,mousepoll,grid,vpswitch,wall,fade,scale,unityshell]
Date: Fri Aug 5 19:32:45 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110802)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

aaand, the regression is caused by this commit http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/1332 reverting this commit fixes the issue.

Changed in unity (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Andrea Azzarone (azzar1) on 2011-08-09
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-08-19
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.8.2-0ubuntu3

---------------
unity (4.8.2-0ubuntu3) oneiric; urgency=low

  * Update to current trunk to get closer from an usable version, including
    - improvements to the alt-tab switcher, fixing the performances issues
      on intel cards, thanks Jason Smith
    - reworked dnd code fixing launcher showing when dragging text(lp: #773028)
      or widgets (lp: #724986), the expose slowness (lp: #821538) and other
      bugs as well, thanks Andrea Azzarone
    - the dash text is selected by default allow to type directly a new command
      (lp: #826904)
 -- Sebastien Bacher <email address hidden> Fri, 19 Aug 2011 18:04:19 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2011-08-19
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-08-19
Changed in unity:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2011-08-25
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers