Blurred background behind bottom-most quicklist is misplaced

Bug #819663 reported by Adolfo Jayme on 2011-08-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend

Bug Description

Please see attached screenshot. If you open the quicklist for the two lenses of Unity, you can see the background is not correctly positioned. This also happen if you have a bunch of icons in your Launcher and you open a quicklist (the Launcher icon has to be at bottom of screen).

EDIT: Now Lenses are inside the main Dash, so the problem is less visible, but the bug is still there. See comment #4 of this bug.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,screenshot,gnomecompat,snap,resize,vpswitch,mousepoll,imgpng,animation,move,unitydialog,grid,place,unitymtgrabhandles,expo,wall,workarounds,session,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Tue Aug 2 01:39:48 2011
DistUpgraded: Log time: 2011-07-27 03:59:45.711708
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.0.0-6-generic, i686: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-7-generic, i686: installed
DpkgLog:

GraphicsCard:
 Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0241]
   Subsystem: Acer Incorporated [ALI] Device [1025:0241]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110723)
MachineType: Gateway LT20
ProcEnviron:
 LANGUAGE=es_MX:es
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=1d1a8a40-0ddf-4268-a5ed-0c9afb44feb3 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-07-27 (5 days ago)
dmi.bios.date: 09/04/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: LT20
dmi.board.vendor: Acer
dmi.board.version: V1.10
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.10
dmi.modalias: dmi:bvnAcer:bvrV1.10:bd09/04/2009:svnGateway:pnLT20:pvrV1.10:rvnAcer:rnLT20:rvrV1.10:cvnAcer:ct10:cvrV1.10:
dmi.product.name: LT20
dmi.product.version: V1.10
dmi.sys.vendor: Gateway
peripherals:
 /desktop/gnome/peripherals/mouse:
   cursor_theme = DMZ-White
version.compiz: compiz 1:0.9.5.0-0ubuntu1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Adolfo Jayme (fitojb) wrote :
Adolfo Jayme (fitojb) on 2011-08-10
tags: added: bitesize
removed: single-occurrence
Jussi Pakkanen (jpakkane) wrote :

I can not reproduce this using Oneiric daily ISO.

Changed in unity:
status: New → Incomplete
Adolfo Jayme (fitojb) wrote :

This happened to me only with large quicklists, in the bottom-most icons in the Launcher, before the Lenses icons moving to the main Dash, so the problem now is less visible.

Adolfo Jayme (fitojb) wrote :

The bug is still there.

To test:
--------

 - Install Ubuntu Tweak 0.6 from its ‘Next’ development PPA.
 - Add Ubuntu Tweak to the Launcher, and add as many Launcher items so
   the Ubuntu Tweak icon stays near the bottom of the screen.
 - Open Ubuntu Tweak Launcher item’s quicklist.
 - You will notice that the background of the quicklist is shifted down.

See the attached screenshot of current Oneiric.

Changed in unity:
status: Incomplete → New
description: updated
Adolfo Jayme (fitojb) wrote :

Just a note: I mentioned Ubuntu Tweak because its launcher has a very big quicklist, and with it it’s easy to test this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-11-22
Changed in unity:
status: New → Confirmed
Adolfo Jayme (fitojb) wrote :

This bug is no longer reproducible in Precise.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitojb) wrote :

Spoke too soon: the bug is still there, but is less evident now. Certainly quicklists have been improved.

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Stephen M. Webb (bregma) wrote :

I can confirm this is still happening with current Saucy images 2013-08-08

Changed in unity:
importance: Undecided → Medium
milestone: none → 7.1.1
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers