unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()

Bug #811401 reported by Jason Warner on 2011-07-16
184
This bug affects 61 people
Affects Status Importance Assigned to Milestone
The Sound Menu
Fix Released
Critical
Conor Curran
Unity
Fix Released
Critical
Unassigned
Unity Foundations
Undecided
Unassigned
unity (Ubuntu)
Critical
Unassigned

Bug Description

Clicking volume control indicator caused this.

Exact step was:

1. Click on volume indicator
2. attempt to raise volume
3. watch volume go from 0% to 100% (no stopping)
4. system hang for approx 30 seconds.
5. recover and crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.2.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic-pae 3.0.0-rc7
Uname: Linux 3.0.0-5-generic-pae i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Sat Jul 16 15:45:59 2011
DistUpgraded: Log time: 2011-06-15 08:28:12.994726
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/lib/unity/unity-panel-service
GraphicsCard:
 nVidia Corporation G84M [Quadro FX 570M] [10de:040c] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkPad T61p [17aa:20d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 646067U
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-5-generic-pae root=UUID=a2df561a-fffa-439f-9910-22efa03470da ro quiet splash vt.handoff=7
Renderer: Unknown
SegvAnalysis:
 Segfault happened at: 0xb712152f <g_type_check_instance_cast+15>: call 0xb70f5c67
 PC (0xb712152f) ok
 source "0xb70f5c67" (0xb70f5c67) ok
 destination "(%esp)" (0xbf212000) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/libgtk-3.so.0
 gtk_container_forall () from /usr/lib/libgtk-3.so.0
 ?? () from /usr/lib/libgtk-3.so.0
 ?? () from /usr/lib/libgtk-3.so.0
Title: unity-panel-service crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: Upgraded to oneiric on 2011-06-14 (31 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 05/11/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7LETC6WW (2.26 )
dmi.board.name: 646067U
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7LETC6WW(2.26):bd05/11/2009:svnLENOVO:pn646067U:pvrThinkPadT61p:rvnLENOVO:rn646067U:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 646067U
dmi.product.version: ThinkPad T61p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu6
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.11~1-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Jason Warner (jasoncwarner) wrote :
visibility: private → public

StacktraceTop:
 g_type_check_instance_cast (type_instance=0x92870d8, iface_type=153927760) at /build/buildd/glib2.0-2.29.10/./gobject/gtype.c:3977
 gtk_image_menu_item_forall (container=0x92870d8, include_internals=1, callback=0xb74b0c30 <gtk_grab_notify_foreach>, callback_data=0xbf212274) at /build/buildd/gtk+3.0-3.1.8/./gtk/gtkimagemenuitem.c:634
 gtk_container_forall (container=0x92870d8, callback=0xb74b0c30 <gtk_grab_notify_foreach>, callback_data=0xbf212274) at /build/buildd/gtk+3.0-3.1.8/./gtk/gtkcontainer.c:2031
 gtk_grab_notify_foreach (child=0x92870d8, data=0xbf212274) at /build/buildd/gtk+3.0-3.1.8/./gtk/gtkmain.c:2099
 gtk_menu_shell_forall (container=0x92cb088, include_internals=1, callback=0xb74b0c30 <gtk_grab_notify_foreach>, callback_data=0xbf212274) at /build/buildd/gtk+3.0-3.1.8/./gtk/gtkmenushell.c:1248

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu):
importance: Medium → Critical
Changed in unity (Ubuntu):
status: New → Confirmed

The unity global menu and the indicators are crazy. Some indicators are not shown and the indicator-datetime changes between english and spanish (my laguage). The unity global menu appears and disappears from the app's window. All of this is shown in the video.

Didier Roche (didrocks) on 2011-07-29
Changed in unity:
status: New → Confirmed
Les Lamb (kernelles) wrote :

For me, steps to produce this error were:

1. Clicked on logout indicator
2. Blank transparent menu appeared and panel got frozen
3. Blank transparent menu disappeared, but now the logout indicator does not respond when clicked on.

I am also having issues with the volume control, as mentioned above, but mine is different. It doesn't freeze when I use it, but it will only operate at 0 or 100%, nothing in between. Not sure if that is a separate issue or not, so I'll mention it anyway.

Conor Curran (cjcurran) wrote :

I think this should disappear once we figure out the gtk patch needed for Libido to work nicely with gtk3. On my radar.

Changed in indicator-sound:
status: New → Confirmed
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Medium
Conor Curran (cjcurran) on 2011-09-05
Changed in indicator-sound:
importance: Medium → Critical
Conor Curran (cjcurran) on 2011-09-08
Changed in indicator-sound:
milestone: none → 0.7.7
status: Confirmed → In Progress
Changed in unity-foundations:
milestone: none → oneiric-beta-2
status: New → In Progress
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Conor Curran (cjcurran) on 2011-09-12
Changed in unity-foundations:
status: In Progress → Triaged
Changed in indicator-sound:
status: In Progress → Triaged
Ted Gould (ted) on 2011-09-21
Changed in unity-foundations:
milestone: oneiric-beta-2 → oneiric-final
Neil J. Patel (njpatel) on 2011-09-22
tags: added: rls-mgr-o-tracking
Neil J. Patel (njpatel) on 2011-09-22
Changed in unity:
status: Invalid → Triaged
Changed in unity (Ubuntu):
status: Invalid → Triaged
Changed in unity:
milestone: none → 4.20.0
Neil J. Patel (njpatel) wrote :

I reopened in Unity so we can track it easily.

Changed in unity:
importance: Undecided → Critical
Neil J. Patel (njpatel) on 2011-09-22
Changed in unity:
milestone: 4.20.0 → 4.18.0
omarly666 (omarly666) wrote :

same as first post but I was trying to lower volume. all disappears for a while. luckily it came back

you had it back on 9.10? steady as a rock and sensors and one tiny panel.

maybe i must go mint - but I was such a BIG BIG fan for so long.

Ted Gould (ted) wrote :

I believe this should have been fixed by ido 0.2.93 which was released on 9-20-2011, there hasn't been a duplicate since then, so I'm going to mark this as Fixed. Please submit a new bug if this is still continuing to be an issue.

Changed in indicator-sound:
status: Triaged → Fix Released
Changed in unity-foundations:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Jono Bacon (jonobacon) wrote :

This just happened to me and I am currently up to date. It happened when I unsuspended.

tags: added: iso-testing
dack (dack) wrote :

I am still having this issue. Clicking on the volume control crashes unity-panel-service. dmesg shows this:

unity-panel-ser[22959]: segfault at 1c ip 00007fbeeb594235 sp 00007fff40b08530 error 4 in libgdk-3.so.0.200.0 (deleted)[7fbeeb565000+77000]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers