unity-panel-service crashed with SIGABRT in __kernel_vsyscall()

Bug #810145 reported by Daniel Manrique on 2011-07-13
460
This bug affects 106 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Critical
Neil J. Patel
Oneiric
Critical
Neil J. Patel

Bug Description

The unity-panel-service crashes with a bunch of segfaults in syslog. It then respawns, then crashes again.

The visible symptom is that applications that use the global menu "flicker" because the panel "swallows" the menu when running, then crashes and sends the menu back to the application itself.

Some applications, such as gnome-terminal, start "shrinking" from this behavior and eventually become unusable. This is because when the menu is swallowed, the window gets reduced vertically, and when the menu returns to it, the app doesn't resize back up to accomodate it.

Other apps, such as Firefox, just flicker uncontrollably.

This happens on a fresh and fully-updated Oneiric system (as of 2011-07-13).

I'm reporting this on a Toshiba Tecra S11 with Intel video but I've seen it happen on several other machines; some, though, don't exhibit this problem and I haven't seen it on a virtual machine. If necessary or helpful I can compile a list of systems on which it happens.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-services 4.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic i686
Architecture: i386
CrashCounter: 1
Date: Wed Jul 13 16:38:37 2011
ExecutablePath: /usr/lib/unity/unity-panel-service
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: unity
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: unity-panel-service crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Daniel Manrique (roadmr) wrote :

StacktraceTop:
 g_type_check_instance_cast (type_instance=0xb6237d98, iface_type=138005672) at /build/buildd/glib2.0-2.29.10/./gobject/gtype.c:3985
 gail_widget_notify_gtk (obj=0x8332008, pspec=0x82ac260) at /build/buildd/gtk+3.0-3.1.8/./modules/other/gail/gailwidget.c:954
 g_cclosure_marshal_VOID__PARAM (closure=0x839e600, return_value=0x0, n_param_values=2, param_values=0x83a3028, invocation_hint=0xbfd38570, marshal_data=0x0) at /build/buildd/glib2.0-2.29.10/./gobject/gmarshal.c:539
 g_closure_invoke (closure=0x839e600, return_value=0x0, n_param_values=2, param_values=0x83a3028, invocation_hint=0xbfd38570) at /build/buildd/glib2.0-2.29.10/./gobject/gclosure.c:773
 signal_emit_unlocked_R (node=0x8286f18, detail=433, instance=0x8332008, emission_return=0x0, instance_and_params=0x83a3028) at /build/buildd/glib2.0-2.29.10/./gobject/gsignal.c:3256

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Daniel Manrique (roadmr) on 2011-07-15
visibility: private → public
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu):
importance: Medium → Critical
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
tags: added: iso-testing
Daniel Manrique (roadmr) wrote :

Tried Oneiric Alpha 3 (20110803.1) and this is still happening.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in unity (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
David Barth (dbarth) wrote :

It sounds weird to me that the service can crash that hard and systematically.
Are you using a11y specifically, and does turning that off change the situation. I know that may not be practical, but it could clarify whether the issue comes under special circumstance or not.

Otherwise, is there a test procedure that we could follow to try and make it crash here as well? With a particular set of actions?

Last, i'd be interested to know which machines it's crashing on, and which are not prone to exposing the issue. That may also be HW related, but at this point it's just an hypothesis.

Thanks in advance for your feedback.

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Neil J. Patel (njpatel)
Daniel Manrique (roadmr) wrote :

Hi David,

Thanks for looking at this report!

We do automated testing on a bunch of laptops, which are all network-installed using a preseed file which contains this line in the late_command:

in-target sudo -u ubuntu gconftool-2 --set --type bool /desktop/gnome/interface/accessibility true

The reason for this was to enable testing using mago, which requires the accessibility framework to be enabled.

So we don't actually need a11y specifically, but that's how we came across this problem.

In principle, disabling it makes things work correctly; in practice, however, I've found that using gconftool-2 on Oneiric gives weird results. If, after installing with the aforementioned command in the preseed, I go into "Universal Access" it shows everything as "Off" but the problem still occurs. However, if I toggle (On, then Off) the screen reader, accessibility gets disabled correctly and the panel stops crashing.

Steps to reproduce:

1- Install from an Oneiric Alpha 3 image using the attached preseed file. I created a custom CD image replacing the /preseed/ubuntu.seed file with the one I'm attaching. Note that this preseed file minimally modifies the stock one, just adding the gconftool-2 command as mentioned above.
2- When prompted for the user's data, the username should be "ubuntu", as that's the user the preseed file modifies.
3- Once the install completes, and upon logging in, you'll notice elevated CPU usage from the constant dying/respawning of unity-panel-service.
4- from the Unity app lens, launch gnome-terminal to witness how it shrinks due to the panel respawning.

This happens on every system I've tested Oneiric in, about 30 laptops, various makes/models, but more importantly, the test case I just gave works even on a virtual machine (I'm using VirtualBox 4 on Natty), so it's definitely not hardware-related. The systems where it did not happen, were the ones that were installed manually, hence, the gconftool command wasn't used.

Finally, I should mention that what hinted that accessibility was somehow related, was bug 798094 which describes a similar issue.

Thanks again!

Daniel Manrique (roadmr) wrote :

This is the preseed file to use, it should be in /preseeds/ of your Ubuntu install media. I built a custom ISO using instructions from here:

https://help.ubuntu.com/community/LiveCDCustomization

The custom ISO was the easiest way for me to try this on a virtual machine. If using for instance USB install media on bare metal, just dropping this file in the needed location and maybe regenerating the md5sums file could potentially be easier.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Paolo Rotolo (paolorotolo) wrote :

I can confirm this issue on Ubuntu Oneiric Ocelot daily bulid (20110814).

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Changed in unity (Ubuntu):
status: Confirmed → Triaged
David Barth (dbarth) wrote :

We have recently fixed an issue related to the a11y stack in the panel. See bug #817477. Can you re-test with unity-4.16.0 and report? Thanks

Daniel Manrique (roadmr) wrote :

Hi David,

I can no longer reproduce this problem, on systems installed from an image dated 20110908 and using unity 4.12.0-0ubuntu2, and the problem is no longer present. I checked that the /desktop/gnome/interface/accessibility setting is "true", and I also tried manually turning on screen reading to try and trigger the error, but I can't make it fail anymore.

I also tried a dist-upgrade as of today, bringing Unity up to 4.14.2-0ubuntu1, and it's still working correctly.

Based on the fact that it wasn't the fix you mention that solved it, we'd have to mark this Invalid (unknown fix), but based on bug 817477 I'll mark fix released instead. Please change if you feel this is incorrect.

Thanks so much for your help with this problem!

Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/810145

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers