unity crashed with AttributeError in reset_unity_compiz_profile(): 'str' object has no attribute 'get_string'

Bug #809378 reported by GNAServicesInc on 2011-07-12
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Didier Roche
unity (Ubuntu)
High
Didier Roche
Oneiric
High
Didier Roche

Bug Description

I just updated and this happens on login.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-4.5-generic 3.0.0-rc6
Uname: Linux 3.0.0-4-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Tue Jul 12 11:02:13 2011
DistUpgraded: Log time: 2011-07-11 16:42:24.199036
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/bin/unity
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0122] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
InterpreterPath: /usr/bin/python2.7
MachineType: System manufacturer System Product Name
ProcCmdline: /usr/bin/python /usr/bin/unity --reset
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-4-generic root=UUID=f52836b5-40d8-4c42-8a21-3abda4d0774e ro enable_mtrr_cleanup mtrr_spare_reg_nr=1 crashkernel=384M-2G:64M,2G-:128M quiet splash enable_mtrr_cleanup mtrr_spare_reg_nr=1 vt.handoff=7
PythonArgs: ['/usr/bin/unity', '--reset']
Renderer: Unknown
SourcePackage: unity
Title: unity crashed with AttributeError in reset_unity_compiz_profile(): 'str' object has no attribute 'get_string'
UpgradeStatus: Upgraded to oneiric on 2011-07-11 (0 days ago)
UserGroups:

dmi.bios.date: 05/09/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0501
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8Z68-V PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0501:bd05/09/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP8Z68-VPRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu6
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.11~1-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

GNAServicesInc (gnaservicesinc) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #737320, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Jean-Baptiste Lallement (jibel) wrote :

regression in Unity 4.2 (was fixed in Unity 3.8.14-0ubuntu1 cf bug 737320)

Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: regression-release
Changed in unity (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → nobody
status: New → Confirmed
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
David Barth (dbarth) on 2011-07-20
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Medium
status: New → Triaged
milestone: none → 4.6.0
Didier Roche (didrocks) on 2011-07-20
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-07-20
Changed in unity:
importance: Medium → Critical
David Barth (dbarth) on 2011-07-22
Changed in unity (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
David Barth (dbarth) on 2011-08-30
Changed in unity:
milestone: 4.8.0 → 4.12.0
Didier Roche (didrocks) on 2011-09-01
Changed in unity:
milestone: 4.12.0 → 4.14.0
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-09-05
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-06
Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers