Ubuntu

no confirmation for deleting from trash in Unity launcher

Reported by Jason Warner on 2011-07-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Undecided
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

Unity 3D. Emptying trash in launcher empties without confirmation dialog.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-3.4-generic-pae 3.0.0-rc5
Uname: Linux 3.0-3-generic-pae i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Sun Jul 10 08:42:25 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=en_AU:en
 LC_CTYPE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-06-14 (25 days ago)

Related branches

lp:~andyrock/unity/fix-808162
Merged into lp:unity at revision 1416
Gord Allott (community): Approve on 2011-08-24
Jason Warner (jasoncwarner) wrote :
Daniel Manrique (roadmr) on 2011-07-10
Changed in unity (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I confirmed the behavior you report, thus setting the bug as Confirmed with importance Medium as it has "moderate impact in a core application". IMHO if the user had already put the items in the trashcan indicating he didn't want them, and then selected to empty the trash, it shouldn't come as a surprise that the items get deleted, neither is it critical, as the user had already discarded them, so it doesn't warrant a higher importance.

However I do agree that it's a bug that should be fixed. It should be before the development cycle for Oneiric is out.

Thanks for your report!

Changed in unity (Ubuntu):
importance: Undecided → Medium

In 11.04, unity follows nautilus' preference (ask before empty trash). Now, nautilus uses gsettings instead of gconf to store this preference. We just need to change the place where this option is looked for.

Changed in unity:
status: New → Confirmed
assignee: nobody → Marco Biscaro (marcobiscaro2112)
Sebastien Bacher (seb128) wrote :

the gconf to gsetting is a duplicate of bug #800689 but ideally unity would stop having a copy of the code of that dialog and use the nautilus3 dbus interface for that action rather

Changed in unity:
assignee: Marco Biscaro (marcobiscaro2112) → nobody
Omer Akram (om26er) on 2011-08-09
tags: added: regression-release
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Gord Allott (gordallott) on 2011-08-24
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers