Unity tooltips doesn't show Hebrew characters

Bug #807921 reported by Haggai Eran on 2011-07-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Chris Halse Rogers
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When running Unity with a Hebrew locale, the dock's tooltips for icons that have Hebrew in them are empty.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.16-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,resize,grid,compiztoolbox,vpswitch,move,mousepoll,regex,gnomecompat,snap,imgpng,place,animation,wall,unitymtgrabhandles,expo,session,ezoom,workarounds,staticswitcher,fade,scale,unityshell]
Date: Sat Jul 9 13:08:56 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
ProcEnviron:
 LANGUAGE=he:en_US:en
 PATH=(custom, user)
 LANG=he_IL.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Haggai Eran (haggai-eran) wrote :
Haggai Eran (haggai-eran) wrote :

When the text is in English, even with Hebrew locale, the tooltips look fine.

Haggai Eran (haggai-eran) wrote :

I looked into the code, and I think this may be due to how GetTextExtent works. It seems to take the x and width fields of Pango's logical rect and sum them together to get the text width. (http://bazaar.launchpad.net/~unity-team/unity/trunk/view/head:/plugins/unityshell/src/StaticCairoText.cpp#L365)
I'm not sure, but I think it should take just the width of the logical rectangle.

Omer Akram (om26er) wrote :

Haggai, is that still an issue with latest unity in ubuntu oneiric ?

Changed in unity:
status: New → Opinion
Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: Opinion → Incomplete
Haggai Eran (haggai-eran) wrote :

Yes, the issue still exists in version 4.14.2-0ubuntu2.

Omer Akram (om26er) on 2011-09-16
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Haggai Eran (haggai-eran) wrote :

Hi,

I've tried changing the width and height to include only the width and height returned from Pango, without including the x, and y values. This solved the problem for me. You can see the (two-lines) patch at lp:~haggai-eran/unity/rtl-tooltips
Regards,
Haggai

Didier Roche (didrocks) on 2011-11-17
Changed in unity-distro-priority:
status: New → Fix Committed
Tim Penhey (thumper) on 2011-11-23
Changed in unity-distro-priority:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Tim Penhey (thumper) on 2011-11-24
Changed in unity:
assignee: nobody → Chris Halse Rogers (raof)
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2011-12-20
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-01-20
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers