no menu bar on top, compositing bug?

Bug #806358 reported by Colin Ian King on 2011-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jay Taoko
unity (Ubuntu)
Medium
Jay Taoko
Oneiric
Medium
Jay Taoko

Bug Description

Failure mode: ISO testing, OEM Desktop install

ISO Image: http://cdimage.ubuntu.com/daily-live/20110705.1/oneiric-desktop-amd64.iso
H/W: Dell Inspiron 6400 laptop
Test case: http://testcases.qa.ubuntu.com/Install/DesktopOem, failed on Case ID: uoi-001

The menu bar along the top of the desktop is not rendered on my Dell Inspiron 6400 laptop.

Attached: Screenshot of missing menu bar and weird lines across screen.

Colin Ian King (colin-king) wrote :
Colin Ian King (colin-king) wrote :
Colin Ian King (colin-king) wrote :

Just to add, when I move my mouse over the blank menu bar I can click on the items on the menu, but I cannot see the menu bar at all.

tags: added: iso-testing
affects: ubuntu → unity (Ubuntu)
Jean-Baptiste Lallement (jibel) wrote :

possibly duplicate of bug 745996

Changed in unity (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
Colin Ian King (colin-king) wrote :

Is this due to the way stacking is broken?

Neil J. Patel (njpatel) on 2011-07-08
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.4.0
David Barth (dbarth) wrote :

Or a compositing bug indeed. What kind of graphics card is that running on?

According to http://en.wikipedia.org/wiki/Dell_Inspiron#Inspiron_6400.2FE1505 it could be either an ATI or Intel issue. Intel should work. ATI, there have been some issues with older chipsets like the one I am running. It is fixed in the regular desktop case though. Maybe a corner case when in install mode.

Changed in unity (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Thomas Thurman (marnanel)
Changed in unity:
assignee: Sam Spilsbury (smspillaz) → Thomas Thurman (marnanel)
David Barth (dbarth) wrote :

Let's consider it's a stacking issue for now. I'm shifting that to Thomas's bug list.

Colin: could you indicate whether you can get that systematically or not?

If that's systematic and can indeed be traced as a stacking issue, that would be a major finding! Otherwise, it should be requalified as a compositing problem, pushed to Jay's Nux bug list.

Jean-Baptiste Lallement (jibel) wrote :

lspci output says it is a
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc M52 [Mobility Radeon X1300] [1002:7149] (prog-if 00 [VGA controller])

Colin Ian King (colin-king) wrote :

1. Yes, it's a ATI Technologies Inc M52 [Mobility Radeon X1300] [1002:7149] (answer to posting #6)
2. It happened every time I booted, so it was repeatable (answer to posting #7)

Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
David Barth (dbarth) on 2011-08-12
Changed in unity (Ubuntu Oneiric):
assignee: Thomas Thurman (marnanel) → Jay Taoko (jaytaoko)
Changed in unity:
assignee: Thomas Thurman (marnanel) → Jay Taoko (jaytaoko)
status: New → Confirmed
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
importance: High → Medium
Changed in unity:
importance: Undecided → Medium
David Barth (dbarth) wrote :

Kept on the radar since it's driver related and reproducible, so worth fixing if that improves the general level of GL support across the board.

Changed in unity:
milestone: 4.8.0 → 4.12.0
Didier Roche (didrocks) on 2011-09-01
Changed in unity:
milestone: 4.12.0 → 4.14.0
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
milestone: 4.14.0 → 4.16.0
Neil J. Patel (njpatel) wrote :

Colin, does this still happen with latest Oneiric? I couldn't figure out whether this was on Ati or Intel from the bug (sorry if I missed something). If the latter, it may well be a dupe of #745996 as Jean-Baptiste mentioned. In our tests, this has usually happened on Intel due a custom ~/.drirc file (though ISO testing suggests that this would be a fresh install?) or a /etc/drirc file. Removing it fixes the issue.

Didier Roche (didrocks) on 2011-09-15
Changed in unity:
milestone: 4.16.0 → 4.18.0
Colin Ian King (colin-king) wrote :

OK, tested with today's ISO and the bug no longer happens, so it's now been magically fixed somewhere.

Thanks for testing. I'm setting the status to 'Fix released'

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers