dash prevents the system going to suspend (which may suspend afterwards when the dash is closed)

Bug #802938 reported by Jean-Baptiste Lallement on 2011-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Neil J. Patel
unity (Ubuntu)
Medium
Canonical Desktop Experience Team
Oneiric
Medium
Canonical Desktop Experience Team

Bug Description

TEST CASE:
1. Set your system to suspend with the lid is closed
2. Press the SUPER key to open the dash
3. Close the lid, and wait few seconds
  -> Verify that the system doesn't go to suspend mode
4. Reopen the lid
5. Press the SUPER key to close the dash
  -> The system goes to suspend mode but shouldn't

Expected:
The system suspends when the lid is closed and doesn't when the lid is opened and hasn't reach the suspend timeout.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.0.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Uname: Linux 3.0-2-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,imgpng,regex,resize,mousepoll,vpswitch,grid,move,resizeinfo,place,snap,animation,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Tue Jun 28 13:28:12 2011
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-06-27 (0 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Omer Akram (om26er) wrote :

Does the same happen when a menu is opened? like the messaging menu. I cant try to reproduce as suspend fails on my system

Hi Jean-Baptiste,

I can reproduce this except for the 'Suspend after closing the Dash' part. I do -

1.) Open Dash
2.) Press my laptops Fn + Esc combination which maps to Suspend (I had tried with closing the lid but I think that maps to hibernate now). Noticed that it doesn't suspend
3.) Close the Dash.
4.) Press the Fn + Esc combination again, this time the laptop suspends.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed

Omer,

This happens if any menu is open (indicator menu, application menus) not just the Dash.

I would rank this issue at High importance, as it could lead to users closing their laptops expecting them to suspend and not doing so because they have the Dash or a menu open. This would be a 'moderate impact on a large proportion of Ubuntu users'

summary: - dash prevents the system of going to suspend (which suspends afterwards
+ dash prevents the system going to suspend (which may suspend afterwards
when the dash is closed)
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
status: New → Confirmed
David Barth (dbarth) wrote :

When testing, I recommend making the distinction between a lid close and a press of Fn+FX key, as the latter may expose a different issue with the way keyboard grabs are managed.

David Barth (dbarth) wrote :

On natty, closing the lid with the dash open prevented the suspend, but as soon as I re-opened the lid (and the dash was still open) the system started the sleep procedure.

This tells me a few things:
- the problem is there for some time, it's not related to a recent kernel or sub-system change
- it should be unity or compiz related, since both the dash and the globalmenu are touching a similar unity window layer

Additionally, a quicklist window also prevents suspend to work. So it seems in general, any kind of window that unity creates on it's own super layer. But not a tooltip FWIW.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Changed in unity (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in unity:
milestone: none → 4.4.0

When the Dash is opened, it calls GrabPointer () and GrabKeyboard ().

When a Quicklist is opened, it calls GrabPointer () and GrabKeyboard ().

When the Launcher enters in key nav mode (Alt+F1), it calls GrabPointer () and GrabKeyboard ().

I didn't find the code that shows the menus, but I think it calls GrabPointer () and GrabKeyboard () too.

In none of the above the computer suspends when requested.

I think that the suspend function does not work when the mouse and/or keyboard are grabbed.

Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Omer Akram (om26er) wrote :

Dash in oneiric no longer grabs the keyboard when opened, hence suspend works even when dash is open.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers