Ubuntu

Lines appear at the top of the desktop, and at the bottom of some windows

Reported by Will Warren on 2011-06-23
This bug report is a duplicate of:  Bug #910624: Corrupt panel shadow texture. Edit Remove
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

These strange lines appear at the top of the desktop, and at the bottom of the "unity overlay" (the thing that comes up when you click the ubuntu logo in the top left.

Running natty (upgraded from maverick) although I know another person has experienced it after doing a fresh install.

The common thing between the both of us is that we both have the ATI Radeon Xpress 1250 graphics chipset. See here for more information + screenshots: http://ubuntuforums.org/showthread.php?t=1752329

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.14-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
Date: Thu Jun 23 17:26:05 2011
DistUpgraded: Log time: 2011-04-29 07:20:49.421794
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc Radeon Xpress 1250 [1002:7942] (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c511]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
MachineType: SAMSUNG ELECTRONICS CO., LTD. R19/R20/R21
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=3f992c8d-f84c-4e83-84d1-cd2b5e8e0e8a ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-30 (54 days ago)
dmi.bios.date: 04/03/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 10SH
dmi.board.name: R19/R20/R21
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr10SH:bd04/03/2007:svnSAMSUNGELECTRONICSCO.,LTD.:pnR19/R20/R21:pvr09SH:rvnSAMSUNGELECTRONICSCO.,LTD.:rnR19/R20/R21:rvr:cvnSAMSUNGELECTRONICSCO.,LTD.:ct1:cvrN/A:
dmi.product.name: R19/R20/R21
dmi.product.version: 09SH
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Will Warren (willdavidwarren) wrote :

I get similar when using an ATI Mobility Radeon 3400. Note that this isn't considered a regression if you weren't using Unity in Maverick, so if that's the case please remove the tag regression-update.

Posting a screenshot would also be good.

Will Warren (willdavidwarren) wrote :

I reported this bug using the "ubuntu-bug" tool, and it added the regression tag automatically, even though I was NOT using unity with Maverick.

I did mention that there is a thread on the Ubuntu forums about this that included screenshots, but I might as well attach them to this too.

tags: removed: regression-update
Will Warren (willdavidwarren) wrote :

Here's the other screenshot

Bilal Akhtar (bilalakhtar) wrote :

Seems to be a bug with the open source Radeon driver. Are you able to reproduce the same thing with the proprietary fglrx driver?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Will Warren (willdavidwarren) wrote :

Unfortunately I am unable to reproduce it using the drivers from ATI's site as they are incompatible with the version of X.org that ships with Natty.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Hey willdavidwarren,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
Will Warren (willdavidwarren) wrote :

Hi Bryce, thanks for your comments.

I have upgraded and am using Oneiric now.

The issues with the unity overlay's transparency have been resolved, however there are still lines at the top of the screen when the desktop is focused. When an app is running full screen, there are no issues.

I'm not sure how to proceed with this. Should I file a new bug under Oneiric or just change this one?

Just as an FYI, I recently tested out GNOME3 on the same hardware and that looks great, except all the UI fonts are scrambled. This leads me to believe that it's not a Unity bug, but an ati one.

Bilal Shahid (s9iper1) wrote :

will warren
you should file a new bug and also attach a screenshot and necessary info with it..
if this bug is solved than can we close this?
thankx

Will Warren (willdavidwarren) wrote :

Sure Thing

Omer Akram (om26er) wrote :

closing this bug now since you reported a new bug on a more specific issue.

Changed in unity:
status: Incomplete → Invalid
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.