Maximize window makes window disappear

Bug #800542 reported by harald on 2011-06-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

- dual-head
- monitors on top of each other
- maximize window on lower monitor

- lower monitor is primary, don't know whether that actually makes a difference

=> window disappears, in shift-switcher only title-bar of window appears

screenshot: maximzed firefox on lower screen, seen in screen's menu bar

here is the output of xrandr:
Screen 0: minimum 320 x 200, current 1920 x 1968, maximum 4096 x 4096
LVDS1 connected 1024x768+0+1200 (normal left inverted right x axis y axis) 246mm x 185mm
[...]
VGA1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
[...]

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.14-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,copytex,compiztoolbox,decor,imgpng,gnomecompat,shift,mousepoll,grid,regex,animation,wall,place,move,snap,resize,expo,ezoom,workarounds,session,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 1024x768 1024x768 800x600 640x480
 edid-base64: AP///////wAwrgBAAAAAABYQAQOAGRJ46s11kVVPiyYhUFQhCABhQAEBAQEBAQEBAQEBAQEBKBUAQEEAJjAYiDYA9rkAAAAY7RAAQEEAJjAYiDYA9rkAAAAYAAAADwBhQzJhQygSAQAwZABTAAAA/gBMVEQxMjFFQ0hCCiAgAE0=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x800 1280x800 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAas7AGAQAAAB4TAQNoNCB4Ku6Vo1RMmyYPUFSlSwCBgIEAgQ+VAJUPqUCzAAEBKDyAoHCwI0AwIDYABkQhAAAaAAAA/QA4TB5SEAAKICAgICAgAAAA/ABCMjRXLTUKICAgICAgAAAA/wBZRTZRNTA1OTU4CiAgACo=
Date: Wed Jun 22 09:57:21 2011
DistUpgraded: Log time: 2011-05-26 11:46:08.263264
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.0.8, 2.6.38-8-generic, i686: installed
GraphicsCard:
 Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Lenovo ThinkPad T60/R60 series [17aa:201a]
   Subsystem: Lenovo ThinkPad T60/R60 series [17aa:201a]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
InstallationMedia_: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
InstallationMedia__: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MachineType: LENOVO 170255G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=/dev/mapper/crypt-root ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-05-26 (26 days ago)
dmi.bios.date: 11/20/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 7BETD7WW (2.18 )
dmi.board.name: 170255G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7BETD7WW(2.18):bd11/20/2008:svnLENOVO:pn170255G:pvrThinkPadX60s:rvnLENOVO:rn170255G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 170255G
dmi.product.version: ThinkPad X60s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

harald (harald-net) wrote :

The behaviour described isn't quite what I get. What happens is that the window that was maximized in the lower monitor doesn't quite maximize all of the way. There is still a significant part of the bottom screen which just shows the background. Everything else seems to work okay though. A screenshot is attached to illustrate.

Omer Akram (om26er) on 2011-06-23
tags: added: multimonitor
David Barth (dbarth) wrote :

This bug was reported on a development snapshot of Unity but lacks elements for it to be actionable:
- there seems to be no reports of further occurences of the issue
- the bug cannot be reproduced reliably
- the information provided is not sufficient to track down the issue to a particular programming error.
Could you please check if this issue is present in the current version, and if it is reopen the bug to a NEW status.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
To post a comment you must log in.