Workspace switcher bindings do not always work?

Bug #800278 reported by appelblim on 2011-06-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Switching between workspaces after closing windows on the current workspace fails due to focus remaining on the closed window. Also any other unity hotkeys won't work before clicking at the desktop, i.e. losing focus of the already closed window. Please refer also to
http://askubuntu.com/questions/49670/workspace-switcher-bindings-do-not-always-work

Is there any workaround ?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,snap,titleinfo,grid,vpswitch,mousepoll,imgpng,gnomecompat,regex,animation,unitymtgrabhandles,resize,place,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1200 1600x1200 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLSUENDJEVAoSAQOANCB4Ku6Ro1RMmSYPUFS/74CpQIGAgUBxTwEBAQEBAQEBKDyAoHCwI0AwIDYABkQhAAAaAAAA/QA4Sx5REQAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBIMUFLNTAwMDAwCiAgAF0=
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLZMBOTFJQgkQAQMOJh54Kt6Vo1RMmSYPUFS/74CBgIFAcU8BAQEBAQEBAQEBMCoAmFEAKkAwcBMAeC0RAAAeAAAA/QA4Sx5RDgAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBITUNMMzAxNzYwCiAgACk=
Date: Tue Jun 21 18:10:08 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0102]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=d26731e9-cb65-4bf8-a430-80db4b8b1ed7 ro vga=773 quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/21/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.10
dmi.board.name: H67M-ITX
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.10:bd02/21/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH67M-ITX:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

appelblim (docvanrock) wrote :

Hi,

This is quite difficult to reproduce. If you could perhaps try and identify a concrete sequence of actions (i.e. which applications are involved as well) then maybe someone can confirm this problem and we can get the information that's needed to start working on it,

Thanks,

Changed in unity (Ubuntu):
status: New → Incomplete
appelblim (docvanrock) wrote :

It doesn't matter which application I start, at least I could reproduce this behaviour with every one I tried.
So:
1) Open up any application you like, f.e. the gnome terminal, on a empty workspace.
2) Close it, f.e. by pressing Alt+F4 - it doesn't actually matter which way you close it.
 => Somehow the main focus remains on the already dismissed window, i.e. it shows up at the top panel.
In the discribed case it would look like that:
1) I press ctrl+alt+T -> gnome terminal appears
2) I close it by pressing alt+F4
3) The default unity top panel still reads "Terminal" and I still can click on the menu of the gnome terminal.
    Now the unity keybindings, f.e. ctrl+alt+[left/right/up/down] or even the print button do not work.
4) After clicking at the desktop it vanishes and the focus is lost => the unity hotkeys are usable.

Someone over at askubuntu.com [http://askubuntu.com/questions/49670/workspace-switcher-bindings-do-not-always-work] said it may be up to the setting for the focus tracking behaviour in CCSM, but I tried every of the mentioned options there and it didn't change anything.

I'm sorry that the title of this thread is misleading - I simply wasn't aware of the fact that not only the workspace switcher doesn't work but all of unitys keybindings.

Bilal Akhtar (bilalakhtar) wrote :

Does nautilus draw your desktop? In other words, are you able to add desktop icons to the desktop? If not, then its a known issue.

Changed in unity:
status: New → Incomplete
appelblim (docvanrock) wrote :

Yes, I am able to add desktop icons. Nautilus does draw my desktop.

Bilal Akhtar (bilalakhtar) wrote :

Could you check if running unity --reset fixes the issue?

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Karl Mai (docvanrock-5) wrote :

Actually I got fed up by unity's epic failures ... So I moved away from Ubuntu at all - Fedora is my new/old home ... Thank you for your kind help though :)

appelblim (docvanrock) wrote :

Oh - my 2. account - Karl Mai = me :>

Omer Akram (om26er) wrote :

Thanks for your bug report. Can you please test and let us know if it is still an issue in Ubuntu 12.04 with all updates applied.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Andreas Raster (rakete) wrote :

I think I might have had this issue and now the latest update seems to have fixed it. At least I can't reproduce the behaviour right now and I am pretty sure that before, whenever I closed the last window on a desktop, the switch desktop left/right keys would stop working until I selected/started another application.

Omer Akram (om26er) wrote :

Closed this bug since the reporter don't use Ubuntu anymore. and the fact the issue is fixed for Andreas

Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in unity:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers