Blank screen after suspend

Bug #798935 reported by Ashwin Saval on 2011-06-17
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

After suspend or closing laptop lid with option of "Blank Screen" after closing of laptop lid in Power Preferences, if lid is opened after a long time(approx. 20mins or more), the screen is blank with the option missing for entering password and logging back in, into the suspended system. This results in the need to shut down the Laptop manually (by long pressing the power button) and restarting the system.
---
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
NonfreeKernelModules: wl
Package: unity 3.8.14-0ubuntu1~natty1
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Tags: natty running-unity natty running-unity natty running-unity ubuntu
Uname: Linux 2.6.38-8-generic-pae i686
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ashwin Saval (ashwinsaval) wrote :

Supplementary Information:
-The Laptop is a Dell Inspiron 1545
-Intel Core2Duo 2.2 Ghz
-Intel Graphics
-Running Windows 7 Ultimate and Ubuntu "Natty Nahrwal" 11.04.
-The interface used is the default Unity interface

Thanks for reporting a bug and making Ubuntu better.

More information would be needed in order to diagnose your problem. First, the best way to report a bug is to press ALT-F2 and enter ubuntu-bug followed by the name of the package you have an issue with (for instance "ubuntu-bug unity").

Second, has this problem appeared when you upgraded to 11.04? Does it happen if you suspend from "Ubuntu Classic" instead than from "Unity" ("Ubuntu")?

It may be that your issue is with the Linux kernel, usually responsible of freezes on suspend/hibernate.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Ashwin Saval (ashwinsaval) wrote :

Thanks Walter, in response to your queries, i have replied, each query at a time.

First :
While running in Unity, I tried opening Ubuntu bug, but there was no response. It showed up, but on clicking it, there was no response.

Second:
This problem has occurred only in Ubuntu 11.04. I was using 9.04 before this without any problems whatsoever.
This was a fresh installation from ground up. It doesn't happen often, only if I leave it for a long long time. Like an hour or so.

I haven't tried it on Ubuntu classic, but I don't think there must be cause for concern. I shall try it nevertheless and revert back to you.

Furthermore, if permissible, I would like to report other bugs in Unity too.
Firefox seems to crash or hang often. Sometimes it refuses to open a link in a new tab. Now switched to Chromium.
If one of my disks is mounted in one profile, it totally "disappears", if i switch to another profile. I have to go back and unmount it in the original profile and then it is visible in the other profile.
Unity prone to hanging, that too with the new kernel.

PS: All that said, I absolutely love the new unity, wasn't much of a fan of the first one(my netbook runs 10.10), but absolutely love the new one. Hope the bugs are sorted out for an even more fun experience.

It is important that you also tried with Ubuntu Classic, as the problem of suspending may be a problem with the Linux kernel and not Unity.

Also, to complete the information in this bug run the command "apport-collect bug_number" via "Run Application" or terminal window., that is

apport-collect 798935

As for the other bugs try to open specific bugs for each one. Usually "ubuntu-bug <package>" should work to report your bugs.

Ashwin Saval (ashwinsaval) wrote :

Update:
1. I disabled the lock screen automatically option as well as suspend on idle option.

2. Again left the Laptop idle for a while. This time it didn't get stuck at the blank screen, but at what was on the screen before I left it idle. Which means it isn't problem with suspend mode. It gets stuck if left idle.

3. When restarted the Laptop, Ubuntu would not boot, showed black screen wit initrd(i think) error. Deduced the error solution from forums and re-installed the component of the kernel using sudo update-initramfs .....

4. Haven't deduced yet if its a kernel problem, but I'm wondering how the kernel crashed?

PS: Working on classic ubuntu, but have to wait as it crashes only occasionally, only if i leave it idle for a long long time.

tags: added: apport-collected natty running-unity ubuntu
description: updated

apport information

apport information

Update:

After running Ubuntu Classic desktop for a week:

1. No issues, no hanging after suspend or laptop lid closure.

2. Left laptop on all night, screen blank and it continued effortlessly next morning. NO issues whatsoever.

So, my guess is that the Unity interface is having problems with my laptop.

Ashwin Saval (ashwinsaval) wrote :

Latest Update:

Ubuntu crashed with classic desktop as well!

Just to try, I closed the laptop lid, and removed my wired lan connection.

This morning as I opened the lid, the screen was hung.

Mouse worked, but screen was stuck with the LAN connection shown as connected.

Inferences:
The system possibly hangs when lid is closed and some hardware change occurs. (Like unplugging lan, unplugging power supply, switching off power supply, etc..)

So not a Unity issue after all.

Thanks for the update. So somebody with a system equal or similar to your sytem will have to be able to reproduce and confirm.

affects: unity → linux
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in linux:
status: Incomplete → New
summary: - Unity blank screen after suspend
+ Blank screen after suspend

Take a look at Bug #776468 . It is reported there that an overheating problem may be happening in your model and a workaround is given.

Ashwin Saval (ashwinsaval) wrote :

Thank you Walter:

I went through the bug report, but I have to say that I haven't had any overheating issues (yet).

To reiterate, I have just recently installed 11.04, the Laptop was working on 9.04 flawlessly up until last month, after which I installed 11.04, because of lesser and lesser legacy support.

Have to say that 11.04 has 'more' bugs than 9.04, yet I absolutely love the new Unity interface.

Ashwin Saval (ashwinsaval) wrote :

Was in a fix about where to report another bug:

I have a bug at Login, i.e, it does not recognize the 'Enter' button press as accept password

and

You have to long press a button for it to type, for instance:
   You press A, but it wont detect or even type A, you need to long press and hold A, till it types.

These errors happen only at login (The login screen that is).

This should be reported against "gdm", that is from a terminal you can enter "ubuntu-bug gdm"

Ashwin, are you still seeing the issue originally reported in this bug?

Changed in linux:
status: New → Incomplete
Ashwin Saval (ashwinsaval) wrote :

Dear Walter,
I've switched to Ubuntu 11.10. But yes, once or twice I have noticed the same bug occurring in this version. But the frequency is much lower. I think only once or twice as far as I remember. I've been using this version since October 2011.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers