unity-panel-service crashed with SIGSEGV in g_cclosure_marshal_VOID__PARAM()

Bug #798078 reported by Jean-Baptiste Lallement on 2011-06-16
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: unity

I got this crash together with bug 798074 following the same steps

TEST CASE:
1. Open gnome-control-center
2. Go to Universal access
3. Enable accessibility (Set Screen reader to ON)

Result:
unity-panel-service starts dying and respawning.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 3.8.14-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-0.1-generic 3.0.0-rc2
Uname: Linux 3.0-0-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,imgpng,regex,resize,mousepoll,vpswitch,grid,move,resizeinfo,place,snap,animation,session,wall,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CrashCounter: 1
Date: Thu Jun 16 10:26:58 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity/unity-panel-service
ProcCmdline: /usr/lib/unity/unity-panel-service
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_US.utf8
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.utf8
SegvAnalysis:
 Segfault happened at: 0x6b4c704: mov 0xc4(%eax),%eax
 PC (0x06b4c704) ok
 source "0xc4(%eax)" (0x000000ec) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? () from /usr/lib/gtk-2.0/modules/libgail.so
 g_cclosure_marshal_VOID__PARAM (closure=0x9cedca8, return_value=0x0, n_param_values=2, param_values=0x9cf3918, invocation_hint=0xbfe5c9f0, marshal_data=0x0) at /build/buildd/glib2.0-2.29.8/./gobject/gmarshal.c:533
 g_closure_invoke (closure=0x9cedca8, return_value=0x0, n_param_values=2, param_values=0x9cf3918, invocation_hint=0xbfe5c9f0) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771
 signal_emit_unlocked_R (node=0x9bb2bc0, detail=254, instance=0x9c33130, emission_return=0x0, instance_and_params=0x9cf3918) at /build/buildd/glib2.0-2.29.8/./gobject/gsignal.c:3256
 g_signal_emit_valist (instance=0x9c33130, signal_id=1, detail=254, var_args=0xbfe5cba0 "\320\a\302\t\002") at /build/buildd/glib2.0-2.29.8/./gobject/gsignal.c:2987
Title: unity-panel-service crashed with SIGSEGV in g_cclosure_marshal_VOID__PARAM()
UpgradeStatus: Upgraded to oneiric on 2011-05-16 (30 days ago)
UserGroups: adm admin audio cdrom dialout dip floppy fuse libvirtd lpadmin netdev plugdev scanner sudo video

Jean-Baptiste Lallement (jibel) wrote :

StacktraceTop:
 gail_widget_notify_gtk (obj=0x9c33130, pspec=0x9bcde00) at /build/buildd/gtk+2.0-2.24.4/modules/other/gail/gailwidget.c:959
 g_cclosure_marshal_VOID__PARAM (closure=0x9cedca8, return_value=0x0, n_param_values=2, param_values=0x9cf3918, invocation_hint=0xbfe5c9f0, marshal_data=0x0) at /build/buildd/glib2.0-2.29.8/./gobject/gmarshal.c:533
 g_closure_invoke (closure=0x9cedca8, return_value=0x0, n_param_values=2, param_values=0x9cf3918, invocation_hint=0xbfe5c9f0) at /build/buildd/glib2.0-2.29.8/./gobject/gclosure.c:771
 signal_emit_unlocked_R (node=0x9bb2bc0, detail=254, instance=0x9c33130, emission_return=0x0, instance_and_params=0x9cf3918) at /build/buildd/glib2.0-2.29.8/./gobject/gsignal.c:3256
 g_signal_emit_valist (instance=0x9c33130, signal_id=1, detail=254, var_args=0xbfe5cba0 "\320\a\302\t\002") at /build/buildd/glib2.0-2.29.8/./gobject/gsignal.c:2987

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Didier Roche (didrocks) on 2011-06-20
Changed in unity (Ubuntu):
importance: Medium → Critical
visibility: private → public
Michael Terry (mterry) on 2011-06-20
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

It is reproducible on systems upgraded from Natty.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Daniel Manrique (roadmr) wrote :

Hello,

I reported this behavior as bug 810145. That bug's trace is slightly different, and to be fair on recent Oneiric builds I get the trace from *this* bug instead. I'm commenting here in case the other bug should be set as a duplicate of this one.

I got this in an Oneiric network installation with accessibility enabled in the preseed file by doing this in the late_command:

gconftool-2 --set --type bool /desktop/gnome/interface/accessibility true

I confirmed that setting that to false and then restarting the session makes the problem go away, i.e. the panel stops dying/respawning.

Let me know if more information or testing is needed or if I can help in any other way.

Jean-Baptiste Lallement (jibel) wrote :

Cannot reproduce. Closing.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers