Can't drag Quassel to launcher (other apps work)

Bug #796207 reported by 3vi1 on 2011-06-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10
unity:
  Installed: 3.8.14-0ubuntu2

Every other app icon that I've tried to drag from the dash to the launcher works. But, when I try to drag the quassel icon from the dash to the launcher the icon simply disappears when I release it. During the process, the launcher does open up a position and show the "Drop To Add Application" pop-up, like normal - only when it is released the launcher behaves as if you did not drop the icon on it.

I have been able to recreate this bug inside a VM, so I do not believe it is specific to my machine.

affects: ubuntu → unity (Ubuntu)
Bilal Akhtar (bilalakhtar) wrote :

I think this is because the Quassel desktop file is in the /usr/share/applications/kde4/ directory, while Unity only takes interest in desktop files which are in /usr/share/applications/ or /usr/local/share/applications or ~/.local/share/applications.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed

Retested with current updates; this now appears to be fixed.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers