Clicking the first item on launcher starts it moving sometimes

Bug #793593 reported by Steven Weston on 2011-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Expired
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Occasionally when I click (sometimes accidentally) on the first item in the launcher, which I have as gnome-terminal (it may occur with other items in the launcher, but I haven't experienced it), it tries to move the icon. This would probably be okay if I were clicking and dragging it to try to move it, but I'm not, I'm just clicking on it (there may be some movement of the mouse that's causing it, but it's not deliberate). It detaches the icon from the launcher and leaves it hovering somewhere nearby. I can move my mouse around, but it doesn't move the icon. It is as if the icon is stuck. Clicking somewhere on the launcher again seems to fix it but clicking on the hovering icon does nothing.
It is not very reproducible because I cannot determine under which situations it occurs. I have not managed to deliberately cause it. I just now tried clicking randomly on the icon with various small mouse gestures (and also no movement) and it didn't happen. However, I did manage (twice) to do something similar. I managed to get all the icons to move down as if I were dragging all the icons down. They got stuck, even though I had let go of the mouse button and was moving the pointer around the screen freely. Again, clicking anywhere on the launcher but them back in place. It is as if the launcher is not correctly recognising ButtonRelease events.
I actually just now (in a second session of attempts) managed it but in my frantic clicking reset it before I could get a screenshot. : ( I suppose a screenshot wouldn't provide much information though.
This has happened with both my laptop's touchpad and my desktop's mouse (on those machines respectively, both fresh installs) so it is probably not to do with hardware.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.14-0ubuntu1~natty1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,gnomecompat,titleinfo,regex,zoom,grid,put,vpswitch,resize,commands,move,animation,compiztoolbox,winrules,expo,snap,mousepoll,imgpng,mag,blur,place,wall,resizeinfo,ezoom,unitymtgrabhandles,workarounds,switcher,staticswitcher,obs,session,fade,scale,scaleaddon,unityshell]
Date: Mon Jun 6 15:25:47 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110413)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :

I have just been able to reproduce this bug without any specific steps it just happens when you drag the top launcher diagonally to the upper left to upper right side and then leave it for a few time. After 15-minutes of testing I still dont have any steps, but it happens

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

is that still an issue with oneiric or precise version?

Omer Akram (om26er) wrote :

I have not seen it since.

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers