Unity fails to redraw the screen using URxvt

Bug #790516 reported by Camille Moncelier on 2011-05-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Expired
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

When using rxvt-unicode with unity (Using nouveau, the nvidia driver, fglrx or radeon). Unity tends to fail to redraw properly the screen. This does not happen under ubuntu-classic.

This might be related: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/756560

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,vpswitch,compiztoolbox,place,session,gnomecompat,mousepoll,regex,grid,resize,animation,snap,move,wall,imgpng,unitymtgrabhandles,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAQrDDQTDIxMBMUAQMOMBt47u6Vo1RMmSYPUFSlSwBxT4GA0cABAQEBAQEBAQEBAjqAGHE4LUBYLEUA3QwRAAAeAAAA/wBENTUzUjA1RzAxMkwKAAAA/ABERUxMIEUyMjEwSAogAAAA/QAyTB5TEQAKICAgICAgAOs=
Date: Tue May 31 09:31:34 2011
DistUpgraded: Log time: 2011-04-27 08:42:18.946773
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.0.4, 2.6.35-28-generic-pae, i686: installed
 vboxhost, 4.0.4, 2.6.38-8-generic-pae, i686: installed
 fglrx, 8.850, 2.6.38-8-generic-pae, i686: installed
GraphicsCard:
 ATI Technologies Inc Cedar PRO [Radeon HD 5450] [1002:68f9] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:010e]
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
InstallationMedia_: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
InstallationMedia__: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MachineType: Dell Inc. Studio XPS 7100
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=507a9939-cd08-4032-8aa9-918b707587d8 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-27 (33 days ago)
dmi.bios.date: 05/27/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0FF3FN
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd05/27/2010:svnDellInc.:pnStudioXPS7100:pvr:rvnDellInc.:rn0FF3FN:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: Studio XPS 7100
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Camille Moncelier (camille-5) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Omer Akram (om26er) on 2011-08-23
Changed in unity:
status: Incomplete → Invalid
Alexey Bazhin (baz-irc) wrote :

The same bug is affecting me (tested with both nvidia and nouveau drivers). For me it is not reprodusable, but happens a lot, there is no half an hour using terminal when it is not happened. I'm using latest oneiric (updated today morning). Screenshots are here:
http://files.yume.ru/files/urxvt.png (when corruprion happend)
http://files.yume.ru/files/urxvt-good.png (when i swiched tabs in urxvt forth and back it redraw)

Changed in unity (Ubuntu):
status: Expired → New
Leandro A. F. Pereira (lafp) wrote :

Also affects me; Alexey's screenshot is exactly what I see here. Up-to-date Oneiric, awesome 3.4.10 window manager, urxvt 9.12, Intel HD Graphics 3000. Didn't test under Unity or GNOME.

Using gnome-terminal for the time being.

Sebastien Bacher (seb128) wrote :

is that still an issue in precise?

Changed in unity (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Changed in unity:
status: Invalid → Incomplete
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

[Expired for unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers