full-screen window mode doesn't work on lower of two monitors in extended workspace under Unity

Bug #788240 reported by Christopher Barrington-Leigh on 2011-05-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: unity

Alt-F10, the default for expanding a window to full-screen, has no effect in the lower of two monitors in an extended desktop.
In the upper monitor, it snaps nicely back and forth to full screen. In Compiz / 10.10, it worked nicely by snapping to the local full-screen in either upper or lower display.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.3:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1440x900 1440x900
 edid-base64: AP///////wAwrjZAAAAAAAASAQOAHhN46uWVk1ZPkCgoUFQAAAABAQEBAQEBAQEBAQEBAQEBwSmg5FGEGjAwIDYAL74QAAAZ3iKgLFGEfjAwIDYAL74QAAAZAAAADwCVCjKVCigeCQBMo0JUAAAA/gBMVE4xNDFCVDA4MDAxAMs=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1680x1050 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x960 1152x864 1024x768 1024x768 832x624 800x600 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebbNWgDoDAAsSAQNqMSB46q7FoldKnCUSUFSna4CVD5UAgYCBQHFPAQEBAQEBfC6QoGAaHkAwIDYA2igRAAAaITmQMGIaJ0BosDYA2igRAAAcAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABXMjI0MQogICAgICAgAEg=
Date: Wed May 25 09:58:50 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21c1]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: LENOVO 2901CTO
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=7bcaa9ff-22c9-4574-b9f1-04b21eff087a ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/16/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET54WW (1.34 )
dmi.board.name: 2901CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET54WW(1.34):bd09/16/2010:svnLENOVO:pn2901CTO:pvrThinkPadT410s:rvnLENOVO:rn2901CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2901CTO
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → iteration-2
Changed in unity (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → oneiric-alpha-2
Sam Spilsbury (smspillaz) wrote :

Hrm, I can't seem to reproduce this one. Can you explain what you mean by "fullscreen" here? I've tried both the bindings for fullscreen and /maximize/ (alt-f10) on both monitors in a top/bottom arrangement and I didn't see any problems.

Remarkably, this behaviour has changed a lot and for the better after a recent update (this week?).
 I assume that means I'm benefiting from backports. I don't have handy a system with the initial 11.04 distribution, but I think a lot of problems I've reported have been helped (without assignment from my bugs) since then. (It would sort of be nice to have launchpad reflect the real perfomance with which the distro went out, though --- presumably not everyone can update as easily).

So, if I drag a maximised window from my top screen to my bottom screen, it now jumps to maximised as it should (didn't before).
If I alt-f10 a window currently in bottom, it jumps to max in bottom, as it should (didn't before).
If I drag a window so that mouse is in top bar of bottom screen, I think I get a max state in bottom screen too, though I find it very difficult if the window is coming from the top screen (unmaximised).

There is still a problem with the bottom screen max state, though: the top bar of the window is missing/invisible (ie, behind the unity panel there). It remains visible and working properly when max'd in the top screen.
For instance, in Chrome, the tabs are invisible in the bottom max state. This problem exists for other apps too.

Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Martin Pitt (pitti) on 2011-07-07
Changed in unity (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3

AFter yet another update, things got worse again! Actually, worse than ever. It's back to completely unusable external monitor. If I boot with it plugged in, I get multicolor flashing screen / unusable. If I plug it in after logging, the screen goes black and useless. If I unplug it to recover, I get a black responseless screen with an arrow cursor. I cannot recover and must reboot.
I'm back to early 1990s functionality now under the latest Natty updates. (Very very discouraged)

Download full text (5.4 KiB)

That sounds like an X11/Driver bug to me, not a compiz bug

On Thu, Jul 7, 2011 at 11:42 PM, Christopher Barrington-Leigh
<email address hidden> wrote:
> AFter yet another update, things got worse again! Actually, worse than ever. It's back to completely unusable external monitor. If I boot with it plugged in, I get multicolor flashing screen / unusable. If I plug it in after logging, the screen goes black and useless. If I unplug it to recover, I get a black responseless screen with an arrow cursor. I cannot recover and must reboot.
> I'm back to early 1990s functionality now under the latest Natty updates. (Very very discouraged)
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/788240
>
> Title:
>  full-screen window mode doesn't work on lower of two monitors in
>  extended workspace under Unity
>
> Status in Unity:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: unity
>
>  Alt-F10, the default for expanding a window to full-screen, has no effect in the lower of two monitors in an extended desktop.
>  In the upper monitor, it snaps nicely back and forth to full screen.  In Compiz / 10.10, it worked nicely by snapping to the local full-screen in either upper or lower display.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.04
>  Package: unity 3.8.12-0ubuntu1
>  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>  Uname: Linux 2.6.38-8-generic x86_64
>  Architecture: amd64
>  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
>  CompositorRunning: compiz
>  DRM.card0.DP.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.DP.2:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.DP.3:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.HDMI.A.1:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.HDMI.A.2:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.HDMI.A.3:
>   status: disconnected
>   enabled: disabled
>   dpms: Off
>   modes:
>   edid-base64:
>  DRM.card0.LVDS.1:
>   status: connected
>   enabled: enabled
>   dpms: Off
>   modes: 1440x900 1440x900
>   edid-base64: AP///////wAwrjZAAAAAAAASAQOAHhN46uWVk1ZPkCgoUFQAAAABAQEBAQEBAQEBAQEBAQEBwSmg5FGEGjAwIDYAL74QAAAZ3iKgLFGEfjAwIDYAL74QAAAZAAAADwCVCjKVCigeCQBMo0JUAAAA/gBMVE4xNDFCVDA4MDAxAMs=
>  DRM.card0.VGA.1:
>   status: connected
>   enabled: enabled
>   dpms: Off
>   modes: 1680x1050 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x960 1152x864 1024x768 1024x768 832x624 800x600 800x600 800x600 640x480 640x480 720x400
>   edid-base64: AP///////wAebbNWgDoDAAsSAQNqMSB46q7FoldKnCUSUFSna4CVD5UAgYCBQHFPAQEBAQEBfC6QoGAaHkAwIDYA2igRAAAaITmQMGIaJ0BosDYA2igRAAAcAAAA/QA4Sx5TDwAKICAgICAgAAAA/ABXMjI0MQogICAgICAgAEg=
>  Date: Wed May 25 09:58:50 2011
>  DistUpgraded: Fresh install
>  DistroCodename: natty
>  DistroVariant: ubuntu
>  DkmsStatus: virtualbox-ose, 4.0.4, 2.6.38-8-gen...

Read more...

Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers