no ttys (alt-f1...), can't logout, no compositing, no unity, can't shutdown

Bug #785986 reported by João Pequito Almeida on 2011-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

My screen goes blank whenever i try to go to tty, unity (and compiz) won't start, logging out or shutting down turns my screen into digital noise and i have to shut it down with the power button. everything was fine before the dist-upgrade (including compositing and so on), and i successfully used the ttys if i don't run X.
sorry if this ended up in the wrong place but it's my first bug report! thank you!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-9.43-powerpc 2.6.38.4
Uname: Linux 2.6.38-9-powerpc ppc
Architecture: powerpc
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri May 20 22:44:53 2011
DistUpgraded: Log time: 2011-05-14 10:58:05.079757
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50] (prog-if 00 [VGA controller])
   Subsystem: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] [1002:4e50]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release powerpc (20101008)
InstallationMedia_: Ubuntu 10.10 "Maverick Meerkat" - Release powerpc (20101008)
InstallationMedia__: Ubuntu 10.10 "Maverick Meerkat" - Release powerpc (20101008)
Lsusb:
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 003: ID 05ac:8203 Apple, Inc. Bluetooth HCI
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=/dev/hda3 ro quiet splash
ProcVersionSignature_: Ubuntu 2.6.38-9.43-powerpc 2.6.38.4
ProcVersionSignature__: Ubuntu 2.6.38-9.43-powerpc 2.6.38.4
Renderer: Software
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-05-14 (6 days ago)
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Bilal Akhtar (bilalakhtar) wrote :

Probably an issue with X. Are you able to get to a classic desktop? If not then seems an Xorg issue on powerpc.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
João Almeida (joao+launchpad) wrote :

hello, thanks for the answer. I can use the classic desktop. it's when I try to get a text console (with alt+Fx) that everything goes blank (with random colors and lines too), and turning on compositing or unity fails. my desktop also doesn't refresh correctly, and ends up with a lot of "pieces" of windows that I recently closed. this happens both on metacity and openbox/enlightenment. if I set my desktop to a single solid color, it crashes the screen and i have to force reboot

before the update, I had compiz running perfectly, after the update, no compiz, no unity, and no TTYs. maybe something changed in the support for my graphics card (ati mobility radeon 9600), since it seems to affect all these things at the same time

bugbot (bugbot) on 2011-06-20
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
bugbot (bugbot) on 2011-06-20
tags: added: ppc
Bryce Harrington (bryce) wrote :

Hey joao-hipercubo,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete

yup, you can close it. i've given up ubuntu for now in this particular computer, but i might give the new distro a run. seems to be fairly specific too

thanks

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Incomplete → Invalid
Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers