Ubuntu

Run dialog doesn't use $HOME as the pwd by default when specifying files/directories

Reported by Joaquin on 2011-05-15
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-lens-applications
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned
unity-lens-applications (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

For example, in classic gnome, I can press Alt+f2 and write ".local" or "Documents" or a folder in my home folder and nautilus opens the window.
In unity, I write ".local" for example, and nothing happens, but if I write nautilus .local it runs.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Uname: Linux 2.6.38-9-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CompizPlugins: [core,bailer,detection,crashhandler,composite,opengl,compiztoolbox,imgjpeg,decor,grid,place,vpswitch,mousepoll,imgsvg,resize,dbus,zoom,obs,text,regex,commands,move,winrules,shift,imgpng,gnomecompat,wall,wobbly,animation,expo,animationaddon,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
Date: Mon May 16 01:05:39 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=es_ES:en
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Joaquin (jknvv13) wrote :

I just went looking for this bug report on Launchpad after seeing a question on Ask Ubuntu from someone asking what the right keyboard-based way was in Unity to open a file. (He mentioned being able to hit Alt+F2 and enter the path to a file to open it in classic gnome.) I checked to see what happened, and noticed that the behaviour is a bit odd: hit Alt+F2, then type /home/, and you'll see all the user folders in /home. Type /home/user/ and you'll see all the files and folders in your home directory. You can continue to Documents (for example) and subfolders. However, typing a full path and hitting enter does nothing. Strangely enough, once you get to the folder you want, the files will be displayed below the search bar, and you can click on the one you want. This should really open the file, but it doesn't.

If you tap the Super key instead of Alt+F2, you can select files, but as soon as you start entering a full path, no files show up. (Super + typing /home shows me about half a dozen files, chosen seemingly at random, but these disappear as soon as I continue typing the path.) In my case the file search dialogue fails to find the majority of my files, but that's a different issue.

It supports them if you use full paths e.g. '~/.local', so changing the bug summary

Changed in unity (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
summary: - Run dialog doesn't support files or folders
+ Run dialog doesn't use $HOME as the pwd by default when specifying
+ files/directories
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity-place-applications:
status: New → Confirmed
Changed in unity-place-applications (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-07-22
Changed in unity-2d:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-07-22
no longer affects: unity-place-applications (Ubuntu)
James Henstridge (jamesh) wrote :

Perhaps the glibc wordexp() function, or delegate the job to the shell.

Are you still experiencing this bug in any current supported Ubuntu release? (https://wiki.ubuntu.com/Releases)

Changed in unity-2d:
status: Confirmed → Incomplete
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in unity-lens-applications:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Low

Actually I just gave this a try running 13.04 and noticed the following:
With Alt+F2 I can type in a path, and if I hit enter at a folder, Nautilus opens to that folder. If I enter the full path to a file and hit enter, nothing happens - I have to click on a file.

However, this is probably a non-issue since the expected behaviour occurs if I use the Unity dash (Super key) instead of Alt-F2.
So I'd say it's running fine: you can open folders with Alt-F2 if you want, but documents are accessed from the dash, which by my understanding is how things are supposed to work in Unity anyway.

no longer affects: unity
no longer affects: unity-2d
Changed in unity-lens-applications:
importance: Undecided → Wishlist
status: Incomplete → Won't Fix
Changed in unity (Ubuntu):
status: Incomplete → Invalid

Since this bug has a status of 'Won't Fix' for the main project (unity-lens-applications), it also has this status for the Ubuntu's one.

Changed in unity-lens-applications (Ubuntu):
status: Incomplete → Won't Fix

Since this bug has a priority of 'Whishlist' for the main project (unity-lens-applications), it also has this status for the Ubuntu's one.

Changed in unity-lens-applications (Ubuntu):
importance: Low → Wishlist
Changed in unity (Ubuntu):
importance: Low → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers