Ubuntu

unity crashed with NameError in reset_unity_compiz_profile(): global name 'GError' is not defined

Reported by BkoChan on 2011-05-06
312
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Unity
High
Didier Roche
5.0
High
Didier Roche
unity (Ubuntu)
Medium
Unassigned
Precise
High
Didier Roche

Bug Description

[Test Case]
No obvious test case, just making sure the crash does not happen.

[Regression Potential]
No regression potential.

Original description:

Binary package hint: unity

changed the focus animation of all windows to fade

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Fri May 6 12:20:35 2011
ExecutablePath: /usr/bin/unity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcCmdline: /usr/bin/python /usr/bin/unity --reset
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/unity', '--reset']
SourcePackage: unity
Title: unity crashed with NameError in reset_unity_compiz_profile(): global name 'GError' is not defined
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

lp:~didrocks/unity/fix-gerror-import
Rejected for merging into lp:unity
jenkins (community): Needs Fixing (continuous-integration) on 2012-06-28
Unity Team: Pending requested 2012-06-28
Merged into lp:unity/5.0 at revision 2378
Sam Spilsbury (community): Approve on 2012-06-29
lp:~didrocks/unity/fix-gerror-triggering
Merged into lp:unity at revision 2455
Sam Spilsbury (community): Approve on 2012-06-29
jenkins (community): Approve (continuous-integration) on 2012-06-28
BkoChan (bko-san) wrote :
tags: removed: need-duplicate-check
Omer Akram (om26er) on 2011-06-08
visibility: private → public
Sam_ (and-sam) wrote :

Still the case on an up-to-date Oneiric. If needed, crash file is still in /var/crash which I was about to upload via apport, but found this bug and only confirmed.
Reproducable.
Disable automatic plugin sorting in CCSM. Enable cube, rotate and switcher, disable wall and staticswitcher. Enable automatic plugin sorting. Panel disrupts, desktop gets emptied. No keystrokes work, hardreset, recovery mode root shell gives the topic message when trying to reset Unity. Didn't let me mount encrypted /home either in order to remove files.
Never got back a working desktop and wanted to reinstall with usb-stick, which didn't boot, but was displayed on the empty desktop. Double click on usb-stick opened Nautilus, removed recently changed session files and compizconf, which resulted in bringing back launcher and panel. Conclusion for now, rather leave CCSM alone.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
C de-Avillez (hggdh2) wrote :

In my case, easily reproducible: on a dual-monitor setup, all I have to do is run 'unity --reset &'. Crashes every time.

BTW, I ran --reset for bug 833130.

Xavier Fung (xavier114fch) wrote :

I have tried running unity --reset from a Terminal (byobu) and it crashes. This is done within a Gnome Classic session running Gnome 3.2, and just a single monitor setup.

Magnus (koma-lysator) wrote :

unity --reset segfaults for me on 11.10.

Erik Hedin (3-erib-f) wrote :

The issue that I had was a compiz config file in the ~/.compiz-1 directory. Once I deleted that unity --reset was able to bring back unity 3d.

unity --reset segfaults for me on Ubuntu 12.04 LTS

tags: added: precise
Changed in unity (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Didier, could you look at trapping that error? The issue got reported a bit over 600 times on errors.ubuntu.com this month, which means quite some users see whoopsie due to it, not sure the bug is worth tracking and fixing since that's on the reset command but we should at least catch it I guess, what do you think?

Changed in unity (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Didier Roche (didrocks)
status: Confirmed → Triaged
Didier Roche (didrocks) on 2012-06-28
Changed in unity (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Fix Committed
Didier Roche (didrocks) on 2012-06-28
Changed in unity (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity:
milestone: none → 6.0
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in unity (Ubuntu Precise):
status: Fix Committed → In Progress

Hello BkoChan, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Alan Pope ㋛ (popey) on 2012-07-24
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity - 5.14.0-0ubuntu1

---------------
unity (5.14.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Unity launcher shows internal partitions after they have been unmounted
      (LP: #994163)
    - can't click to dismiss hud in the area where dynamic hud results are
      meant to appear (LP: #962651)
    - Spread/Scale should exit if Dash is invoked (LP: #944033)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dash - The search bar gets the focus when pressing invalid keys
      (LP: #931393)
    - unity crashed with NameError in reset_unity_compiz_profile(): global name
      'GError' is not defined (LP: #778470)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      from unity::UnityWindow::glPaint() (LP: #851982)
    - "Keyboard Shortcuts" overlay can cause annoyance (LP: #934062)
    - padding between last quicklist item and bottom edge is non-deterministic
      (changes randomly) (LP: #955158)
    - HUD Draws improperly while searching for results (LP: #932531)
    - compiz crashed with SIGSEGV in
      unity::ui::KeyboardUtil::GetKeycodeAboveKeySymbol() (LP: #920258)
    - Launcher - when a user starts dragging a item, any folded launcher icons
      that are valid drop receptacles should unfold (LP: #839717)
    - Dragging image from firefox/chrome to dock causes lagg/freeze
      (LP: #772445)
    - dash should open when pressing "super" in scale mode (LP: #1023811)
    - Multimonitor, Launcher - When the Launcher is set to autohide and
      'Sticky edges' are turned off, 'Launcher Edge Stop Overcome Pressure'
      seems to be broken when revealing the Launcher (LP: #987955)
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Purchased items are not being added to the Unity launcher (LP: #925014)
    - Unity Launcher Fails To Auto-Hide When Enabled & Installing Commercial
      Software (LP: #1002440)
    - Regression: shift+click on a launcher icon to open a new application
      instance gone (LP: #754565)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Duplicated applications icons on quick application restart (LP: #1003574)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - alt-backtick flickers between windows (LP: #987156)
    - [Hud] The result grid is not drawn in proximity of the search entry
      (LP: #1008603)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - [hud] The last button is not rounded (LP: #1008656)
    - Hud flickers when show up (LP: #1011507)
    - Dash maximise button changed location (LP: #987674)
    - launcher reordering "line" doesn't go to the bottom slot (LP: #971421)
    - Dash/HUD should close on "Spread" (LP: #870284)
    - Nothing should be written into the dash/hud searchbar whe...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions