windows disapear when moved using workspace switcher

Bug #778233 reported by Thomas on 2011-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: unity

Start an X application (I used xlogo from an xterm)
Right-click on the menu-bar and select "Always on Visible Workspace"
Bring up the workspace switcher (super-S)
Left-click drag the app from any workspace into a different workspace
Expected behavior: "Always on Visible Workspace" is disabled and the app appears in the destination window
Observed behavior: The app will disappear, apparently without terminating (i.e. xterm still has it running, pidof still finds it)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Fri May 6 10:51:53 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc RS880 [Radeon HD 4200] [1002:9710] (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
JockeyStatus: xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Gigabyte Technology Co., Ltd. GA-MA785GT-UD3H
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=920e6878-b6db-427c-870a-dd2f83096ba3 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/03/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: GA-MA785GT-UD3H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd12/03/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA785GT-UD3H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA785GT-UD3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA785GT-UD3H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Thomas (thomas-sprinkmeier) wrote :
Harry van Haaren (harryhaaren) wrote :

Tried to reproduce here, upon starting xlogo, and hitting "Always visible on workspace", then doing <super-S> i get the screenshot attached. So I can't move it to another workspace, its already there. Marking as incomplete.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Mikołaj (novemberox) wrote :

I have the same problem. What more info do you need?

I have ubuntu 11.04, using nvidia-drivers-current. I don't have natty proposed turned on. I'm using dual monitors, with absolute positioning.

Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.4.0
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers