Ubuntu

Panel disappears after enabling Window Previews in Compiz

Reported by Attila Bukor on 2011-05-03
54
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Wishlist
Unassigned
unity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: unity

I'm using Ubuntu 11.04 Natty Narwhal, Unity 3.8.12-0ubuntu1 and Compiz 1:0.9.4+bzr20110415-0ubuntu2.

I enabled Window Previews in Compiz and it made the Unity panel disappear. When I deactivated it, it didn't come back, however I could use the 'power button' in the top-right corner and it appeared normally so I could log out and log back in. After the log in the panel worked regularly.

I could repeat the bug.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.12-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,regex,imgpng,gnomecompat,vpswitch,unitymtgrabhandles,animation,move,expo,resize,place,snap,grid,mousepoll,workarounds,session,wall,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1920x1080 1680x1050 1280x1024 1280x1024 1440x900 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAEaasiOLMAACAUAQNoLxp4KscgpFVJmScTUFS/7wBxT4FAgYCVALMA0cABAQEBAjqAGHE4LUBYLEUA3QwRAAAeAAAA/wBBOExNVEYwNDU4ODAKAAAA/QA3Sx5VEAAKICAgICAgAAAA/ABBU1VTIFZIMjIyCiAgAE4=
Date: Tue May 3 16:43:45 2011
DistUpgraded: Log time: 2011-05-03 10:22:03.670832
DistroCodename: natty
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e32] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:836d]
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101008)
InstallationMedia_: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101008)
InstallationMedia__: Kubuntu 10.10 "Maverick Meerkat" - Release i386 (20101008)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic-pae root=UUID=48976e1a-81ce-4446-9ef1-b643d2e6d1ff ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-05-03 (0 days ago)
dmi.bios.date: 12/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0204
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: V-P5G41E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0204:bd12/21/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnV-P5G41E:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Attila Bukor (r1pp3r-j4ck) wrote :
Mo-Yu Mandy Zhou (zhou-mandy) wrote :

This also happens for me with other Compiz functions, such as the Application switcher. Logging out and back in makes the panel go back to normal, and the plugins also work if you don't switch them back, but it is an annoyance having to do so.

happens for me too - doing almost anything in ccsm causes the top panel, or the launcher icons or both to become corrupt or invisible. Only a logout/login or a "compiz --replace" causes them to be restored (the latter also causing all desktops to become shuffled and all terminal windows to be resized and relocated). It happens so often, it's almost impossible not to trigger it.

Another good one is changing the ccsm setting for which windows have shadows drawn (Window Decoration -> Shadow Windows). I don't want shadows on my conky window, but changing it from the default "any" to pretty much anything else causes compiz to crash and restart not just once, but every time a popup menu is displayed plus several other events. Worked fine in all previous releases.

Staggers me how much stuff is now just being rushed into Ubuntu with little to no testing :(

Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-06-20
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-07-17
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist

Are you still experiencing this bug in any current supported Ubuntu release (https://wiki.ubuntu.com/Releases)?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Attila Bukor (attila-bukor) wrote :

No idea, switched to ArchLinux and XFCE a few months after reporting this bug. Someone else please answer this!

> No idea, switched to ArchLinux and XFCE a few months after reporting
> this bug. Someone else please answer this!

Likewise.. I stopped using Ubuntu a long time ago because of far too many
issues like this. (Funnily enough I also use Arch/XFCE pretty much
exclusively on non-server machines :) )

--
Darren Davison
Public Key: 0xE855B3EA

I was considering this too a long time ago, but I thought it will be more interesting making you regretting of doing so.

So welcome to your next redemption.

Attila Bukor (attila-bukor) wrote :

Well, good for you. By the way, I didn't leave Ubuntu because of the "far too many issues like this" - well, not only at least -, but I wanted to try something else. I've been using Ubuntu since 2005 and it seemed like it's time to dive in to the GNU/Linux world a little bit deeper, and using Gentoo or ArchLinux seemed like the best way to do that, since those need you to understand at least a bit what you're doing as opposed to Ubuntu, which is an awesome OS for users who are less experienced in Linux and IT. Anyhow, I don't think this is the best place to talk about this. So just keep it up guys, I'm happy that there is Ubuntu and a great community!

Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers