close / min / max button location inconsistent with metacity / global app menu settings

Bug #775346 reported by Steve Comrie on 2011-05-02
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Unity
Opinion
Undecided
Unassigned
Baltix
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

I've disabled the Global Appmenu and changed my Metacity configuration to display the minimize / maximize / close buttons on the right hand side of the window.

When I maximize a window with the Appmenu disabled (especially with the buttons on the right), Unity should not move these buttons into the top left corner of the top panel, it should instead function as if I had pressed CTRL+ALT+NUM 5

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Mon May 2 01:57:19 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Steve Comrie (stevecomrie) wrote :
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-05-30
Changed in unity:
status: New → Confirmed

This one could be changed to a medium/low importance yes?

Ronnie (ronnie-10) wrote :

This bug is really annoying, its stopping me from using unity. imagine each time u want to close a maximized window, u need to force urself to go to the left part of the screen when ur mind automatically goes to the right because its used to doing tht.

This bug is indeed pretty annoying. Unity already feels like a Mac-like left-handed OS. The UI is nice, I like where it's going visually but without the minimum customization options that could make it feel "right", it's just inefficient for many of us. This bug is probably the most annoying and what's holding me from using Unity.

heggink (herman-eggink) wrote :

it is particularly annoying if you are also using windoze (with, unfortunately, no option to change). It's a hassle to constantly have to remind yourself what system you are on in order to find the close button. Better yet, I also moved the control buttons to the right and removed the global menu (as needed more similarity with windoze) and now, even within ubuntu, I get confused. The beauty of linux is freedom and choice so hope this gets aligned quickly (thanks in advance).

LeboyX (phreakizzle) wrote :

I'm voicing my own support for fixing this bug. I'm an avid supporter of the "buttons on the right side". I was irked when they moved them to the left in 10.10, and now they're moved, hidden, and permanent in 11.10?! Seriously, this needs to be fixed.

John Lea (johnlea) wrote :

Marking this bug 'invalid' in terms of design because having the window decoration on the right hand side of the window title bar is not a supported config.

Changed in unity:
status: Confirmed → Invalid
Omer Akram (om26er) on 2012-02-21
Changed in unity (Ubuntu):
status: Confirmed → Opinion
Changed in unity:
status: Invalid → Opinion
Mantas Kriaučiūnas (mantas) wrote :

Bug #1072755 (Window buttons in panel for maximized windows don't respect org.gnome.desktop.wm.preferences like normal windows do) is also related to this bugreport.

Changed in baltix:
importance: Undecided → Medium
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers