Desktop background not properly drawn on login (dual monitor)

Bug #769458 reported by Greg A
90
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

This is on a dual monitor setup (not sure if that's relevant) with a Radeon HD 3450. It's reproducible every time I restart. The image is fine on the second monitor.

I can't take a screenshot of this using gnome-screenshot because it disappears when I do. I think that anything that causes the screen to be redrawn "fixes" it. So for instance where I've moused over some launchers on the unity panel then the are where the label was displayed (next to them) is fine.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,vpswitch,move,animation,imgpng,mousepoll,grid,unitymtgrabhandles,gnomecompat,place,workarounds,wall,wobbly,expo,ezoom,staticswitcher,session,fade,scale,unityshell]
CompositorRunning: compiz
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAQrBRATFk4MiMQAQNoJh54Ls5Qo1RMmSYPUFSlSwBxT4GAAQEBAQEBAQEBAQEBMCoAmFEAKkAwcBMAeC0RAAAeAAAA/wA2NDE4MDY4UzI4WUwKAAAA/ABERUxMIDE5MDdGUAogAAAA/QA4TB9TDgAKICAgICAgACU=
Date: Sat Apr 23 12:11:37 2011
DistUpgraded: Log time: 2011-03-09 16:26:08.225547
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc RV710 [Radeon HD 4350] [1002:954f] (prog-if 00 [VGA controller])
   Subsystem: Hightech Information System Ltd. Device [1787:2271]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110127)
MachineType: Dell Inc. Dell DXP061
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=8edb1aef-0dda-4612-8fdc-5373889f01d7 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-19 (3 days ago)
dmi.bios.date: 11/22/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.5.3
dmi.board.name: 0WG855
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.5.3:bd11/22/2007:svnDellInc.:pnDellDXP061:pvr:rvnDellInc.:rn0WG855:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Dell DXP061
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Revision history for this message
Greg A (etulfetulf) wrote :
Revision history for this message
Greg A (etulfetulf) wrote :
Revision history for this message
Greg A (etulfetulf) wrote :
Revision history for this message
Octavian Damiean (mainerror) wrote :

I can confirm this. I have the exact same issue with an NVIDIA card (9800 GTX+) on a dual monitor setup. For me it is enough to just left click somewhere on the desktop to make it redraw properly.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Greg A (etulfetulf) wrote :

I tested with Ubuntu only rendering a single monitor (with the same hardware) and did not not experience this bug.

summary: - Desktop background not properly drawn on restart
+ Desktop background not properly drawn on login (dual monitor)
Revision history for this message
Octavian Damiean (mainerror) wrote :

I took a photo with my smartphone cam since every action causes a redraw.

Revision history for this message
Greg A (etulfetulf) wrote :

Thanks for the photo Octavian, it illustrates the problem very well. It looks like the wallpaper was initially rendered stretching across both screens, rather than once on each screen.

This is the same in my photos, but it's not as clear.

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Confirmed
tags: added: multimonitor
Revision history for this message
Greg A (etulfetulf) wrote :

This appears to be a natty issue that is fixed in Oneiric. Can anyone confirm that?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Yes, it is fixed in Ubuntu 11.10 for me too.

Changed in unity:
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers