no custom icon on launcher displayed for mono winforms and ogre apps

Bug #768931 reported by Julian Taylor on 2011-04-22
310
This bug affects 57 people
Affects Status Importance Assigned to Milestone
BAMF
Low
Marco Trevisan (Treviño)
Unity
Invalid
Low
Unassigned
bamf (Ubuntu)
Undecided
Unassigned
keepass2 (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

applications based on libmono-winforms2.0-cil do not display a icon on the launcher. One only sees the generic questionmark.
Also it shows three lines which indicate the number of instances when there is only one.
In the unity app place and the gnome2 menu the icon is displayed correctly.

Example applications are keepass2 (https://launchpad.net/~jtaylor/+archive/keepass), openbve and xsddiagram

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.10-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Apr 22 13:36:21 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Julian Taylor (jtaylor) wrote :

Any workaround?

Cas (calumlind) wrote :

I tried to find a workaround but none of the launchers created would associate to the mono application.

Attached is launcher screenshot.

Bilal Shahid (s9iper1) wrote :

any type of screenshot

Changed in unity (Ubuntu):
status: New → Incomplete
Cas (calumlind) wrote :

I posted a screenshot (icon is different due to Faenza)

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Julian Taylor (jtaylor) wrote :

attached screenshot with regular icons.
above is smuxi a mono app *not* based on winforms, works fine
below keepass2 a winform based mono app, not working
keepass2 icon installation should be correct (/usr/share/pixmaps + /usr/share/icon/hicolor/YYxYY)

Cas (calumlind) wrote :

Not sure if this is useful information but weirdly the icon for keepass appeared after having restarted compiz while the mono application was open. If I restart Unity it reverts to the old 'unknown' icon.

Although the icon appears correctly the launcher issues still remain.

In the newly attached screenshot, the green icon is the custom launcher I created for keepass mono application.
The green launcher can start the application but has no further functionality once keepass has started and instead the blue icon/launcher will appear for the opened mono application.
This blue launcher can be kept on the unity launcher but if keepass has been closed it will not reopen the application when clicked.

Alex Launi (alexlauni) on 2011-05-05
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low

For me, however, this bug has a higher importance than "Low". :(

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in keepass2 (Ubuntu):
status: New → Confirmed
Ari (ari-reads) wrote :

having this problem with keepass2 - official package

Dave Vree (hdave) wrote :

Am also seeing this in 11.10 with official keepass2 package. Any chance this could get bumped up in importance?

Simon Gill (somori) wrote :

I'm not as worried about the missing icon. I can live without that. What worries me as that when you right click the icon and Quit, it closes one of the Unity processes - panel, dash, DNDCollectionWindow, launcher.

I would like to confirm Simon Gill's issue, 11.10 & official package.

- Right click -> Quit causes Unity to freak out
- Keepass doesn't (always) open when the launcher icon is clicked
- Launcher icon is a grey questionmark
- Sometimes I am unable to Exit keepass, icon stays in the launcher

Ludovico (aasonykk) wrote :

+1 for this bug.

I have a grey questionmark icon and the name is "panel".

Julian Taylor (jtaylor) wrote :

also appears to affect ogre apps, see bug 950835

summary: - no custom icon on launcher displayed for mono winforms apps
+ no custom icon on launcher displayed for mono winforms and ogre apps
Kai Mast (kai-mast) wrote :

This also happens with application using libogre..

Julian Taylor (jtaylor) wrote :

this seems to be fixed in precise now, at least keepass2 is working now
can someone confirm?

Sebastien Bacher (seb128) wrote :

thanks, closing the bug then, feel free to reopen if it turns out it's not really fixed though

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
Changed in bamf:
status: New → Invalid
Changed in keepass2 (Ubuntu):
status: Confirmed → Invalid
Ludovico (aasonykk) wrote :

I installed precise 12.04 but the question mark remained.

The bug persists.

Julian Taylor (jtaylor) wrote :

indeed its still broken in unity
I was logged into unity2d and didn't notice, when back in unity the questionmark reappeard, alhtouh it only has one of those arrow things instead of three and clicking on it actually brings up keepass more reliably than before.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in bamf:
status: Invalid → Triaged
Changed in unity:
status: Confirmed → Triaged
Changed in bamf:
importance: Undecided → Low
asohangh (asohangh) wrote :

I can confirm this bug in Precise as well. My custom winforms mono app shows up a question mark on the launcher.

What is an even bigger issue is that as Simon Gill pointed out, trying to quit the application from the Unity launcher actually closes Unity itself. This is a pretty big issue in my opinion.

Kai Mast (kai-mast) wrote :

Yeah I have the same issue with Unity closing/crashing..

Alt-Tab and holding on the KeePass2 application shows 3 windows (one corresponding to the app, the second named launcher and the third one named panel).

tekstr1der (tekstr1der) wrote :

Oneiric install of keepass2 here crashes/freezes Unity completely.

1) launch keepass via dash
2) observe grey question mark icon in launcher with 3 arrows.
3) single-click said launcher
4) Unity is frozen, mouse pointer still moves, but no keyboard/mouse interaction is possible.

I switched to a virtual terminal and restarted Unity, but noticed display corruption in the tty. Many characters are replaced with seemingly random ascii non-alphabetic characters.

This is a show-stopper bug and should have a much higher Importance set.

xabier (xabier) wrote :

Equal to #22 and previous. Keepass2 crashing and affecting unity.

rod singleton (rod40cool) wrote :

#22 for me too. Keepass2, Unity under Precise

Martin Wildam (mwildam) wrote :

Earlier mentioned workaround does not work on my machine (Ubuntu 12.04 on Unity).

I have a partial workaround for the keepass2 users:
a) Look at the screens in the attachments - make sure that keepass2 is limited to a single instance and set options to minimize instead of close and to minimize to tray instead of task bar.
b) I have put keepass2 to my startup applications (using traditional Gnome menu which I have added back) - wherever that is done on the commandline feel free to use that.

No the launcher disappears after logging in to keepass2 and closing the window. Which is perfectly fine - it stays now in background and the hotkey is now working. At least you cannot accidently quit unity now during normal work and the annoying questionmark icon is gone. Before you ask: No, the icon is not displayed in the notification bar on the upper right. But using Dash to start it, brings back the existing instance.

Florian W. (florian-will) wrote :

I'm on a fresh Ubuntu 12.04 (64 bit) install.

KeePass2 works fine most of the time, I can use the launcher icon to close and focus the keepass window, and there is only 1 arrow to its left. The icon is displayed correctly as well (no question mark, it's the blue keepass icon).

The only problem is with keeping the icon on the launcher when keepass is closed (not sure what the name of that feature is in English). Clicking the icon causes it to blink a few seconds, but the window is not re-opened (while ps aux tells me the process is still alive). At the same time, using the dash to open the window works fine but creates a second, non-permanent launcher icon.

The permanent launcher icon does not work after shutting down keepass as well (with no keepass process running). Launching via dash still works in that case.

Martin Wildam (mwildam) wrote :

At this opportunity update to my experience: Since one of the last bulk of updates I can see the correct icon.
However, it does not activate the window immediately - I have to click a second time onto the launcher (when keepass was already running).

@Florian: Your problem is a different one - see https://bugs.launchpad.net/bugs/1011349 (bug #1011349)
See comment #2.
To work around this do my suggestions from #27 of this bug.

This bug looks like it is caused by mono winforms not setting the WM_CLASS X11 property.

mono winforms (or the application themselves) should call the X11 function XSetClassHint.

I've just hacked my winforms application to do this, and it fixes the issue for me.

@Tom Hindle:
Could you please add an example?

Still seeing the symptoms from #28 for KeePass 2.18 and Ubuntu 12.04 (64-bit, fresh install on a new machine). The Unity launcher is basically of no use with KeePass2; you have to use the HUD to launch it.

tags: added: quantal runnng-unity
removed: running-unity
trampster (trampster) wrote :

My custom winforms application has this same problem. unbntu 12.04 importance of this issue should not be low.

On Thu, Oct 18, 2012 at 3:41 AM, trampster <email address hidden> wrote:
> My custom winforms application has this same problem. unbntu 12.04
> importance of this issue should not be low.

I do not have this problem any more with keepass2 - maybe they just
added a .desktop file with a matching icon. mhm...

Regards, Martin.

tekstr1der (tekstr1der) wrote :

I am also no longer seeing this issue as of keepass2 (v2.20.1). Looks like the keepass folks fixed it as of v2.20

From the changelog:
* Added Mono workaround to set the WM_CLASS property.

http://keepass.info/news/n120908_2.20.html

Nathaniel W. Turner (nturner) wrote :

If keepass2 Upstream implemented a workaround 2 months ago, why is the bug is still marked invalid for keepass2? Can the keepass2 maintainer comment?

Also, it sounds like maybe the real defect is in Mono itself. Does anyone know which mono package would be appropriate to mark as affected?

Julian Taylor (jtaylor) wrote :

its invalid for keepass because its not keepass's buisness to fix it.
mono does not set the WM_CLASS property which you could consider a bug, but other desktops handle that just fine

it actually seems to be fixed in quantal, openbve works too
so we can mark it fix released

Changed in unity (Ubuntu):
status: Triaged → Fix Released

Another problem of KeePass is that is not setting the _NET_WM_PID atom, so for BAMF it's hard to find many of the informations it needs to do a correct matching.

Bamf side is currently doing the most it can, so marking this as fixed.

Changed in unity:
status: Triaged → Invalid
Changed in bamf:
status: Triaged → Fix Committed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 0.5.0
Changed in keepass2 (Ubuntu):
status: Invalid → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:bamf at revision None, scheduled for release in bamf, milestone 0.5.0

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.0+13.10.20130628-0ubuntu1

---------------
bamf (0.5.0+13.10.20130628-0ubuntu1) saucy; urgency=low

  [ Marco Trevisan (Treviño) ]
  * BamfDaemon, LibBamf: Make the BamfView's name a property, deprecated
    method+signal.
  * BamfDaemon, LibBamf: add icon property to store the BamfView icon
    and notify about its changes. New tests added.
  * BamfMatcher: ignore registered .desktop files that are in an
    autostart-folder. (LP: #1193502)
  * BamfApplication: try to use a window icon if the computed icon
    belongs to a "generic" app Added a bunch of new BamfApplication
    tests for icon. (LP: #768931, #1007383)
  * BamfFactory: remove the local_views list, we don't need that anymore
    Having them tracked on allocated_views list is enough, and fixes an
    issue as explained on bug #1193559. (LP: #1193449, #1193559)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 560
 -- Ubuntu daily release <email address hidden> Fri, 28 Jun 2013 02:02:32 +0000

Changed in bamf (Ubuntu):
status: New → Fix Released

Fix Released in Bamf BAMF 0.5.0.

Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Released → Invalid
Changed in keepass2 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers