compiz crashed with SIGSEGV in PanelView::~PanelView()

Bug #761634 reported by Piotr Paszyński on 2011-04-15
294
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Unassigned
Unity
Fix Released
High
Didier Roche
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

After start of unity.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.44-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
CheckboxSubmission: 17a30fd74b8a2944babbcfe331de3cd9
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Fri Apr 15 10:25:29 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=pl_PL:en
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f4573a9c618: shl %cl
 PC (0x7f4573a9c618) in non-executable VMA region: 0x7f4573a9b000-0x7f4573aa1000 rw-p None
 source "%cl" ok
SegvReason: executing writable VMA None
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 PanelView::~PanelView() () from /usr/lib/compiz/libunityshell.so
 PanelView::~PanelView() () from /usr/lib/compiz/libunityshell.so
 nux::Object::Destroy() () from /usr/lib/libnux-core-0.9.so.0
 nux::Object::UnReference() () from /usr/lib/libnux-core-0.9.so.0
Title: compiz crashed with SIGSEGV in PanelView::~PanelView()
UpgradeStatus: Upgraded to natty on 2011-04-01 (13 days ago)
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Piotr Paszyński (virus100) wrote :

StacktraceTop:
 main_arena () from /lib/x86_64-linux-gnu/libc.so.6
 PanelView::~PanelView (this=0x57a2d10, __in_chrg=<value optimized out>) at /build/buildd/unity-3.8.8/src/PanelView.cpp:90
 PanelView::~PanelView (this=0x57a2d10, __in_chrg=<value optimized out>) at /build/buildd/unity-3.8.8/src/PanelView.cpp:97
 nux::Object::Destroy (this=0x57a2d28) at ./Object.cpp:430
 nux::Object::UnReference (this=0x57a2d28) at ./Object.cpp:333

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Matt Zimmerman (mdz) wrote :

I got a similar crash just now after running xrandr to turn off one output (internal LCD) and turn on another (external VGA).

visibility: private → public
zeruke (oninekoze) wrote :

this happened to me after i disabled my secondary screen from within nvidia-settings and im running natty i386

Matt Zimmerman (mdz) wrote :

I filed mine as bug 761864 in case it is a separate issue

Didier Roche (didrocks) on 2011-04-15
Changed in nux:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in nux (Ubuntu):
status: New → Triaged
Changed in nux:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 3.8.10
Didier Roche (didrocks) on 2011-04-15
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
status: Triaged → Fix Committed
Changed in nux:
status: Triaged → Invalid
affects: nux (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Damiön la Bagh (kat-amsterdam) wrote :

I had this bug when I was doing the System Test and plugged and unplugged my VGA monitor to my netbook VGA port.

Dave Johnson (dave-scomple) wrote :

This bug appeared when trying to enable desktop spanning across two monitors instead of the default mirrored desktop. Possibly related is that spanning across two monitors is still not supported, all I get is scrambled video on the second display.

Compiz crashed on my Acer Aspire One (A150L) after I've unplugged my second Monitor (VGA).

Bruno Munoz (bruno-bmunoz) wrote :

Crash after connecting 2nd monitor (LCD), 1st one is internal LCD (dell latitude D620)

seems to work a little, very slowly, high cpu from compiz, and crash after a while

Victor Costan (costan) wrote :

Crashed after attempting to disconnect a secondary screen using nvidia-settings.

Scott Balneaves (sbalneav) wrote :

Same as breefru:

Connected second monitor to my Acer Aspire One D255 netbook, compiz no like. Seemed to restart on it's own. It's not using up any excessive CPU time, so it looks like it starts ok.

D (tenswiths) wrote :

This sort of crash happened to me when I was trying to get EasyStroke Gesture Recognition (available in the repos) to work with my synaptics touchpad (I'm a big fan of lost causes). One of the things I noticed just before Compiz took a dive was that the touchpad stopped responding. I haven't even tried a second monitor yet.

Didier Roche (didrocks) on 2011-04-19
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
paumarc (paumarc) wrote :

This is not solved for me

 When i switch on my second screen, everything is slow, and a strange lines appear at both screens, at the end, i'm able to see imatges at the principal screen but not at the secondary screen, at the second time that i plug the screen a bug appear

the good news are that i hadn't to reboot my computer

Alex (dupe576) wrote :

Doesn't seem to be fixed for me. Compiz crashes when I unplug my second monitor using a Core i5-2410M Processor with integrated graphics.

Same here, was reported in another Bug, but was marked as duplicate of
this one.

El mar, 19-04-2011 a las 21:45 +0000, Alex escribió:
> Doesn't seem to be fixed for me. Compiz crashes when I unplug my second
> monitor using a Core i5-2410M Processor with integrated graphics.
>

--
Joaquín Ignacio Aramendía <email address hidden>

Bruno Munoz (bruno-bmunoz) wrote :

Hello,
same for me, seems not fully solved, may be this is a graphic driver
issue.
correction seems to fix the crash (no more crash for the moment), but
graphic is extreemly slow (can see half screen refreshing, each screen
change take 2s for image updating).

compiz process stay at full cpu.

no issue at all with only internal lcd (chip intel 945GM intregrated)
came back to normal display once external display is disconnected.
Once 2nd screen connected, the sluggy refresh come back, and compiz stay
at full cpu.

the issue is reproductible 100% with 2 monitors.
no issue at all with only internal lcd display (one monitor)

Le mardi 19 avril 2011 à 19:10 +0000, paumarc a écrit :
> This is not solved for me
>
> When i switch on my second screen, everything is slow, and a strange
> lines appear at both screens, at the end, i'm able to see imatges at the
> principal screen but not at the secondary screen, at the second time
> that i plug the screen a bug appear
>
>
> the good news are that i hadn't to reboot my computer
>

Sebastien Bacher (seb128) wrote :

did you restart your session with the new version installed?

Bruno Munoz (bruno-bmunoz) wrote :

yes even total reboot
submit bug report data on bug 766941
the fix seems to have stop the crash, but the problem seems more complex, still high cpu and very sluggy reshresh (1 to 2s for each frame)

paumarc (paumarc) wrote :

same for me

 after today update and restart, i keep having problems when i connect my second screen, compiz is slow and it is not possible to visualitze anythng on them

gewralds braook (gewralds) wrote :

hola yo tenia el problema con 1 solo monitor lcd pero desde ese dia no an avido incidentes

Tom Chinery (callingwar) wrote :

I have only had this happen once, along with numerous other bugs in the new
OS. I guess upgrading from maverick is quite buggy...

2011/4/20 gewralds braook <email address hidden>

> hola yo tenia el problema con 1 solo monitor lcd pero desde ese dia no
> an avido incidentes
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/761634
>
> Title:
> compiz crashed with SIGSEGV in PanelView::~PanelView()
>
> Status in Nux:
> Fix Released
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> After start of unity.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: libnux-0.9-0 0.9.44-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> NonfreeKernelModules: nvidia wl
> Architecture: amd64
> CheckboxSubmission: 17a30fd74b8a2944babbcfe331de3cd9
> CheckboxSystem: d00f84de8a555815fa1c4660280da308
> Date: Fri Apr 15 10:25:29 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
> (20101007)
> ProcCmdline: compiz
> ProcEnviron:
> LANGUAGE=pl_PL:en
> LANG=pl_PL.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x7f4573a9c618: shl %cl
> PC (0x7f4573a9c618) in non-executable VMA region:
> 0x7f4573a9b000-0x7f4573aa1000 rw-p None
> source "%cl" ok
> SegvReason: executing writable VMA None
> Signal: 11
> SourcePackage: nux
> StacktraceTop:
> ?? () from /lib/x86_64-linux-gnu/libc.so.6
> PanelView::~PanelView() () from /usr/lib/compiz/libunityshell.so
> PanelView::~PanelView() () from /usr/lib/compiz/libunityshell.so
> nux::Object::Destroy() () from /usr/lib/libnux-core-0.9.so.0
> nux::Object::UnReference() () from /usr/lib/libnux-core-0.9.so.0
> Title: compiz crashed with SIGSEGV in PanelView::~PanelView()
> UpgradeStatus: Upgraded to natty on 2011-04-01 (13 days ago)
> UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nux/+bug/761634/+subscribe
>

Rocko (rockorequin) wrote :

I just had this happen again when I ran the command "xrandr -s 1" to switch from separate monitors to duplicated monitors.

Didier Roche (didrocks) wrote :

Thanks everyone for the feedback.

However, disconnecting the monitor can lead to a crash (depends on hardware, nvidia here doesn't handle multi-monitor the same way: no xrandr possible) but it can be a different bug.

If you experience so, please open a bug with the crash file in /var/crash/*compiz*
(like ubuntu-bug -c /var/crash/*compiz*). Choose the "full report" and not the light one so that we can have enough information for debugging those please.

Thanks :)

Changed in nux (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/761634

tags: added: laptop-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers