compiz crashed with SIGSEGV in PlacesResultsController::Clear()

Bug #761211 reported by Michael Porco on 2011-04-14
98
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Mirco Müller
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

I attempted to change my theme to equinox dawn theme, however the application lens had trouble loading the faenza app icons. I switched back to ambiance default and the the crash occurred shortly after changing back.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.8.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Thu Apr 14 18:27:59 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x1ea9cab <_ZN23PlacesResultsController5ClearEv+43>: mov (%eax),%edx
 PC (0x01ea9cab) ok
 source "(%eax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 PlacesResultsController::Clear() () from /usr/lib/compiz/libunityshell.so
 PlacesView::SetActiveEntry(PlaceEntry*, unsigned int, char const*, bool) () from /usr/lib/compiz/libunityshell.so
 PlacesController::OnViewShowHideFrame(PlacesController*) () from /usr/lib/compiz/libunityshell.so
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGSEGV in PlacesResultsController::Clear()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Michael Porco (mkporco) wrote :

StacktraceTop:
 PlacesResultsController::Clear() () from /usr/lib/compiz/libunityshell.so
 PlacesView::SetActiveEntry(PlaceEntry*, unsigned int, char const*, bool) () from /usr/lib/compiz/libunityshell.so
 PlacesController::OnViewShowHideFrame(PlacesController*) () from /usr/lib/compiz/libunityshell.so
 g_timeout_dispatch (source=0xa1c42b8, callback=0x1e46b50 <PlacesController::OnViewShowHideFrame(PlacesController*)>, user_data=0x9e9c5a0) at /build/buildd/glib2.0-2.28.5/./glib/gmain.c:3882
 g_main_dispatch (context=0x955bf48) at /build/buildd/glib2.0-2.28.5/./glib/gmain.c:2440

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Alan Musnikow (am) wrote :

This occurred immediately after clicking on banshee to start it, immediately after logging in after turning on the laptop.

Didier Roche (didrocks) on 2011-04-18
Changed in unity:
milestone: none → 3.8.10
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Ralph Taylor (djnrrd) wrote :

This happened to me after attempting to load a suggested application (eclipse) from the unity launcher in the software centre

Mirco Müller (macslow) on 2011-04-18
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-04-19
Changed in unity (Ubuntu):
status: Triaged → In Progress
Gord Allott (gordallott) on 2011-04-19
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-04-19
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.10-0ubuntu1

---------------
unity (3.8.10-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Application windows can sometimes fail to display and will mask regions
      of the screen (LP: #709461)
    - Launcher appears _under_ application windows (LP: #743834)
    - Unity Launcher Temporarily Appears Broken at Login (LP: #756951)
    - compiz crashed with signal 7 in g_file_get_uri() (LP: #728319)
    - Only with few windows (and one maximized) or Dodge active window - When
      re-focusing on maximised window Unity launcher does not hide
      (LP: #734681)
    - UIFe: Unity Dash button does not give adequate feedback (LP: #748676)
    - Focus problem with Thunderbird (LP: #753951)
    - compiz crashed with SIGSEGV in PrivateWindow::updateStartupId()
      (LP: #759363)
    - unity places don't start up on login. (LP: #761225)
    - unity crashes when emptying trash twice (LP: #761643)
    - compiz crashed with SIGSEGV in PlacesResultsController::Clear()
      (LP: #761211)
    - compiz crashed with SIGSEGV in PanelView::~PanelView() (LP: #761634)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::SetIconName()
      (LP: #763560)
    - compiz crashed with SIGSEGV in PlacesView::ConnectPlaces() (LP: #761942)
    - Intellihide stuck with in x=0 on the bfb (LP: #764643)
    - compiz crashed with SIGSEGV in PlacesView::OnResizeFrame() (LP: #763800)
    - unity crashed with GError in reset_unity_compiz_profile(): Failed to
      contact configuration server; the most common cause is a missing or
      misconfigured D-Bus session bus daemon. See
      http://projects.gnome.org/gconf/ for information. (Details - 1: Failed
      to get connection to session: Command line `dbus-launch
      --autolaunch=f0af37ac055f6f348acd417f00000008 --binary-syntax --close-
      stderr' exited with non-zero exit status 1: No protocol
      specified\nAutolaunch error: X11 initialization failed.\n) (LP: #753528)
    - Chromium fullscreen + Alt-TAB confuses the launcher (LP: #757434)
    - Cannot click on left-most indicator on panel if a non-indicator icon
      appears (LP: #761409)
    - vim.gnome window is invisible (LP: #719001)
    - Trash/ws switcher icon in unity resets to default icon theme on the
      event of a deletion or emptying the trash or after an upgrade
      (LP: #761289)
    - Incorrect keynav hilight/opened Quicklist without any request
      (LP: #764730)
    - indicator font does not update when changing font in Appearance
      Preferences. (LP: #759886)
    - In dash search filter drop box, black text is on a black background when
      item is selected (LP: #761201)
 -- Didier Roche <email address hidden> Tue, 19 Apr 2011 19:30:20 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers