systray icons still visible on each desktop in expo mode

Bug #759129 reported by PEIGNOT Kévin on 2011-04-12
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Sam Spilsbury
unity (Ubuntu)
Low
Sam Spilsbury

Bug Description

Binary package hint: unity

When I use the Unity function wall (to see every desktop on the screen), the top panel is always on the top of the screen, but the Skype icon, and the panel shadow are displayed on each desktop. There should be with the top panel.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Tue Apr 12 21:52:55 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110408)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

PEIGNOT Kévin (kpeignot) wrote :

I can confirm that.

Omer Akram (om26er) wrote :
summary: - Skype icon still visible on each desktop in expo mode
+ systray icons still visible on each desktop in expo mode
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Medium → Low
assignee: nobody → Neil J. Patel (njpatel)
Alex Launi (alexlauni) on 2011-04-22
Changed in unity:
importance: Undecided → Low
Vladimir Darak (vladimir-darak) wrote :

I can confirm that too. Except skype icon it certainly happens with dropbox and vlc icon.

Adnane Belmadiaf (daker) wrote :

Yes this happens with xchat/radiotray.

Omer Akram (om26er) on 2011-09-04
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
milestone: none → 4.14.0
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → Sam Spilsbury (smspillaz)
Rocko (rockorequin) wrote :

Could the fix for this have broken the systray completely? I no longer see any systray icons at all (I have logged Bug #842337 for it).

First wait for Unity 4.14.0 which might come out tomorrow or the day
after and let us know if the issue is gone.

Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers