compiz assert failure: *** glibc detected *** compiz: free(): invalid pointer: 0xbfa9f5cc ***

Bug #759102 reported by Gediminas Paulauskas on 2011-04-12
372
This bug affects 82 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Was simply browsing Facebook, many other Chrome tabs open. Nothing else crashed, compiz was restarted.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.8.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
AssertionMessage: *** glibc detected *** compiz: free(): invalid pointer: 0xbfa9f5cc ***
CrashCounter: 1
Date: Tue Apr 12 22:24:48 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=lt:en_GB:en
 PATH=(custom, user)
 LANG=lt_LT.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: unity
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: compiz assert failure: *** glibc detected *** compiz: free(): invalid pointer: 0xbfa9f5cc ***
UpgradeStatus: Upgraded to natty on 2011-04-06 (6 days ago)
UserGroups: adm admin audio cdrom dialout dip fuse lpadmin netdev plugdev sambashare scanner schooltool staff video

Gediminas Paulauskas (menesis) wrote :
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Invalid
tags: added: iso-testing
FabrizioOrsini (fabrizioorsini) wrote :

The full-screen applications that are minimized makes desktop freeze. I tried it with LibreOffice Calc, same effect. All full-screen applications cause this problem.

Pedro Villavicencio (pedro) wrote :

Could you open a new bug if you have a similar issue? this is a memory corruption one, so please open a new one. Thanks.

tomasz kubacki (tomasz-kubacki) wrote :

i was dragging link in chromium browser when compiz died

Stitch (itddilu) wrote :

Happens every time I close program Darktable Photo Workflow Software

Senol Ozkan (snlzkn-gmail) wrote :

I was using LabVIEW and compiz just crashed when I tried to closed one of the open windows.

ameos (ameos) wrote :

My package manager (synaptic) just ended installing some packages. Firefox was maximized, but currently hidden. I have to press OK button on synaptic dialog showing end of install process and everything freezed for a while, then compiz restarted

jhellen (jukka-hellen) wrote :

I experienced this same bug but my video driver is i915

James Peters (reteptj73-) wrote :

It occurred when I shut Firefox down then tried to open it up afterwards.

Martin Wildam (mwildam) wrote :

Same issue here. Just a few seconds after logon while emptying trash.
Don't think of memory corruption - have other distros running well on this machine.

sabby7890 (tsalacinski) wrote :

This bug doesn't mean that the physical memory is corrupted. It just means that Compiz allocated some memory and had a pointer to it, but when he tried to release this memory, pointer pointed to region of memory that is invalid or has already been freed (not allocated anymore). It's clearly a bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers