Launching gnome-terminal from unity starts me in /

Bug #758819 reported by Jonathan Carter on 2011-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Launching gnome-terminal from Unity (2d and 3d) results in my working directory being the / directory.

$HOME is set to my home directory correctly.

This behaviour is not present in the classic desktop

tags: added: iso-testing
Paul Sladen (sladen) wrote :

I have _not_ managed to reproduce this. Is it specific to the LiveCD?

Changed in unity (Ubuntu):
status: New → Incomplete
Jonathan Carter (jonathan) wrote :

It's not just on the livecd, it happened on an installed session too, and ~stgraber had the same effect when testing under WebLive.

I will re-test tomorrow morning and will try to find out what you need to reproduce. For me it was quite easy to do so though.

Brian Murray (brian-murray) wrote :

I wonder if this is somehow related to bug 760140.

Tobin Davis (gruemaster) wrote :

I doubt that this is related to the sudo issue, unless gnome-terminal and sudo are sharing an environment at launch. Also, it only happens when launched from unity/unity-2d places/launcher and not in Classic Desktop.

This bug was actually originally filed and marked as fix-released. See bug 736471.
For unity-2d, it is tracked under bug 684471.

Changed in unity (Ubuntu):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Didier Roche (didrocks) wrote :

This is not anymore the case.

Changed in unity:
status: New → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers